Теория систем автоматического регулирования

681.5(07)
К493 		VisSim.nm.ru & VisSim.com

Н. В. Клиначёв

ТЕОРИЯ СИСТЕМ АВТОМАТИЧЕСКОГО
РЕГУЛИРОВАНИЯ

Учебно-методический комплекс

Наша работа во тьме -
Мы делаем, что умеем,
Мы отдаем, что имеем -
Наша работа - во тьме.

Сомнения стали страстью,
А страсть стала судьбой.
Все остальное - искусство
В безумии быть собой.


УДК 681.5(07) K493

УДК 681.5.01(076)
K493

Клиначёв Н. В. Теория систем автоматического регулирования и управления: Учебно-методический комплекс. - Offline версия 1.7. - Челябинск, 2002. - 543 файла, ил.

Учебно-методический комплекс рекомендуется в качестве базового ресурса для организации учебного процесса на кафедрах САУ вузов. Комплекс включает типовую рабочую программу, конспект лекций адаптированный к компьютерным проекторам, комплект лабораторных работ, тесты, и др. документы. На лекциях, для демонстрации методов теории, преподавателям рекомендуется использовать программу VisSim фирмы Visual Solutions Inc. Комплекс не содержит информацию для служебного пользования (билеты к экзамену, и пр.), тем самым предусмотрена передача комплекса студентам.

Ил. 314, учебных моделей 87, список лит. - 12 назв.

© Н.В. Клиначёв, 2000-2002.

Предисловие

Об авторстве

В любой момент авторство Клиначёва Н. В. на данный учебно-методический комплекс (далее цифровой документ) может быть подтверждено. Дайджест данного файла (для цифрового документа это эквивалент отпечатка пальца) зашифрован закрытым ключом Клиначёва Н. В. (т.е. файл подписан). К электронной подписи Клиначёва посредник добавил временную метку и зашифровал пакет своим закрытым ключом. Для подтверждения авторства необходимо самостоятельно вычислить дайджест имеющегося у вас файла и сравнить его с тем, что зашифрован. Расшифровать дайджест можно двумя публичными ключами - посредника и Клиначёва.

Входящий в данный учебно-методический комплекс конспект лекций по своему содержимому наиболее близок к учебнику В. А. Бесекерского, Е. П. Попова "Теория систем автоматического регулирования".

Правом автора Клиначёв Н. В. объявил данный цифровой документ "Свободной информацией". Т.е. пользователям данного документа доступны четыре вида свободы:

  1. Свобода запускать документ в любых целях.
  2. Свобода изучать работу документа и адаптировать его собственным нуждам.
  3. Свобода распространять копии.
  4. Свобода улучшать документ и публиковать свободные версии.

Однако "Свободная информация" - это не есть "бесплатное пиво". Дабы Вас, как пользователя данного документа нельзя было уличить в воровстве, Вы обязаны соблюдать условия лицензии на свободную документацию и, в зависимости от вашего социального положения, обязаны выполнить следующие действия:

  • Студент обязан познакомить своего преподавателя с данным документом и сетевыми ресурсами о программе VisSim. В случае если преподаватель не использует в курсе программ для визуального математического моделирования, студент обязан спросить преподавателя, в какой части курса он, за свои деньги, будет ознакомлен с современным инструментарием специалиста в области проектирования систем управления, например, с программой VisSim.
  • До тех пор пока учебное заведение, в котором работает преподаватель, будет пользоваться "Бесплатной Академической Программой" фирмы Visual Solutions Inc., и не приобретёт у нее полную версию программы VisSim, преподаватель обязан каждые пол года брать счет у фирмы и поднимать вопрос о приобретении программы как на уровне кафедры и факультета, так и на уровне проректора по учебной работе.

О версиях программы VisSim

На сайте фирмы Visual Solutions Inc. Вы можете найти демонстрационные версии пакета VisSim:

  • VisSim\Analyze - базовая версия, включающая библиотеку частотного анализа.
  • VisSim\TI-C2000 Rapid Prototyper - версия для электроприводчиков (включает моторы, регуляторы на ЦПС (DSP) и т.д.).
  • VisSim\Comm - версия для связистов (включает источники, шифраторы, модуляторы, каналы связи, демодуляторы, дешифраторы, фильтры и т.д.).
  • VisSim\SigPro - версия для специалистов работающих с сигналами аудио диапазона.
  • VisSim\ModelWizard - дополнительный инструментарий, не включающий VisSim, нужный специалистам по идентификации объектов по историческим данным (по переходным процессам).

Только одна демо-версия VisSim\Analyze позволяет полностью изучить модели входящие в учебно-методический комплекс, поскольку остальные не имеют требуемой библиотеки частотного анализа. Уточнить ее URL можно по электронной почте в отделе работы с клиентами фирмы Visual Solutions Inc. Все демо-версии полнофункционально работают 60 дней. После 60 дней демо-версии перестают сохранять рабочие файлы, а библиотека частотного анализа отключается (сохранение учебных моделей не предполагается).

Преподавателю вуза рекомендуется получить по "Бесплатной Академической Программе" у фирмы Visual Solutions Inc. версию VisSim FAP 3.0, в которой расширение VisSim/Analyze имеется. Фирма Visual Solutions Inc. готова поставить русскоязычным вузам платную, полную, русифицированную версию программы.

Памятка по эксплуатации

  1. Материала в теоретическом разделе не достаточно для освоения дисциплины. Его объём специально ограничен. Раскрытие сути отдельных аспектов теории входит в обязанность лектора. При самообучении студент должен дополнительно пользоваться учебниками.
  2. Лектору, при появлении необходимости возвращения к прочитанному материалу, рекомендуется запускать копию пособия, и переключатся между окнами.
  3. Для покадрового изучения рисунков с анимацией необходимо пользоваться кнопками "Стоп" и "Обновить" в инструментальной панели окна документа.
  4. Рекомендуемое разрешение проекционной аппаратуры для визуализации на лекциях любого раздела документа - 800x600x256. Однако оформление документа не искажается и при видеорежиме 640x480x16.
  5. При работе с графическим разрешением 640x480 рекомендуется скрыть панель оглавления, при этом сохраняется возможность навигации по документу посредствам гиперссылок.
  6. При работе с проекционной аппаратурой, можно увеличить шрифт во всем документе. Закройте документ. Запустите браузер MSIE. Увеличьте шрифт по умолчанию с помощью кнопки в его инструментальной панели. Закройте браузер MSIE. Вернитесь к документу. При необходимости более существенного изменения оформления документа составьте свою каскадную таблицу стилей и подключите ее к браузеру MSIE (Сервис > Свойства обозревателя > Общие > Оформление).
  7. Замечено, что некоторые антивирусные программы-мониторы блокируют распаковку рабочих файлов моделирующих программам из данного пособия. Измените их соответствующие настройки. Пособие распространяется с электронной подписью сделанной автором (tau_knv.chm.sig - подпись, KNV.asc - публичный ключ Клиначёва Н.В.). Используя программу PGP, вы можете убедиться, что при распространении данный файл ни кем не был изменен.

Технические аспекты

Учебно-методический комплекс выполнен в соответствии со стандартом Windows-HTML-справки. Он представляет собой один файл, в котором заархивированы html-страницы, рисунки и необходимые скрипты. Файл пособия автоматически распознается и запускается операционной системой Windows 98 (NT, 2000), точнее браузером MSIE версии не ниже 4.0. Пользователям Windows 95 (NT) дополнительно следует установить Windows-HTML-справку. Для чего следует найти на сайте фирмы Microsoft файл hhupd.exe (733 KB). Там же, или в секторе "download" сайта фирмы Microsoft, вы можете скачать программу HTML Help Workshop (файл htmlhelp.exe (4 MB)). Используя ее, Вы можете декомпилировать пособие для запуска в браузере Netscape или для создания собственного на основе этого образца. Программа HTML Help Workshop также содержит утилиту для создания gif-файлов с изображениями необходимых вам фрагментов экрана. Для корректной цветопередачи при создании gif-файлов активируйте цветовое разрешение дисплея в 256 цветов. Пособие так же полностью функционально и запускается браузером MSIE, если в адресной строке набрать: mk:@MSITStore:C:\tau_knv.chm::/index.htm - где C:\ - путь к файлу tau_knv.chm.

Сведения об источнике обновленных версий документа

Обновленные версии данного цифрового документа доступны на сайте "VisSim в России". Если при загрузке с сайта возникают технические затруднения, то для их решения можно связаться с автором (адрес электронной почты: klinacherv_nv@mail.ru). При возможных изменениях в адресах рекомендуется воспользоваться поисковыми системами, используя ключевые слова: VisSim, симуляция движения, моделирование, Nikolay Klinachyov.

Регистрация документа на Вашем компьютере

Если Вы часто пользуетесь этим документом, то постоянная активация счетчика статистики в документе будет мешать вам. Вы можете получить у автора пароль, для деактивации счетчика на полгода. Заполните и отправьте форму:

ФИО: | *
Должность: |
Научное звание: |
Организация (вуз): | *
Город: | *
Область: | *
Укажите сайт, откуда вы скачали этот документ:
http:// |
Какими программами для моделирования
вы пользуетесь? |
Сообщать вам об обновлениях?

Если пароль получен вами, то введите его в эту строку:

Срок действия пароля определен периодом публикации новой версии документа. Если срок истек, и счетчики вновь начали работать, то рекомендуется обновить версию документа. Так же допустимо отключить счетчики повторным вводом пароля на очередные полгода. Клиначёв Николай Васильевич


Оглавление лекций Клиначёва по ТАУ

Тематический план лекционных занятий дисциплины
"Теория систем автоматического регулирования"

Введение. Классификация САР
1. Составление исходных ДУ САР
2. Описание САР в частотном домене
3. Типовые динамические звенья
4. Принципы и законы регулирования
5. Устойчивость САР
6. Оценка качества регулирования
7. Повышение точности САР
8. Коррекция САР
9. Синтез САР
10. Системы с переменными параметрами
11. Системы с запаздыванием
12. Системы импульсные
13. Системы цифровые
Литература


Введение в ТАУ

Введение

Мир технических систем разнообразен. Однако математика и физика выявили простые параллели в этом сложном мире. Можно выделить ряд энергетических доменов, которым принадлежат те или другие системы или их модули. Это электрический, магнитный, термальный, гидравлический, акустический, механический и ротационный домены. Так же существуют два фундаментальных постулата. Первый постулат гласит, что материя не может появиться ни откуда и не может исчезнуть в никуда. Второй постулат утверждает то же самое в отношении энергии. Эти постулаты имеют частные формулировки для каждого энергетического домена. Например, для электрического домена это первый и второй законы Кирхгофа. Каждый из энергетических доменов характеризуется двумя физическими величинами первого и второго рода. В случае электрического домена - это электрические ток и напряжение соответственно. Эти парные физические величины, в каждом энергетическом домене, связаны между собой законом Ома в соответствующей формулировке (существуют: электрическое, магнитное, термальное, гидравлическое, акустическое, механическое и ротационное сопротивления). Так же следует отметить, что произведение физических величин первого и второго рода всегда есть мощность.

Представленная система параллелей позволяет понять, что математическое описание процессов движения координат систем принадлежащих разным энергетическим доменам подобно, и может быть предметом изучения одной науки, которая называется "Теория систем автоматического регулирования". Более того, в последние годы, приобретен успешный опыт применения методов этой теории при решении задач управления в экономических, финансовых и других нетехнических системах.

Классификация систем автоматического регулирования

Классификация систем автоматического регулирования

Классификация по характеру изменения величин:

  1. Системы непрерывного действия
  2. Системы импульсного действия (AM, ФМ, ЧМ, ШИМ, ЧИМ, ...)
  3. Системы дискретного действия (01001011110101100010101)
  4. Системы релейного действия

Классификация по математическим признакам:

  1. Линейные системы
  2. Нелинейные системы
  3. Существенно нелинейные

Классификация по способу настройки:

  1. Не адаптивные системы
  2. Адаптивные системы
    • Системы с переменной структурой
    • Системы с самонастройкой программы
    • Системы с самонастройкой параметров
    • Системы с самонастройкой структуры

Классификация по типу ошибки в статике:

  1. Статические САУ
  2. Астатические САУ

Классификация по алгоритмам функционирования (по назначению):

  1. Системы стабилизации
  2. Системы слежения
  3. Системы программного управления
  4. Системы телеуправления
  5. Системы самонаведения (снаряда), сопровождения (орудия), автопилотирования
  6. Системы компенсационных измерений
  7. ...


Составление исходных дифференциальных уравнений САР

Два подхода к получению исходных дифференциальных уравнений систем.
Истинные и ложные модели

Если поставлена задача составления исходных ДУ САР, то возможны две ситуации. Либо детальная декомпозиция системы на модули и отдельные звенья возможна, либо нет.

Если декомпозиция возможна, то, опираясь на постулаты о сохранении материи и энергии (для соответствующего энергетического домена) и на закон Ома (в соответствующей формулировке), приступают к составлению исходных ДУ САР, т.е. к созданию истинной модели системы. Истинной будем называть такую модель или такое математическое описание, о которых известно, что они детально соответствуют физической природе системы.

Если декомпозиция на модули и звенья для системы невозможна, то, не имея детальной информации о ее физической природе, можно получить лишь ложную модель или ложное математическое описание, которые, однако, позволят исследовать систему и получить адекватные результаты. В этом случае совокупность исходных ДУ САР получают через частотный домен, путем экспериментального снятия частотных характеристик.

Для физической системы порядок системы ДУ ее истинной модели обычно в десять и более раз выше порядка системы ДУ ее ложной модели (например, для моделей ОУ). Тем обусловлена широкая популярность ложных моделей, и типовых звеньев, как структурных элементов для их создания.

Общая форма записи систем ДУ

В целях формализации процесса составления исходных ДУ систем используют такие методы, как "Метод контурных токов", "Метод узловых потенциалов" и их аналоги, имеющиеся во всех энергетических доменах. В результате их применения получается единая система:

(1)

a11(p) x1 + a12(p) x2 + ... + a1k(p) xk = f1(t)
a21(p) x1 + a22(p) x2 + ... + a2k(p) xk = f2(t)
...
ak1(p) x1 + ak2(p) x2 + ... + akk(p) xk = fk(t)

где:

  • x1, x2, ..., xk - обобщенные координаты системы, в том числе (для САР) ошибка - x(t) и регулируемая величина - y(t);
  • f1(t), f2(t), ..., fk(t) - внешние координаты - задающие g(t) и возмущающие f(t) воздействия.

Для удобства и формализации решений систему уравнений (1) могут представить в одной из пяти стандартных форм:

  1. в форме Коши;
  2. в пространстве состояний;
  3. решенную относительно регулируемой величины - y(t);
  4. решенную относительно ошибки - x(t);
  5. в виде передаточных функций - W(p), F(p), F x(p).

Форма Коши

Форма Коши
Матричная форма записи системы ДУ решенных исключительно относительно первой производной координат САР.

Структура блок-схемы решающая систему ДУ представленную в форме Коши

Изображенная на рисунке блок-схема позволяет решить систему ДУ представленную в форме Коши:

(2)

где:

  • x1, x2, x3 - собственные координаты системы - ошибка системы x(t), воздействие на объект u(t), выходная координата - y(t), ...;
  • a11, ... , a33 - постоянные коэффициенты (если система не является зависимой от параметра) - суммы и произведения постоянных времени Tj, коэффициентов усиления Kn;
  • f1, f2, f3 - воздействия на систему - сигнал задания g(t), помехи fj(t).

О форме Коши:

  • Применяется в теории управления не часто.
  • Удобна, если для расчетов использовать классические математические пакеты: MathCAD, MATLAB, Mathematica, Maple, Derive.
  • Используется при построении аналоговых вычислительных моделей матричного типа (например, моделей на операционных усилителях).
  • Уравнения могут быть решены относительно любой из фазовых координат xi.

Пространство состояний

Пространство состояний (ABCD-форма)
Матричная форма записи системы ДУ САР адаптированная для теории управления путем выделения из формы Коши алгебраических уравнений связывающих внутренние координаты САР с выходной(ыми). Применяется для описания САР большого порядка, как правило, с несколькими входами / выходами и с перекрестными связями.

Структура блок-схемы решающая систему ДУ представленную в форме "Пространства состояний"

Изображенная на рисунке блок-схема позволяет решить систему ДУ представленную в форме "Пространства состояний":

(3)

u' = A u + B x
y = C u + D x

где:

  • x - вектор входных переменных;
  • y - вектор выходных переменных;
  • u - вектор переменных состояния (фазовых координат системы);
  • A - матрица коэффициентов системы;
  • B - матрица входных коэффициентов (матрица управления);
  • C - матрица выходных коэффициентов;
  • D - матрица коэффициентов пропорциональных каналов (матрица компенсации).

О форме "Пространство состояний":

  • Это вторая по частоте применений форма записи ДУ в ТАУ. Применяется реже, чем в 5% случаев.
  • Признана стандартом для программ математического моделирования VisSim, Simulink, и т.д., однако в большинстве случаев реализована в SISO-форме (с одним входом и одним выходом). Моделирующие программы для выполнения анализа (символьного или частотного) сводят любую модель пользователя к пространству состояний, заполняя в ходе первых шагов симуляции коэффициенты ABCD-матриц.
  • Как правило, используется для построения моделей тех больших не поддающихся модуляризации, но не сложных систем, описание которых оптимально в матричной форме (таких мало). Для записи уравнений используются такие методы как: "Метод контурных токов", "Метод узловых потенциалов", - а так же их эквиваленты для других энергетических доменов (гидравлического, теплового, механического, ...).
  • Матричное описание строго формализовано, и не требует понимания физической природы системы. Так же структура модели в "пространстве состояний" не позволяет разобраться во внутренней природе системы. Если эта форма записи ДУ применена обосновано, то модель, скорее всего, будет истинной.

ДУ решенное относительно регулируемой величины y(t) - уравнение движения

Система ДУ (1) может быть преобразована к одному уравнению путем исключения промежуточных координат (обычно выходную координату выражают через координату задания):

.

Результатом подобного преобразования является уравнение движения системы:

(4)

D(p) y(t) = R(p) g(t) - N(p) f(t) ,

где:

  • D(p) = a0pn + a1pn-1 + ... + an-1p + an - характеристический полином;
  • R(p) = D(p) - Q(p) = b0pm + b1pm-1 + ... + bm-1p + bm - коэффициенты этого полинома определяют влияние задающего воздействия g(t) на ошибку x(t), причем его степень меньше степени характеристического полинома, т.е. m<n;
  • N(p) = d0pk + d1pk-1 + ... + dk-1p + dk - коэффициенты полинома определяют влияние помехи f(t) на ошибку x(t).

ДУ решенное относительно ошибки x(t) - уравнение ошибки

Если система ДУ (1) решается относительно ошибки системы, то получается уравнение ошибки замкнутой системы:

(5)

D(p) x(t) = Q(p) g(t) + N(p) f(t)

где:

  • D(p) = a0pn + a1pn-1 + ... + an-1p + an - характеристический полином;
  • Q(p) = c0pn + c1pn-1 + ... + cn-1p + cn - коэффициенты полинома определяют влияние задающего воздействия g(t) на ошибку x(t);
  • N(p) = d0pk + d1pk-1 + ... + dk-1p + dk - коэффициенты полинома определяют влияние помехи f(t) на ошибку x(t).

Передаточные функции САР

Передаточная функция
Функция, связывающая один входной и один выходной сигналы САР. Является формой записи системы ДУ САР решённой относительно требуемой выходной координаты. Обычно ПФ записывается не для временного домена, а для домена Лапласа, связывая в этом варианте не сигналы (т.е. не функции времени), а их изображения.

ПФ-ии получают из ДУ решенного относительно требуемой координаты системы (уравнение (4) или (5)). Для чего правую часть уравнения делят на характеристический полином D(p). Отношения полиномов в правой части при возмущающих воздействиях и есть ПФ-ии.

Типовая структура замкнутой САР

Для типовой структурной схемы замкнутой САР различают 3 основные ПФ, применяемые для исследований:

  1. W(p) = y(t)/x(t) Ч Wос(p) = Wрег(p) Wо(p) Wос(p) - ПФ разомкнутой системы;
  2. F(p) = y(t)/g(t) - ПФ замкнутой системы;
  3. F x(p) = x(t)/g(t) - ПФ замкнутой системы по ошибке.

Запишем по структурной схеме уравнение движения для разомкнутой системы:

Уравнение движения для разомкнутой системы.

где: Wпрк(p) - ПФ прямого канала системы.

Замкнем систему с помощью уравнения замыкания:

Уравнение замыкания.

Тогда совместное решение даст уравнение движения замкнутой системы:

Уравнение движения замкнутой системы

и уравнение ошибки замкнутой системы:

Уравнение ошибки замкнутой системы.

При отсутствии помехи f (t) выходная величина связана с задающим воздействием ПФ замкнутой системы:

Передаточная функция замкнутой системы .

А ошибка - с задающим воздействием ПФ замкнутой системы по ошибке:

Передаточная функция замкнутой системы по ошибке .

При этом:

Другие связывающие отношения

Разделим уравнение движения на уравнение ошибки, считая, что f(t)=0 и Wос(p)=1:

y(t) / x(t) = R(p) / Q(p) , => W(p) = R(p) / Q(p) .

В соответствии с теми же уравнениями и уравнением замыкания характеристический полином D(p) = R(p) + Q(p). Добавим 1 к W(p):

1 + W(p) = Q(p) / Q(p) + R(p) / Q(p) = D(p) / Q(p) .

При исследованиях характеристический полином приравнивают к нулю, т.е. вместо него можно использовать W(p):

1 + W(p) = 0 , - характеристическое уравнение.

А так же:

W(p) = [D(p) - Q(p)] / Q(p) = D(p)/Q(p) - 1 = R(p) / [D(p) - R(p)] .

и

W(p) = F(p) / [1 - F(p)] , W(p) = [1 - Fx(p)] / Fx(p) .

Линеаризация ДУ САР

Достаточно часто встречаются звенья, имеющие нелинейную зависимость между входной и выходной координатами. Если для малых отклонений от установившегося режима нелинейность несущественна, то в этом случае до составления исходных ДУ САР (1), ..., (5). Выполняют процедуру линеаризации.

Суть линеаризации

Представление сигналов на входах и выходах САР для решения задачи линеаризации

  1. Пусть нелинейное динамическое уравнение звена имеет вид:

    F(x1, x2, x2', y, y', y'', y''') = j( f, f ') .

  2. Тогда уравнение установившегося состояния, всилу равенства нулю всех производных, имеет вид:

    Fo(x1o, x2o, 0, yo, 0, 0, 0) = j( f o, 0) .

  3. Перейдем к уравнению динамики для отклонений, выполнив подстановки:

    x1 = x1o+D x1(t), x2 = x2o+D x2(t), x2' = D x2'(t),
    y = yo+D y(t), y' = D y'(t), y'' = D y''(t), y''' = D y'''(t);

    и разложив функцию F в ряд:

    .

  4. Завершая линеаризацию, вычтем из левой и правой части уравнение установившегося состояния:

    (*)

    Линеаризованное уравнение модуля системы.

Особенности линеаризованного уравнения

  1. Оно является приближенным - отброшены члены высшего порядка малости.
  2. Неизвестными функциями являются не полные величины, а их отклонения D... от установившихся значений.
  3. Уравнение является линейным относительно отклонений D..., при этом масштабирующие коэффициенты (частные производные) могут быть постоянными или переменными во времени.
  4. Внешнее воздействие линеаризации не подлежит.

Геометрическая трактовка линеаризации

Рабочие файлы: [de_lin.vsm]

Запись линеаризованных уравнений в стандартных для ТАУ формах

Представим линеаризованное уравнение (*) в форме уравнения движения и в виде ПФ.

Уравнение движения предполагает: а) выходную величину и ее производные в левой части уравнения, а входную и все остальные члены - в правой; б) так же, принято, чтобы сама выходная величина входила в уравнение с коэффициентом единица. Чтобы привести линеаризованное уравнение (*) к такому виду введем обозначения:

тогда:

T33D y''' + T22D y'' + T1D y' + D y = k1D x1 + k2D x2 + k3D x'2 + k4 f1 .

Знак D обычно опускают и записывают уравнение в символьном виде:

(**)

(T33 p3 + T22 p2 + T1 p + 1) y = k1D x1 + (k2 + k3 p) x2 + k4 f1 ,

где:

T3, T2, T1 - постоянные времени;
k4, k3, k2, k1 - коэффициенты усиления;
p=d.../dt - оператор дифференцирования.

Для вывода ПФ решим уравнение движения (**) относительно выходной величины:

y = W1(p) D x1 + W2(p) x2 + Wf (p) f1 ,

Более строго передаточные функции определяются через изображения Лапласа или Карсона-Хевисайда, как отношение изображений выходной и входной величин: Пример отображения структурной блок-схемы модуля системы

.

Запись ПФ для переменных во времени величин и для их изображений совпадает до оператора. В первом случае ПФ зависит от оператора дифференцирования p=d.../dt. Во втором случае - от оператора Лапласа s=c+j w.


Описание САР в частотном домене

Частотная передаточная функция

Если на вход любой системы подать сигнал синусоидальной формы:

x(t) = Xm cos(w t+j) = Xm e j w t .

Очевидно, что выходной сигнал будет иметь ту же форму:

y(t) = Ym cos(w t+j) = Ym e j(w t+j) .

Зависимость же между амплитудами и фазами выходного и входного сигналов определяет ДУ движения системы. Возмем произвольное, считая помеху f(t) равной нулю:

(T22 p2 + T1 p + 1) y(t) = (k1 + k2 p) x(t) .

Подставим сигналы в уравнение движения:

T22(j w)2 Ym e j(w t+j) + T1(j w) Ym e j(w t+j) + Ym e j(w t+j) = k1 Xm e j w t + k2(j w) Xm e j w t .

Найдем отношение выходного сигнала ко входному:

Частотная передаточная функция.

Заметим. Если вместо подстановки сигналов записать ДУ движения системы для домена Лапласа и вновь найти отношение выходного сигнала к входному, то полученая, в ходе этого преобразования, ПФ совпадет с частотной ПФ.

Резюме 1: Частотная передаточная функция получается из обычной заменой оператора Лапласа s на комплексную частоту j w, т.е. в результате перехода от изображения Лапласа к изображению Фурье.

Резюме 2: ДУ движения системы связывает входной и выходной сигналы (т.е. функции времени), ПФ связывет изображения Лапласа тех же сигналов, а частотная ПФ связывает их спектры.

Частотная передаточная функция может быть представлена в следующих видах:

W(j w) = A(w) e j j(w), или W(j w) = U(w) + jV(w) ;

где:

  • A(w) - модуль передаточной функции - находится как отношение модулей числителя и знаменателя:

    A(w) = (k1 + k2 w)1/2 / ((1 - T22 w 2)2 + T12 w 2)1/2 .

  • j(w) - фаза передаточной функции - находится как разность аргументов числителя и знаменателя:

    j(w) = arctg(k2w / k1) - arctg(T1w / (1-T2w2)).

  • U(w) и V(w) - вещественная и мнимая части передаточной функции. Для их нахождения немобходимо избавиться от мнимости в знаменателе, умножением на сопряженную знаменателю комплексную величину.

Частотные характеристики

Амплитудно-фазовая (частотная) характеристика или годограф Найквиста

Амплитудно-фазовая характеристика (годограф Найквиста)
Графическое отображение для всех частот спектра отношений выходного сигнала САР к входному, представленных в комплексной форме. Величина отрезка от начала координат до каждой точки годографа показывает во сколько раз на данной частоте выходной сигнал больше входного, а сдвиг фазы между сигналами определяется углом до упомянутого отрезка. Правила отображения "Амплитудо-фазовой характеристики" или "Годографа Найквиста" в программах математического моделирования

От АФХ порождаются все другие частотные зависимости:

  • U(w) - четная (для замкнутых САР P(w));
  • V(w) - нечетная;
  • A(w) - четная (АЧХ);
  • j(w) - нечетная (ФЧХ);
  • ЛАЧХ & ЛФЧХ - используются наиболее часто.

Логарифмические ЧХ - ЛАЧХ & ЛФЧХ

Построение ЛАЧХ & ЛФЧХ производится по выражениям:

L(w) = 20 lg |W(j w)| = 20 lg A(w), [дБ]; j(w) = arg(W(j w)), [рад].

Числитель и знаменатель ПФ САР могут быть представлены либо в виде отношения полиномов:

,

либо в виде отношения их разложений на элементарные множители:

(1)

Передаточная функция линейной системы, записанная в наиболее обобщающем виде.

Постановка s¬j w позволяет перейти в частотный домен. При наличии ЭВМ построение ЛАЧХ & ЛФЧХ не составит труда в любом случае. Однако разложенная на множители ПФ (1) позволяет построить асимптотические ЛАЧХ & ЛФЧХ практически без вычислительной работы. Каждый линейный множитель ее числителя и знаменателя есть комплексное число. Найдем модуль каждого (как гипотенузу прямоугольного треугольника), и перейдем к логарифмическому масштабу:

Обобщающая формула для построения ЛАЧХ.

Для упрощения дальнейших построений избавимся от операции умножения, заменив ее операцией сложения в логарифмическом домене:

(2)

Обобщающая формула для построения ЛАЧХ.

Легко понять, что каждое слагаемое выражения (2) есть либо прямая линия, либо асимптотически приближается к прямым линиям при устремлении частоты к нулю и к бесконечности. Наклон аппроксимирующих прямых всегда кратен 20 дБ за декаду.

Для построения ЛФЧХ необходимо найти фазу каждого множителя числителя и знаменателя частотной ПФ, как арктангенс отношения его противолежащего катета к прилежащему (напомним, что при произведении комплексных чисел (в экспоненциальной форме) фазы (показатели степени) складываются, а при делении - вычитаются). Таким образом, построение ЛФЧХ производится по выражению:

Обобщающая формула для построения ЛФЧХ.

Отметим так же, что одному Белу соответствует увеличение мощности в 10 раз. Поскольку A - это физическая величина либо первого, либо второго рода, а не их произведение (т.е. не мощность); увеличение ее в 10 раз соответствует увеличению мощности в 100 раз, что соответствует двум Белам или 20 дБ.

Правила построения асимптотических ЛАЧХ & ЛФЧХ

Правила построения асимптотических ЛАЧХ & ЛФЧХ, точнее каждого слагаемого выражения (2) показаны на рисунках.

Точность асимптотических ЛАЧХ & ЛФЧХ достаточна в большинстве случаев. Для звеньев первого порядка максимальная амплитудная ошибка вблизи частоты сопряжения составляет 3 дБ. Максимальная фазовая ошибка - 6%. Фрагмент ЧХ колебательного звена вблизи резонансной частоты лишь иногда следует уточнить по опорным справочным кривым для данного z.


Типовые звенья и их характеристики

Единичная функция. Дельта-функция.
Типовые реакции систем

Рабочие файлы: [Интеграл Дюамеля] [Интеграл свертки]
[Интеграл свертки]

Единичная ступенчатая функция - 1(t)
Математическая функция, заданная условиями: 1(t) = 0 при t < 0, и 1(t) = 1 при t > 0. Для автоматических систем является распространенным видом входного воздействия. Как правило, подобные воздействия сопровождают процессы включения систем и вызывают переходы от одного установившегося состояния к другому.
Дельта-функция Дирака - d(t)
Математическая функция, заданная условиями: d(t) ® Ґ при t = 0, и d(t) = 0 при t № 0, - т.е. это импульс с бесконечной амплитудой, площадь которого принимается равной 1. Для автоматических систем является менее распространенным видом входного воздействия, чем единичная ступенчатая функция. Однако для теоретического описания последних имеет существенное значение. Подобные воздействия характерны для радарных комплексов, описывают передачу импульса при упругом взаимодействии и т.д.

Из определений функций 1(t) и d(t) очевидна связь между ними:

(1)

1(t) = т d(t) dt и d(t) = 1'(t) .

Единичная ступенчатая функция 1(t) легка для практической реализации с высокой точностью, однако дельта-функцию Дирака d(t) реализовать сложнее. Для теоретического описания систем и их моделирования ее можно грубо представить с помощью двух ступенчатых функций:

(2)

d(t) » N 1(t) - N 1(t-e) ,

где: N - амплитуда функций, e - время, на которое запаздывает вторая ступенчатая функция, при этом N e = 1 и e ® 0.

Переходная функция или характеристика - h(t)
Переходный процесс на выходе типового звена или линейной системы, возникающий при подаче на вход единичной ступенчатой функции 1(t).
Функция веса - w(t)
Переходный процесс на выходе типового звена или линейной системы, возникающий при подаче на вход короткого импульса, который, в приближении, можно рассматривать как дельта-функцию Дирака d(t).

В виду независимости присущих линейных систем свойств от внешних воздействий и наличия связи (1) между последними, подобное же отношение существует и для соответствующих типовых реакций:

h(t) = т w(t) dt и w(t) = h'(t) .

Докажем эту взаимосвязь подав на систему грубую реализацию дельта-функции (2). В этом случае переходный процесс на выходе можно представить следующей суперпозицией:

y(t) = N h(t) - N h(t-e) ,

которая будет являться функцией веса, предел которой (при e ® 0) будет равен производной от переходной функции:

w(t) = lime®0( e N (h(t) - h(t-e)) / e ) = h'(t) , - напомним: N e = 1.

Функция веса связана с передаточной функцией преобразованием Лапласа:

W(s) = oҐ т w(t) e -st dt.

Переходная функция связана с передаточной функцией преобразованием Карсона:

W(s) = s oҐ т h(t) e -st dt.

Для произвольного входного воздействия, переходный процесс на выходе линейной системы может быть определен на основании интеграла Дюамеля-Карсона, если известны типовые реакции:

  • h(t): y(t) = x(0) h(t) + ot т x'(t) h(t-t) d t ;
  • w(t): y(t) = ot т x(t) w(t-t) d t , - так же "Интеграл свертки";

где: t - вспомогательное время интегрирования.

Типовые динамические звенья

Рабочие файлы: [Звенья]

Типовые динамические звенья
Совокупность элементарных, универсальных математических функций наиболее часто используемых при построении динамических моделей реальных объектов. Представляют собой ДУ, записанные в особой форме - в виде ПФ связывающих входной и выходной сигналы звеньев. Обычно ПФ записываются не для временного домена, а для домена Лапласа, связывая в этом варианте не сигналы (т.е. не функции времени), а их изображения.

Типовые динамические звенья Частотные характеристики типовых динамических звеньев

Наличие нулевых корней в числителе или знаменателе ПФ типовых звеньев - это признак для разбиения последних на три группы:

  • Позиционные звенья: 1, 2, 3, 4, 5, - не имеют нулевых корней, и, следовательно, в области низких частот (т.е. в установившемся режиме), имеют коэффициент передачи равный k.
  • Интегрирующие звенья: 6, 7, 8, - имеют нулевой корень-полюс, и, следовательно, в области низких частот, имеют коэффициент передачи, стремящийся к бесконечности.
  • Дифференцирующие звенья: 9, 10 - имеют нулевой корень-ноль, и, следовательно, в области низких частот, имеют коэффициент передачи, стремящийся к нулю.

Передаточные функции типовых динамических звеньев


Принципы и законы регулирования

Основы регулирования автоматических систем

Принципы автоматического регулирования

По принципу управления САУ можно разбить на три группы:

  1. С регулированием по внешнему воздействию - принцип Понселе (применяется в незамкнутых САУ).
  2. С регулированием по отклонению - принцип Ползунова-Уатта (применяется в замкнутых САУ).
  3. С комбинированным регулированием. В этом случае САУ содержит замкнутый и разомкнутый контуры регулирования.

Принцип управления по внешнему возмущению

Структурная схема системы, построенной согласно принципу управления по внешнему возмущению В структуре обязательны датчики возмущения. Система описывается передаточной функцией разомкнутой системы.

Достоинства:

  • Можно добиться полной инвариантности к определенным возмущениям.
  • Не возникает проблема устойчивости системы, т.к. нет ОС.

Недостатки:

  • Большое количество возмущений требует соответствующего количества компенсационных каналов.
  • Изменения параметров регулируемого объекта приводят к появлению ошибок в управлении.
  • Можно применять только к тем объектам, чьи характеристики четко известны.

Принцип управления по отклонению

Структурная схема системы, построенной согласно принципу управления по отклонению Система описывается передаточной функцией разомкнутой системы и уравнением замыкания: x(t) = g(t) - y(t) Woc(p). Алгоритм работы системы заключен в стремлении свести ошибку x(t) к нулю.

Достоинства:

  • ООС приводит к уменьшению ошибки не зависимо от факторов ее вызвавших (изменений параметров регулируемого объекта или внешних условий).

Недостатки:

  • В системах с ОС возникает проблема устойчивости.
  • В системах принципиально невозможно добиться абсолютной инвариантности к возмущениям. Стремление добиться частичной инвариантности (не 1-ыми ОС) приводит к усложнению системы и ухудшению устойчивости.

Комбинированное управление

Структурная схема системы, построенной согласно принципу комбинированного управления Комбинированное управление заключено в сочетании двух принципов управления по отклонению и внешнему возмущению. Т.е. сигнал управления на объект формируется двумя каналами. Первый канал чувствителен к отклонению регулируемой величины от задания. Второй формирует управляющее воздействие непосредственно из задающего или возмущающего сигнала.

Достоинства:

  • Наличие ООС делает систему менее чувствительной к изменению параметров регулируемого объекта.
  • Добавление канала(ов), чувствительного к заданию или к возмущению, не влияет на устойчивость контура ОС.

Недостатки:

  • Каналы, чувствительные к заданию или к возмущению, обычно содержат дифференцирующие звенья. Их практическая реализация затруднена.
  • Не все объекты допускают форсирование.

Программы и законы регулирования

Программа регулирования
План формирования задающего воздействия g(t) на систему.

Программа регулирования может быть:

  • временной: y = y(t);
  • параметрической: y = y(s1, s2, s3, ..., sn).

Например, временная программа приготовления пищи (лапшу варить 12 мин.), или параметрическая программа посадки самолета на палубу авианосца (в зависимости от: бокового ветра, изменений координат посадочной полосы, массы остатка топлива, ...).

Закон регулирования
Зависимость, по которой формируется регулирующее воздействие u(t) на объект из первичной информации: g(t) и/или x(t) и, возможно, f (t).

Законы регулирования бывают:

  • линейные:
    Пример линейного закона регулирования;
  • нелинейные: F1(u, du/dt, ...) = F2(x, dx/dt, ...; g, ...; f, ...) .

Классификация нелинейных законов регулирования:

  1. Функциональные.
  2. Логические.
  3. Оптимизирующие.
  4. Параметрические.

Примеры статических функциональных нелинейностей в законах:

Примеры статической нелинейности в законах регулирования.

Примеры динамических функциональных нелинейностей в законах:

Примеры динамической нелинейности в законах регулирования

Пример логического нелинейного закона:

Пример оптимизирующего нелинейного закона:

Пример параметрического нелинейного закона:

Линейные непрерывные законы регулирования

Под законом регулирования (управления) понимается алгоритм или функциональная зависимость, определяющая управляющее воздействие u(t) на объект:

u(t) = F(x, g, f) .

Линейные законы описываются линейной формой:

u(t) = k1x(t) + k2т x(t)dt + k3тт x(t)dt2 + ... + k4x'(t) + k5x''(t) + ...

она же в операторной форме записи:

(1*)

u(t) = x(t) [k1 + k2/p + k3/p2 + ... + k4 p + k5 p2 + ...] .

Наличие в (1*) чувствительности регулятора к пропорциональной, к интегральным или к дифференциальным составляющим в первичной информации x(t), определяет тип регулятора:

  1. P - пропорциональный.
  2. I - интегральный.
  3. PI - пропорционально интегральный (изодромный).
  4. PD - пропорционально дифференциальный.
  5. и более сложные варианты - PID, PIID, PIDD, ...

Пропорциональное регулирование

Пропорциональный закон регулирования имеет вид:

u(t) = Wрег(p) x(t) = k1x(t) ,

тогда в разомкнутом состоянии система будет характеризоваться ПФ:

W(p) = Wрег(p) Wo(p) = k1Wo(p) .

Рассмотрим уравнение ошибки:

В установившемся режиме p®0 (все производные равны нулю); Wo(p)®ko; W(p)®k1ko=k; где k - контурный коэффициент усиления разомкнутой системы (при Wос(p)=1).

Резюме: P-регулирование позволяет уменьшить установившуюся (статическую) ошибку, но только в 1+k раз, поэтому регулирование будет статическим. Т.е. при любом k xуст№0.

Интегральное регулирование

Интегральный закон регулирования имеет вид:

u(t) = Wрег(p) x(t) = k2/p x(t) ,

тогда в разомкнутом состоянии система будет характеризоваться ПФ:

W(p) = Wрег(p) Wo(p) = k2/p Wo(p) .

Рассмотрим уравнение ошибки:

В установившемся режиме p®0, => W(p)®Ґ; => первая составляющая ошибки g0/Ґ®0. Ошибка от возмущения зависит от вида функции Wf(0) и может быть отлична от нуля.

Резюме: I-регулирование позволяет исключить статическую ошибку в системе, т.е. система будет астатической по отношению к задающему воздействию g(t).

Интегральное регулирование по второму интегралу от ошибки

Двойной интегральный закон регулирования имеет вид:

u(t) = Wрег(p) x(t) = k3/p2 x(t) ,

тогда в разомкнутом состоянии система будет характеризоваться ПФ:

W(p) = Wрег(p) Wo(p) = k3/p2 Wo(p) .

В этом случае система будет обладать астатизмом второго порядка - в ноль обратятся как постоянная составляющая ошибки, так и её скоростная составляющая (ошибка от помехи здесь не рассматривается):

Резюме: повышение порядка астатизма приводит к увеличению установившейся точности САР, но делает систему более замедленной в действии.

К пояснению инерционных свойств интегрирующих каналов регуляторов

На рисунке показано, что, на сколько бы мал ни был коэффициент усиления пропорционального канала, и насколько большим бы ни был коэффициент усиления интегрального канала, для малых отклонений ошибки x(t) сигнал управления на объект u(t) интегральным каналом формируется менее интенсивно.

Изодромное регулирование - PI

Изодромный закон регулирования имеет вид:

u(t) = Wрег(p) x(t) = (k1 + k2/p) x(t) ,

тогда в разомкнутом состоянии система будет характеризоваться ПФ:

W(p) = Wрег(p) Wo(p) = (k1 + k2/p) Wo(p) .

В этом случае если p®0, то W(p)®Ґ и регулирование будет астатическим. Но если p®Ґ, то W(p)®k1ko=k и регулирование будет пропорциональным.

Резюме: PI-регулирование сочетает точность I-регулирования и быстродействие P-регулирования.

Регулирование с использованием производных

Регулирование с использованием одного канала, чувствительного к производной сигнала не имеет самостоятельного значения, т.к. сигнал управления:

u(t) = Wрег(p) x(t) = k4 p x(t) ,

будет равен нулю при p®0 (т.е. в установившемся режиме). Поэтому обязательно наличие параллельного либо P, либо I-канала, а чаще обоих:

u(t) = (k1 + k2/p + k4 p) x(t) .

В таком варианте регулятора управляющее воздействие будет образовываться даже когда x(t)=0, но dx/dt№0. Т.е. наличие параллельного D-канала в регуляторе повышает быстродействие системы и снижает ошибки в динамике.

Сегодня техническая реализация регуляторов, чувствительных к производным более высоких порядков, затруднена.


Устойчивость систем

Устойчивость САР

Понятие устойчивости системы регулирования связано с ее способностью возвращаться в состояние равновесия после исчезновения внешних сил, которые вывели ее из этого состояния.

Понятие устойчивости можно распространить и на случай движения САР:

  • невозмущенное движение,
  • возмущенное движение.

Определение устойчивости по М. Я. Ляпунову

Невозмущенное движение (при D xi Ґ=0) называется устойчивым по отношению к пременным xi, если при всяком заданном положительном числе A2, как бы мало оно нибыло, можно выбрать другое положительное число l2(A2) так, что для всех возмущений D xi0, удовлетворяющих условию:

,

возмущенное движение будет для времени t і T удовлетворять неравенству:

,

где: m i - коэффициенты, уравновешивающие размерности величин D xi0.

Если с течением времени lim D xi®0, то система ассимптотически устойчива.

Условие устойчивости. Типы границы устойчивости

Устойчивость систем зависит от корней характеристического уравнения, поскольку его решение есть сумма экспоненциальных функций:

.

Рассмотрим варианты свободного движения систем от ненулевого начального положения:

Влияние знака вещественной части корня ХУ на вид преходного процесса

Заметим, что:

C1 e -(a+j b)t + C2 e -(a-j b)t = A e -a t sin(b t+j) ,

где: A и j - новые постоянные интегрирования, a - показатель затухания, b - круговая частота затухающих колебаний.

Область устойчивости (для корней) Таким образом, для затухания переходного процесса и устойчивости линейной системы необходимо и достаточно, чтобы вещественные части корней были отрицательными, те лежали слева от мнимой оси плоскости корней.

Система будет находиться на границе устойчивости при наличии:

  • нулевого корня,
  • пары чисто мнимых корней,
  • бесконечного корня.

Необходимое условие устойчивости САР,
достаточное только для систем 1-ого и 2-ого порядков

Чтобы корни ХУ имели отрицательные вещественные части, необходимо чтобы все его коэффициенты были положительны. Однако это условие является достаточным только для систем 1-ого и 2-ого порядков. Док-во:

ХУ

a0 s n + a1 s n-1 + ... + an-1 s + an = 0 ,

представим в виде:

a0 (s - s1) (s - s2) ... (s - sn-1) (s - sn) = 0 ,

где: s1, s2, ... sn-1, sn - корни.

В устойчивой системе вещественные части корней отрицательны. Подставим такие корни: s1 = -a1; s2 = -a2; s34 = -a3±j b ... :

a0(s+a1)(s+a2)(s+a3-j b)(s+a3+j b) ... = a0(s+a1)(s+a2)((s+a3)2+b2) ... = 0

Если раскрыть скобки и вернутся к стандартному виду ХУ, то все коэффициенты уравнения получатся положительными.

Критерий устойчивости Гурвица

Чтобы все корни ХУ:

a1 | a3 | a5 | a7 | ... | 0 | 0
a0 | a2 | a4 | a6 | ... | 0 | 0
0 | a1 | a3 | a5 | ... | 0 | 0
0 | a0 | a2 | a4 | ... | 0 | 0
... | ... | ... | ... | ... | ... | ...
0 | 0 | 0 | 0 |  | an-1 | 0
0 | 0 | 0 | 0 |  | an-2 | an

a0 s n + a1 s n-1 + ... + an-1 s + an = 0 ,

имели отрицательные вещественные части, необходимо, при a0 > 0 выполнение условия: все n определителей Гурвица получаемые из квадратной матрицы коэффициентов должны быть положительны. Матрицы, для расчета определителей, получаются из исходной последовательным исключением последних столбца и строки.

Условие нахождения системы на границе устойчивости - D n = 0. Но D n = an D(n-1) = 0, следовательно, если an = 0, то наблюдается апериодическая граница устойчивости (нулевой корень - астатическая система), а если D(n-1) = 0, то - колебательная граница устойчивости (комплексные корни).

Критерий устойчивости Михайлова

Чтобы все корни ХУ:

a0 s n + a1 s n-1 + ... + an-1 s + an = 0 ,

имели отрицательные вещественные части, необходимо чтобы после подстановки частоты в соответствующий характеристический полном D(s) полное приращение его фазы при изменении w от 0 до Ґ составляло n p/2, где: n - степень полинома D(s). При этом характеристический полином опишет в комплексной плоскости кривую - "годограф Михайлова".

Док-во: Представим D(s) в виде разложения на линейные множители и выполним подстановку s=j w:

D(j w) = a0 (j w - s1) (j w - s2) ... (j w - sn) ,

где: s1, s2, ..., sn - корни ХУ. Скобки идентичны, поэтому рассмотрим одну из них. Возможны четыре основных варианта:

Пусть si=a, - вещественный положительный корень. Тогда годограф соответствующего линейного множителя (j w - a) при изменении w от 0 до Ґ повернется на угол -p/2.

Пусть si=-a, - вещественный отрицательный корень. Тогда годограф соответствующего линейного множителя (j w + a) при изменении w от 0 до Ґ повернется на угол p/2.

Пусть si;i+1=a±j b, - сопряженные корни с положительной вещественной частью. Тогда годографы соответствующих линейных множителей (j w - a - j b)(j w - a + j b) при изменении w от 0 до Ґ повернутся на углы -p/2+g, и -p/2-g. Вектор, соответствующий произведению двух сомножителей, повернется на угол равный -p.

Пусть si;i+1=-a±j b, - сопряженные корни с отрицательной вещественной частью. Тогда годографы соответствующих линейных множителей (j w + a - j b)(j w + a + j b) при изменении w от 0 до Ґ повернутся на углы p/2-g, и p/2+g. Вектор, соответствующий произведению двух сомножителей, повернется на угол равный p.

Резюме: Если ХУ имеет l корней с положительной вещественной частью, то угол поворота годографа D(j w) при изменении w от 0 до Ґ составит:

y = - l p/2 + (n - l) p/2 = n p/2 - l p ,

где: n - порядок ХУ.

Свойства годографа Михайлова

  • Годограф всегда спиралевиден.
  • При w=0, будетy=0, следовательно годограф начинается с точки на оси "+1".
  • Поскольку при w®Ґ K(j w)®0 (нет безинерционных систем), годограф уходит в бесконечность.
  • При четном n, годограф стремится к Ґ параллельно оси "+1"; при нечетном n, годограф стремится к Ґ параллельно оси "+j".

Определение типа границы устойчивости по виду годографа Михайлова

Оценка типа границы устойчивости по виду годографа Михайлова

  1. Астатизм первого порядка - "апериодическая" граница устойчивости.
  2. Астатизм второго порядка - "апериодическая" граница устойчивости.
  3. "Колебательная" граница устойчивости.
  4. Граница устойчивости типа "бесконечный корень".

Критерий устойчивости Найквиста

Чтобы система в замкнутом состоянии была устойчивой необходимо и достаточно, чтобы при изменении w от -Ґ до +Ґ годограф разомкнутой системы W(j w) (АФХ), поворачиваясь вокруг начала координат по часовой стрелке, охватил точку (-1, j0) столько раз, сколько корней в правой полуплоскости содержит знаменатель W(j w).

Примечания:

  1. Если корней в правой полуплоскости нет, то годограф W(j w) не должен охватить точку (-1, j0).
  2. Неустойчивая система в разомкнутом состоянии может быть устойчивой в замкнутом состоянии. И наоборот.
  3. Годограф W(j w) всегда начинается на оси "+1". Но при порядке астатизма равном r, по причине устремления W(j w) к Ґ (при w®0), видимая часть годографа появляется только в квадранте r, отсчитанном по часовой стрелке.

Док-во:

Рассмотрим ПФ для статической САР сдвинутую на величину (-1, j0):

W1(s) = 1+ W(s) = Q(s)/Q(s) + R(s)/Q(s) = D(s)/Q(s) ,

в ней D(s) - характеристический полином, Q(s) пусть не имеет корней в правой полуплоскости (пусть W(s) устойчива).

Рассмотрим угол поворота годографа W1(s). Он равен j = j1(D(j w)) - j2(Q(j w)). Поскольку степень полинома R(s) всегда меньше степени полинома Q(s), то степени полиномов числителя и знаменателя ПФ W1(s) равны. Следовательно при изменении w от -Ґ до +Ґ: j1(D(j w))=n p - (по критерию Михайлова), j2(Q(j w))=n p - (по предположению об отсутствии корней в правой полуплоскости у полинома Q(s)). Т.е. j=n p-n p=0. Другими словами для устойчивости САР в замкнутом состоянии не должна охватывать начала координат W1(j w), а функция W(j w) - точку (-1, j0).

Если знаменатель будет содержать l корней в положительной полуплоскости, то угол поворота годографа W(j w) должен составить величину:

j = j1(D(j w)) - j2(Q(j w)) = n p - [(n - l) p - l p] = l 2p ,

что и требовалось доказать.

Свойства годографа Найквиста

  1. К пояснению вида годографа консервативного звена Годограф Найквиста спиралевиден.
  2. При w®Ґ годограф W(j w)®0, т.к. нет безинерционных систем.
  3. В статических САР годограф начинается из точки на вещественной оси.
  4. Для положительных и отрицательных частот годографы зеркально симметричны относительно оси "+1".
  5. Наличие корней на границе устойчивости приводит к устремлению годографа в Ґ и приращению его фазы на -1800.

Примеры годографов Найквиста статических САР (wО[0...+Ґ))

Примеры годографов Найквиста статических САР

  1. САР на колебательной границе устойчивости.
  2. Абсолютно устойчивая САР (устойчива при любом уменьшении K).
  3. Неустойчивая САР.
  4. Условно устойчивая САР (только при изменении K в некотором диапазоне).

Примеры годографов Найквиста астатических САР и САР с чисто мнимыми корнями

Примеры годографов Найквиста астатических САР и САР с корнями, близко расположенными к мнимой оси

  1. Устойчивая САР с астатизмом первого порядка.
  2. Устойчивая САР с астатизмом второго порядка.
  3. Устойчивая САР с астатизмом третьего порядка.
  4. Неустойчивая САР с консервативным звеном.
  5. Устойчивая САР с консервативным звеном (коррекция выполнена фазовращающим звеном).

Определение устойчивости по логарифмическим частотным характеристикам

Для определения устойчивости по критерию Найквиста можно строить не АФХ, а ЛАЧХ & ЛФЧХ разомкнутой системы.

Чтобы замкнутая система была устойчива, необходимо и достаточно, чтобы сдвиг фазы на частоте единичного усиления разомкнутой системы W(j w) не достигал значения -1800.

Если система условно устойчивая, то при модулях больших единицы, фазовый сдвиг может достигать значения -1800 четное число раз.

Построение областей устойчивости - D-разбиение

Пусть имеем произвольную передаточную функцию систем:

,

и требуется оценить влияние разброса параметров на устойчивость.

Выделим два параметра (K и Ti), влияние которых на устойчивость следует оценить. Остальные параметры зафиксируем. Воспользуемся алгоритмом:

Итог итерационного алгоритма - область устойчивости (D-разбиение) ограниченная осями и графиком (уменьшение K и одной из постоянных времени объекта, как правило, положительно сказывается на устойчивости).

При заданной частоте существует только одна координата (K, Ti), которой будет соответствовать положение системы на границе устойчивости.

Наиболее удобно в итерационном алгоритме для системы любого порядка использовать критерий Михайлова, тогда уравнение границы:

D(j w) = 1+ W(j w) = 1 + R(j w)/Q(j w) = R(j w) + Q(j w) = 0,
т.е. K (1 + T3(j w)) ... + j w(1 + T1(j w)) (1+T2(j w)) ... = 0


Оценка качества регулирования

Качество любой системы регулирования определяется величиной ошибки:

x(t) = g(t) - y(t) = F x(p) g(t)

Но функцию ошибки x(t) для любого момента времени трудно определить, поскольку она описывается с помощью ДУ системы - F x(p) - высокого порядка, и зависит от большого количества параметров системы. Поэтому оценивают качество САР по некоторым ее свойствам, определяют которые с помощью критериев качества.

Критериев качества регулирования много. Их разделяют на 4 группы:

  1. Критерии точности - используют величину ошибки в различных типовых режимах.
  2. Критерии величины запаса устойчивости - оценивают удаленность САР от границы устойчивости.
  3. Критерии быстродействия - оценивают быстроту реагирования САР на появление задающего и возмущающего воздействий.
  4. Интегральные критерии - оценивают обобщенные свойства САР: точность, запас устойчивости, быстродействие.

Существует два основных подхода к оценке качества:

  1. Первый использует информацию о временных параметрах системы: h(t), w(t); расположение полюсов и нулей ПФ замкнутой системы F(s).
  2. Второй использует информацию о некоторых частотных свойствах системы: полоса пропускания; относительная высота резонансного пика; и т.д.

Точность в типовых режимах

Для оценки точности используется величина ошибки в различных типовых режимах. Типовые режимы движения состоят в подаче на вход сигналов с нормированными метрологическими характеристиками. Различают типовые режимы:

  1. Ненулевое, неподвижное состояние.
  2. Движение с постоянной скоростью.
  3. Движение с постоянным ускорением.
  4. Движение по гармоническому закону.

Сигналы задания для типовых режимов движения, их модели и изображения по Карсону-Хевисайду

Сигналы задания для типовых режимов движения

На рис. показаны режимы: ненулевого, неподвижного положения координаты; движение с постоянной скоростью; движение с постоянным ускорением. Легко понять, что перемещение координаты с постоянной скоростью легко получить интегрированием постоянного сигнала, а для получения координаты движущейся с постоянным ускорением необходимо интегрировать координату перемещающуюся с постоянной скоростью. Заменив операцию интегрирования оператором, получим изображения по Карсону-Хевисайду.

Ошибки статической системы

Здесь и далее будем рассматривать установившиеся составляющие ошибки системы в типовых режимах движения. Для чего будем анализировать уравнение ошибки:

,

где: g0+v/s+e/s2 - изображение представленного рядом Тейлора входного сигнала; s®0 соответствует установившемуся режиму.

Итак, если ПФ САР W(s) статическая, т.е. в области низких частот W(s)|s®0®K. Тогда первая составляющая ошибки:

,

т.е. в статической системе ошибка, вызванная заданием равным константе, так же константа, но меньшая на величину 1+K, а ошибки от заданий меняющихся с постоянными скоростью или ускорением нарастают до бесконечности.

Ошибки системы с астатизмом первого порядка

Если ПФ САР W(s) обладает астатизмом первого порядка, т.е. в области низких частот W(s)|s®0®Kv/s. Тогда первая составляющая ошибки:

,

т.е. в астатической системе первого порядка ошибка от задания равного константе равна нулю, ошибка от задания меняющегося с постоянной скоростью равна xv=v/Kv, а ошибка от задания меняющегося с постоянным ускорением нарастает до бесконечности.

Ошибки системы с астатизмом второго порядка

Если ПФ САР W(s) обладает астатизмом второго порядка, т.е. в области низких частот W(s)|s®0®Ke/s2. Тогда первая составляющая ошибки:

,

т.е. в астатической системе второго порядка ошибки от заданий равного константе и изменяющегося с постоянной скоростью равны нулю, а ошибка от задания меняющегося с постоянным ускорением равна константе xe=e/Ke.

Качество САР с астатизмом принято характеризовать величинами, называемыми добротностью по скорости и ускорению:

.

О компенсации помех в астатических системах

Астатическая система под воздействием помех

Рассмотрим вторую составляющую ошибки x''уст от возмущающих воздействий fko. Если САР астатическая, то W(s)|s®0®Ґ, но возможен случай, когда Wfk(s)|s®0®Ґ. Т.е. при любой степени астатизма САР x''уст может быть отличной от нуля.

.

Резюме:

  1. Для подавления ошибки от возмущения необходимо, чтобы интегрирующий элемент был включен в контур до места приложения возмущения.
  2. Если рассматривать ошибку чувствительного элемента (сумматора) как возмущение, то, очевидно, что повышение степени астатизма не позволяет устранить ее.

Ошибка при движении по гармоническому закону g(t)=Gmsin(w kt)

Рассмотрим только первую составляющую ошибки:

x'уст = g(t) / [1+W (s)] = Xmsin(w kt+j)

где: g(t) - синусоида; [1+W (s)] - комплексное число.

Следовательно:

(1)

Xm = Gm / |1+W (j wk)| » Gm / A(wk).

Резюме:

  1. Формула (1) позволяет идентифицировать положение неизвестной ЛАЧХ на данной частоте по амплитуде ошибки или сформулировать требования к ЛАЧХ при синтезе системы.
  2. Особые точки ЛАЧХ определены комплексными сопряженными корнями. Поведение системы при данных частотах (w k=|j b k|) требует дополнительного исследования.
  3. Особенность движения системы при гармоническом сигнале задания - это смена знака координат, которое во многих системах может сопровождаться нелинейными искажениями типа "ступенька" или сменой направления сил сухого трения.

Коэффициенты ошибок

Пусть известна ПФ по ошибке F x(s), тогда:

X(s) = F x(s) G(s) = 1/(1+W(s)) G(s)

где: G(s) - изображение функции g(t).

Разложим F x(s) в ряд Тейлора:

(2)

X(s) = [c0 + c1s/1! + c2s2/2! + c3s3/3! + ...] G(s) ;

перейдем к оригиналу:

x(t) = c0g(t) + c1g'(t)/1! + c2g''(t)/2! + c3g'''(t)/3! + ...

Величины c0, c1, c2, ..., cm - называют коэффициентами ошибок. Их можно определять двумя способами:

  1. c0 = F x(s)|s®0, cm = [dm F x(s)/dsm]|s®0
  2. Делением числителя F x(s) на знаменатель и сравнением с рядом (2).

Примечания:

  1. Коэффициенты ряда (2) непосредственно связанны с коэффициентом усиления САР, добротностями Kv, Ke, ...
    Система \ Ошибки | K & c0 | Kv & c1 | Ke & c2
    W(s)=1/s1 * ... | K & 1/1+K | 0 & Ґ | 0 & Ґ
    W(s)=1/s2 * ... | Ґ & 0 | Kv & 1!/Kv | 0 & Ґ
    W(s)=1/s3 * ... | Ґ & 0 | Ґ & 0 | Ke & 2!/Ke
  2. САР астатическая сигналу задания g(t) может быть статической для f (t), поэтому равенство нулю коэффициентов c0, c1, c2, ... для сигнала g(t) не обязательно означает равенство нулю коэффициентов c0, c1, c2, ... для сигнала f (t).
  3. Ограничение количества членов ряда (2) и предположение о постоянстве коэффициентов ошибок c0, c1, c2, ... определяет применение метода для плавно меняющихся сигналов g(t) и f (t), когда переходная составляющая в движении системы успевает затухнуть.

Оценка запаса устойчивости и быстродействия по переходной характеристике

Оценка запаса устойчивости и быстродействия по переходной характеристике

Запас устойчивости САР оценивают по величине перерегулирования:

s = (ymax - yҐ) / yҐ100, [%]

Варианты s | 0 % | 10..30 % | 50..70 %
Применяемость | редко | часто | избегают
Запас по фазе | 900 | 600..300 | 300..100
Число колебаний | 0 | 1, 2 | 3, 4, ...

Быстродействие САР оценивают по времени окончания переходного процесса tп, при заданной допустимой ошибке (трубке):

D О 5; 2,5; 1,5; 1; 0,5; ... [%] от yҐ , - усатановлено ГОСТ-ами.

Частоту единичного усиления разомкнутой системы wср можно оценить по частоте колебаний переходной функции.

Область допустимых значений регулируемой величины Примечание: При синтезе САР используют область допустимых отклонений регулируемой величины.

Время нарастания ограничено:

  • tн min - допустимым ускорением координат и предельными колебательными режимами;
  • tн max - требуемым быстродействием.

На рис. tз - максимальное допустимое время запаздывания (распространения) сигнала.

Корневые методы оценки качества

Поскольку корни ПФ однозначно определяют вид переходного процесса, их можно использовать для оценки: 1) запаса устойчивости и, 2) быстродействия.

Примечание: Обычно обходятся исследованием только полюсов ПФ, т.е. корней характеристического уравнения.

Система будет склонна к колебаниям, если имеются комплексные корни вида -a±j b. Оценить эту склонность можно используя показатель запаса устойчивости - колебательность:

m = b/a, 0 < m < Ґ

где: a - коэффициент затухания; b - круговая частота колебаний.

Колебательность определяет другой показатель - затухание амплитуды колебаний x(t) = Ce -a t sin(b t+j) за период: Допустимая область расположения корней системы, удовлетворяющей заданному показателю колебательности или затуханию за период

Связь между показателями: затуханим за период и колебательностью.

Задание определенной колебательности заставляет ограничить область расположения корней.

Колебательность системы m можно найти используя подстановку s = z e j(90-j), что соответствует повороту осей плоскости корней на угол (90-j). Далее, используя любой критей устойчивости, подбирают угол j, при котором система будет находиться на границе устойчивости. И тогда: m = tg j = b/a.

Для оценки быстродействия может использоваться понятие степени быстродействия h - это абсолютное значение вещественной части ближайшего к мнимой оси корня. Т.е. если этот корень -a±jb, то h равна коэффициенту затухания a.

И действительно, составляющая в переходном процессе xh(t) = Che -h tsin(b t+j), затухает тем медленней, чем меньше h. Если в конце переходного процесса амплитуда колебаний равна D Ch, то веремя переходного процесса: Допустимая область расположения корней системы, дополнительно удовлетворяющей заданному показателю степени быстродействия

.

Задание определенной степени быстродействия заставляет ограничить область расположения корней.

Степень быстродействия h можно найти используя постановку s = z - hvar, что соответствует смещению корней на величину hvar. Далее, используя любой критерий устойчивости, подбирают значение hvar, при котором система будет на границе устойчивости. И тогда: h=hvar.

Понятие о среднегеометрическом корне W0. Мажоранта и миноранта переходной функции

Пусть имеем характеристическое уравнение:

a0 s n + a1 s n-1 + ... + an-1 s + an = 0 .

Приведем его к нормированному виду (разделим на an и выполним подстановку [image]):

q n + a1/an (W0 s) n-1 + ... + ak/an (W0 s) n-k +...+ 1 = 0 ,

где: Среднегеометрический корень - среднегеометрический корень.

Влияние величины среднегеометрического корня на радиальное смещение корней Для статических САР an = 1 + K, для астатических an = K, a0 = T1 T2 ... Tn; следовательно увеличивая K можно увеличить W0. На основании теоремы подобия увеличение W0 вызовет пропорциональное радиальное смещение корней. Т.е. вид переходного процесса меняться не будет, но будет меняться его временной масштаб. Поэтому среднегеометрический корень W0 является мерой быстродействия.

Для приведенного уравнения время будет безразмерным t = W0 t, переходная функция h(t) в случае кратных вещественных корней или одной пары комплексных будет ограничена минорантой и мажорантой:

Мажоранты и миноранты переходных функций h(t) дла кратных вещественных корней 1-u(h, t) < h(t) < 1+u(h, t) ,

где: u(h, t) = e -h t [1 + (h t)1/1! + (h t)2/2! + ... + (h t)n-1/(n-1)! ] - разложение в ряд Тейлора огибающей той составляющей в пререходном процессе, корень которой ближе к оси "+j".

На рис. демонстрируется, что любой переходный процесс в любой системе будет затухать тем медленней, чем больше корней вблизи оси "+1".

Интегральные оценки качества

Интегральные оценки дают обобщенную оценку быстроты затухания и величины отклонения регулируемой величины, в виде единого числового значения.

Находят применение первые три из перечисленных в списке ИТ-оценки:

  1. I1 и I2 - линейные ИТ-оценки (не чувствительны к высшим производным координат САР).
  2. I и I' - квадратичные ИТ-оценки (не чувствительны к высшим производным координат САР).
  3. I+T12I' - улучшенная квадратичная ИТ-оценка (чувствительна к значению скоростной составляющей в движении координат САР).
  4. I+T12I'+T24I''+... - ИТ-оценки более высоких порядков (чувствительны к значению скорости, ускорению, ... координат САР).

Пусть имеем переходные функции h(t).

Рассмотрим линейные ИТ-оценки:

Линейные интегральные оценки.

Очевидно, что чем меньше значение оценки I1 или I2, тем лучше переходный процесс, но:

  1. Оценка I1 не может применяться к колебательному переходному процессу.
  2. Аналитическое вычисление оценки I2 по коэффициентам уравнения ошибки затруднено.
  3. Одно значение оценки I2 может соответствовать переходным процессам с разной колебательностью (если совпадают мажоранты и миноранты).

Ограничения "a" и "b" для оценок I1 и I2 преодолеваются квадратичными ИТ-оценками I и I' :

Квадратичные интегральные оценки.

Заметим, что оценку I' можно получить нахождением оценки I, если подать на вход САР не ступенчатую 1(t), а дельта функцию d(t)=1'(t). Применение оценки I' ограничено тем, что она не чувствительна к установившемуся значению ошибки xҐ.

Ограничение "b" для оценок I1, I2, I и I' снимается улучшенной квадратичной ИТ-оценкой:

Улучщенная квадратичная интегральная оценка,

где: x0 - начальное значение отклонения в переходном процессе.

Очевидно, что I+T12I' будет минимальна при T1x'+x = (T1s+1)x = 0. Решение этого ДУ есть экспонента: , а [image].

Т.е. улучшенная квадратичная ИТ-оценка I+T12I' будет иметь минимум при приближении переходной функции к заданной экспоненте (с постоянной времени T1).

Можно использовать улучшенные ИТ-оценки более высоких порядков. Например:

Улучщенная квадратичная интегральная оценка второго порядка.

Здесь оценка будет иметь минимум, только при перемещениях координат САР с определенными скоростью и ускорением, которые определены постоянными времени T1 и T2 соответственно. Очевидно, что дифференциальным уравнением второго порядка можно определить желаемый переходный процесс с заданным затуханием.

Аналитический расчет квадратичных ИТ-оценок

Для аналитического расчета можно воспользоваться теоремой Парсеваля:

.

Если ошибка x(t) = yҐ - y(t), то ее изображение:

Надо сделать проще - здесь сразу записать Фx (jw) и не мучиться.

Для нахождения I и I' мы должны подавать сигналы 1(t) и 1'(t). Их изображения Фурье соответственно равны:

.

Тогда установившиеся значения выходной координаты и, соответственно, значения ПФ для этих режимов:

yҐ = 1, F(0) = 1 и yҐ = 0, F(0) = 0.

В итоге изображения ошибок:

А квадратичные ИТ-оценки:

.

Частотные критерии качества

Частотные критерии качества применяют, когда известны или можно определить экспериментально частотные свойства САР (АФХ, АЧХ, ЛАЧХ & ЛФЧХ). Вид переходного процесса при этом не рассматривается.

Оценить частотными критериями можно:

  1. Запас устойчивости (b; m1; M)
  2. Быстродействие САР (wр; wср; wп; wэк).

Оценка запаса устойчивости

Запретная область для АФХ на основе запасов устойчивости по амплитуде и фазе

По виду АФХ разомкнутой системы оценивают запас устойчивости:

  • по амплитуде - L1=20lgb1 и L2=20lgb2
  • по фазе m1=180+j1

где: j1 - запаздывание по фазе на частоте единичного усиления при |W(j w)|=A(w)=1 или L(w)=0 (по ЛАЧХ).

Для абсолютно устойчивых систем (n<3) имеет смысл только величина L1, т.к. L2®Ґ. Для хорошо демпфированных систем bО[2...10), т.е. [6...20) дБ.

Запас устойчивости тем больше, чем больше b и m1. Используя b и m1 можно задать запретную область для АФХ. Но недостаток заключен в том, что если АФХ будет касаться запретной области в разных точках, перерегулирование s будет разным.

Если имеется АЧХ замкнутой системы |F(j w)|, то удобным критерием запаса устойчивости является показатель колебательности: Определение показателя колебательности M по максимальному значению AЧХ системы в замкнутом состоянии, и (опосредованно) запаса устойчивости

Показатель колебательности - M,

равный максимальному значению приведенной к коэффициенту усиления в области низких частот АЧХ замкнутой системы. Т.е. вынужденное движение на резонансной частоте будет иметь амплитуду в M раз большую, чем в области низких частот. И чем больше M, тем меньше запас устойчивости.

Если имеется только АФХ разомкнутой системы W(j w), то показатель колебательности M удобно использовать в виде нанесенной сетки, представляющей линии уровня M О [1/4; 1/2; 1/0,707; 1,41; 2; 4]. Выполним расчет сетки:

Сетка показателя колебательности M на АФХ - W(jw)

где: (1) - уравнение окружности с радиусом R, и центром в точке C.

Оценка быстродействия САР

Оценить быстродействие можно по частотным характеристикам замкнутой и разомкнутой системы используя:

  1. АЧХ - |F(j w)| - замкнутой системы
  2. P(w) = Re(F(j w)) - вещественную ЧХ
  3. АФХ - W (j w) - разомкнутой системы
  4. ЛАЧХ & ЛФЧХ
  5. ...

При этом в качестве критериев используют величины:

  • wр - резонансная частота, соответствует пику АЧХ, близка к частоте колебаний в переходном процессе;
  • wср - частота среза, соответствующая условию |W(j wср)|=A(wср)=1 или L(wср)=0 (по ЛАЧХ).
  • wп - частота соответствующая полосе пропускания замкнутой системы F(j w), определяемая из условия A(wп)=0,707.
  • wэ - эквивалентная полоса пропускания замкнутой системы: wэ = oҐ т |F(j w)|2 dw, - эта величина связана с поросом пропускания системой помех. Кроме того, если ее рассчитать, включая отрицательные частоты, причем в герцах, то она совпадет с квадратичной ИТ-оценкой I'.


Повышение точности систем

Повышение точности САР

Задача повышения точности САР обычно предполагает существенный пересмотр ее структуры. Возможны замены или добавления отдельных звеньев в контуре.

Общими методами повышения точности САР являются:

  1. Увеличение коэффициента усиления K разомкнутой цепи
  2. Повышение порядка астатизма r
  3. Применение регулирования по производным
  4. Использование комбинированного управления
  5. Введение неединичных обратных связей
  6. Включение масштабирующих устройств на входе или выходе

Повышение точности систем увеличением коэффициента усиления

Рассмотрим задачу повышения точности системы второго порядка, состоящей из 2х апериодических звеньев.

Повышение точности системы увеличением коэффициента усиления

Повышение точности системы увеличением коэффициента усиления Ошибка системы:
,
будет тем меньше, чем больше K.

Очевидно так же, что первые коэффициенты ошибок не будут равны нулю, но будут тем меньше, чем больше K:

Т.е. увеличение K уменьшает ошибки во всех типовых режимах.

Метод эффективен, широко применяется, но обычно увеличение K приводит к уменьшению запаса устойчивости (см. ЛАЧХ & ЛФЧХ)

Повышение точности систем увеличением порядка астатизма

Повышение порядка астатизма используется для устранения установившихся ошибок в типовых режимах движения.

Повышение точности системы увеличением порядка астатизма

Повышение точности системы увеличением порядка астатизма Применением интегрирующих или изодромных звеньев стремятся свести к нулю первые коэффициенты ошибок системы:

или

где: Kv = Ki K ; Ke = Ki1 Ki2 K.

Очевидно, что последовательное включение уже 2-х интеграторов приведет к появлению структурной неустойчивости, когда ни при каком значении общего коэффициента усиления невозможно получить устойчивую систему.

Это затруднение можно преодолеть использованием изодромных устройств:

Передаточная функция изодромного устройства

Повышение точности системы увеличением порядка астатизма

Повышение точности системы увеличением порядка астатизма По ЛАЧХ & ЛФЧХ видно, что постоянную времени изодромных звеньев Ti надо брать большой, дабы вносимый изодромными звеньями фазовый сдвиг не был существенным в области частоты среза wср и не влиял на устойчивость системы.

Поскольку постоянные времени изодромных устройств Ti, обычно, самые большие в системе, то определенные ими составляющие в переходном процессе затухают наиболее медленно, ухудшая тем самым динамические свойства системы. Это видно и по необращенным в ноль коэффициентам ошибок, поскольку коэффициент усиления интегратора в изодромном устройстве Ki=1/Ti обычно меньше единицы.

Повышение точности систем применением регулирования по производным от ошибки

Использование регулирования по производным от ошибки, позволяет повысить точность системы, поскольку:

  1. Система начнет чувствовать не просто наличие ошибки, но и тенденцию к ее изменению.
  2. Повышается запас устойчивости по фазе и можно поднять общий коэффициент усиления.

Повышение точности системы использованием регулирования по производным от ошибки

Повышение точности системы использованием регулирования по производным от ошибки Раскладывая в ряд ПФ системы по ошибке Fx(s), получим соотношения для ошибок:

Сравнивая полученные коэффициенты с исходными можно увидеть, что все, кроме c0, уменьшаются. При соответствующем выборе Td можно обратить в ноль один из старших коэффициентов c1, или c2, или ...

Последовательное включение 2х пропорционально-дифференцирующих элементов, позволяет обратить в ноль два старших коэффициента ошибки.

Повышение точности систем применением комбинированного управления

САР является инвариантной по отношению к задающему или возмущающему воздействию, если после завершения переходного процесса, определяемого начальными условиями, ошибка системы не зависит от этого воздействия.

Снижение ошибки от сигнала задания введением сигнала КУ на входе регулятора

Рабочие файлы: [пример]

Повышение точности системы использованием комбинированного управления Мысленно поменяем сумматоры местами, тогда для структурной схемы очевидно:

где: Fэк(s) - эквивалентная ПФ для данной системы.

Условие полной инвариантности к сигналу задания - условие полной инвариантности к g(t) (оно наблюдается, если выходной сигнал четко повторяет входной, поэтому его можно получить, приравняв Fэк(s) к 1 или же Fэкx(s) к нулю, т.к. Fэкx(s) = 1- Fэк(s)).

Разложим 1/W(s) в ряд по возрастающим степеням оператора, тогда: j(s)=a0+t1s+t22s2+t33s3+..., т.е. ПФ j(s) должна состоять из масштабирующего (a0<<1) и дифференцирующих звеньев (t1s, t22s2, t33s3, ...).

Снижение ошибки от сигнала задания введением сигнала КУ после регулятора

Повышение точности системы введением сигнала КУ после регулятора Преобразованная эквивалентная структурная схема используемая для вывода условия инвариантности к сигналу задания

На рисунке показаны структурные схемы исходной и преобразованной системы. Для последней легко записать уравнение движения:

Условие полной инвариантности к сигналу задания - условие полной инвариантности к g(t) (оно наблюдается, если выходной сигнал четко повторяет входной, поэтому его можно получить, приравняв Fэк(s) к 1 или же Fэкx(s) к нулю, т.к. Fэкx(s) = 1- Fэк(s)).

Снижение ошибки от возмущающего сигнала применением КУ

Снижение ошибки от возмущающего сигнала применением КУ Для данной системы ПФ по возмущению имеет вид:

Условие полной инвариантности к сигналу помехи - условие полной инвариантности к f(t) (можно получить, приравняв F f(s) к нулю).

Достоинство КУ:

  • Поскольку знаменатели функций F(s) (исходной) и Fэк(s) равны, введение j(s) не меняет характеристического уравнения системы, следовательно, не нарушаются условия устойчивости.

Недостатки КУ:

  • Требуется точная подстройка коэффициентов ПФ j(s).
  • При изменении параметров W(s) появляются ошибки.
  • Практическая реализация дифференцирующих звеньев высокого порядка затруднительна.

Повышение точности систем применением неединичных обратных связей

Рабочие файлы: [пример]

Повышение точности системы использованием неединичных обратных связей Введение не 1-ых ОС (j(s)) позволяет уменьшить ошибку вызванную задающим воздействием в замкнутой системе.

Для показанной на рисунке системы с не 1-ой ОС уравнение движения будет иметь вид:

Условие полной инвариантности к сигналу задания при не 1-ой ОС - условие полной инвариантности к g(t) (оно наблюдается, если выходной сигнал четко повторяет входной, поэтому его можно получить, приравняв Fэк(s) к 1 или же Fэкx(s) к нулю, т.к. Fэкx(s) = 1- Fэк(s)).

Разложим 1-1/W(s) в ряд по возрастающим степеням оператора, тогда: j(s)=1-(a0+t1s+t22s2+t33s3+...), те ПФ j(s) должна состоять из масштабирующего звена (1-a0, где a0<<1) создающего ООС по постоянной составляющей и дифференцирующих звеньев (t1s, t22s2, t33s3, ...), создающих ПОС по переменным составляющим сигнала. Заметим, что a0№0 только для статических систем.

Поскольку знаменатели функций F(s) (с 1-ой ОС) и Fэк(s) не равны, введение j(s) изменит характеристическое уравнение системы. А при полном выполнении условия инвариантности система буден находится на границе устойчивости.

Повышение точности систем применением масштабирующих устройств на входе или выходе

Повышение точности системы использованием масштабирующего устройства на входе Повышение точности системы использованием масштабирующего устройства на вхыходе


Коррекция систем

Коррекция САР

Задача коррекции состоит в повышении динамической точности САР в переходных режимах. Она возникает, поскольку стремление снизить ошибки регулирования в типовых режимах, приводит к необходимости использования таких значений общего коэффициента усиления, при которых без принятия спец. мер (внедрения пассивных звеньев) система оказывается неустойчивой.

Способы введения корректирующих звеньев

Три способа введения корректирующих звеньев

Результирующие ПФ:

 Формулы эквивалентных
переходов:

Показания к применению:

  • - последовательная коррекция - электрические цепи с немодулированными сигналами (легка в проектировании);
  • - параллельная коррекция - необходимость ВЧ-шунтирования инерционных звеньев;
  • - коррекция локальной ОС - необходимость уменьшения нелинейностей, дрейфа параметров или суммы постоянных времени (проста в реализации).

Частотные свойства последовательных корректирующих звеньев и их практическая реализация для электрического энергетического домена

К основным корректирующим звеньям относятся:

  1. Пассивное интегрирующее звено
  2. Пассивное дифференцирующее звено
  3. Пассивное интегро-дифференцирующее звено
  4. Фазосдвигающее звено
  5. Антивибратор

Пассивное интегрирующее звено

Пассивное дифференцирующее звено

Пассивное интегро-дифференцирующее звено

где: T1 = (R1+R2)C2; T2 = R2C2; T3 = R1C1; T4 = (R1||R2)C1.

Схемы замещения пассивного интегро-дифференцирующего звена на разных частотах

Отмеченный участок ЛАЧХ корректирующих звеньев 1, 2 и 3, должен так изменить вид корректируемой ЛАЧХ, чтобы она в том же диапазоне частот пересекала ось частот с наклоном -20 дБ/дек.

Методы повышения запаса устойчивости

Суть ВЧ, СЧ и НЧ демпфирования Общими методами повышения запаса устойчивости, те динамической точности являются:

  1. Демпфирование с подавлением высоких частот
  2. Демпфирование с подавлением средних частот
  3. Демпфирование с подавлением низких частот или эквивалентным поднятием высоких
  4. Демпфирование с введением дополнительных фазовых сдвигов

Демпфирование с подавлением высоких частот

Применяется сдержанно, поскольку при сохранении точности существенны потери в быстродействии - режется полоса пропускания.

Реализуется:

  1. C помощью апериодического звена с большой постоянной времени T0 - только для точных статических систем T0 і K T1 (подобный тип коррекции в ОУ).
  2. C помощью пассивного интегрирующего звена - для систем имеющих участок ЛАЧХ с наклоном -20 дБ/дек вблизи частоты единичного усиления (среза) wср, на которой наклон может составлять -40, -60, .. дБ/дек.

Коррекция апериодическим звеном Коррекция пассивным интегрирующим звеном

Демпфирование с подавлением средних частот

Применяется наиболее
часто, поскольку позволяет
сохранить точность САР и
полосу пропускания
(быстродействие).

Реализуется с помощью
пассивного интегро-
дифференцирующего
звена. Позволяет успешно
корректировать ЛАЧХ с
наклоном -40 дБ/дек.
Однако
корректирующее звено
вносит дополнительные
отрицательные фазовые
сдвиги в НЧ области.

Коррекция пассивным интегро-дифференцирующим звеном

Демпфирование с подавлением низких частот или эквивалентным поднятием высоких

Применяется ограниченно, поскольку без восстановления коэффициента усиления в области низких частот, падает точность, а поднятие верхних частот расширяет полосу пропускания и увеличивает шумы в системе.

Реализуется с помощью пассивного дифференцирующего звена, которое не дает дополнительных отрицательных фазовых сдвигов в области низких частот и позволяет успешно корректировать ЛАЧХ с наклоном -40 дБ/дек. Компенсировать же падение коэффициента усиления D K= T1/ T2 можно только, если наклон -40 дБ/дек после частоты среза wср сохраняется более одной декады.

Коррекция пассивным дифференцирующим звеном Коррекция пассивным дифференцирующим звеном с компенсирующим увеличением коэффициента усиления


Синтез систем

Синтез САР

Синтез системы
Направленный расчет, имеющий конечной целью отыскание: 1) рациональной структуры системы и 2) установление оптимальных величин параметров отдельных звеньев.

При множестве возможных решений, должен быть выбран критерий оптимизации - цена, точность, надежность, быстродействие, затраты энергии ...

При инженерном синтезе ставятся задачи:

  1. Достижение требуемой точности.
  2. Обеспечение приемлемого характера переходных процессов (задача демпфирования).
  • Решение первой задачи заключено в выборе средств повышающих точность системы (усилительных, изодромных блоков; каналов КУ; не 1ОС), т.е. фактически вида регулирования.
  • Решение второй задачи заключено в выборе оптимальных корректирующих средств.

Метод логарифмических амплитудных характеристик

Процесс синтеза включает в себя следующие операции:

  1. Построение располагаемой ЛАЧХ исходной системы Wo, состоящей из регулируемого объекта без регулятора и без корректирующего устройства.
  2. Построение НЧ части желаемой ЛАЧХ на основе предъявленных требований точности.
  3. Определение вида и параметров регулятора K, Ki, ...:
    Wрег(s) = WНЧ.ж.(s) / Wo(s);

    Lрег(w) = LНЧ.ж.(w) - Lo(w) .

  4. Уточнение ВЧ части желаемой ЛАЧХ на основе требований к запасу устойчивости - LНЧ&ВЧ.ж.(w).
  5. Определение вида и параметров последовательного корректирующего устройства:
    6. WПЗ кор = WНЧ&ВЧ.ж. / [Wрег Wo]; LПЗ кор = LНЧ&ВЧ.ж. - Lрег - Lo .
  6. Техническая реализация корректирующих устройств. В случае необходимости - перерасчет на эквивалентные параллельное звено или ОС.
  7. Поверочный расчет и построение переходного процесса.

Требования к НЧ части желаемой ЛАЧХ

Оценка точности САР по воспроизведению гармонического сигнала

Если: g(t) = Gmsin(w kt), то амплитуда Xm = |F x(j w k)| Gm = Gm / |1+W(j w k)|.

Поскольку Xm должна быть << Gm, то W(j w k) >> 1, следовательно Xm » Gm / |W(j w k)|.

Те, чтобы система воспроизводила сигнал с ошибкой, непревышающей Xm, ЛАЧХ системы должна проходить не ниже контрольной точки Ak с координатами: w = w k, L(w k) = 20lg |W(j w k)| = 20lg Gm/Xm.

Формирование запретной НЧ области для желаемой ЛАЧХ

Способ №1

Дано:

Xm - максимальная амплитуда ошибки;
Vm - максимальная скорость слежения;
Em - максимальное ускорение слежения.

Найдем связывающие отношения между амплитудой, скоростью и ускорением синусоидального сигнала:

g(t) = Gmsin(w kt)
g'(t) = Gm w kcos(w kt)
g''(t) = -Gm w k2sin(w kt) 		=> Vm = Gm w k
Em = Gm w k2 		=>

w k = Em / Vm
Gm = Vm2 / Em

  • Если зафиксировать Vm в сигнале и уменьшать w от w k, то Gm будет увеличиваться на 20 дБ за декаду (в 10 раз).
  • Если зафиксировать Em в сигнале и увеличивать w от w k, то Gm будет уменьшаться на 40 дБ за декаду (в 100 раз).

Запретная НЧ область для системы, удовлетворяющей требованиям точности Запретная область соответствует ЛАЧХ вида 1-2, т.е. системе с астатизмом 1-ого порядка добротности которой:

  • - по скорости
  • - по ускорению

Способ №2

Дано:

w k - контрольная частота;
Dj - фазовая ошибка слежения;
d - относительная амплитудная составляющая ошибки.

Приближенная передаточная функция систем с астатизмом первого порядка - определяет вид запретной области (Kv и T1 - неизвестны).

Построим векторную диаграмму гармонических координат системы:

Общий вид векторной диаграммы для САР, координаты которой меняются по синусоидальному закону

где:

;

Построение НЧ части желаемой ЛАЧХ

Построение желаемой ЛАЧХ для системы с астатизмом второго порядка В следящих системах с астатизмом 2-ого порядка, положение первой низкочастотной асимптоты всегда однозначно. Настройкой параметров регулятора (K, Ki1, Ki2) ее нужно подстроить по правой границе запретной области для НЧ.

В системах с астатизмом первого порядка надо определить положение 2-х асимптот. Возможные варианты определены положением постоянной времени объекта T1, относительно контрольной частоты:

  1. Ke > Ke треб, но: затруднено демпфирование и увеличиваются ВЧ шум.
  2. Kv > Kv треб, но: увеличиваются НЧ шум.
  3. Истинная ЛАЧХ должна быть поднята на 3 дБ, для компенсации ослабления в 1,4142 раза в зоне частоты сопряжения.

Требования к ВЧ части желаемой ЛАЧХ

Методика переноса линий показателя колебательности M на ЛФЧХ Формировать ВЧ участок ЛАЧХ удобно при использовании показателя колебательности M, линии уровня которого, при скольжении вектора A, с фазой j по окружностям M, можно нанести на ЛФЧХ.

В качестве типовых в НЧ части используются ЛАЧХ с наклоном не более -40 дБ/дек, которому соответствует нулевой запас по фазе, поэтому необходимо в области частоты среза формировать участок с наклоном -20 дБ/дек, т.е. сводить типовые ЛАЧХ к одному из 2-х видов:

Запретные зоны для ЛАЧХ & ЛФЧХ вида 2-1-2 Запретные зоны для ЛАЧХ & ЛФЧХ вида 1-2

1-2-1-2-3
0-1-2-1-2-4
... 		1-2-3
0-1-2-3-4
...

Запретные зоны на ЛАЧХ определяют:

  • Для ЛАЧХ вида 2-1-2: а) начало корректирующего участка - Т2; и б) его длину - h = Т2/S Тi, где i = [3, 4, ...), и w3 = w2h или wср = w2M/(M-1) или w3 = wср(M+1)/M.
  • Для ЛАЧХ вида 1-2 максимальное значение суммы постоянных времени равно S Тi, где i = [1, 2, ...).

Если выше частоты среза имеется пик от колебательного звена, то его амплитуда не должна приблизиться к окружности с заданной колебательностью M, т.е. не должна достичь уровня на ЛАЧХ 20lg M/(M+1); а постоянная времени, при определении h, должна войти в сумму как 2z T.

Построение ВЧ части желаемой ЛАЧХ

Исходные данные: w0 и T1 - определены при построении НЧ части желаемой ЛАЧХ.

Для систем с астатизмом 2-ого порядка:

  • Задаются перерегулированием s и определяют M:
    s, % | 13,8 | 26,5 | 37,2 | 44,6
    M | 1,1 | 1,3 | 1,5 | 1,7
  • Зная M, определяют положение постоянной времени T2 (начало корректирующего участка): , где [image]; и его длину: .
  • Проверяют, чтобы резонансные пики высокочастотных колебательных звеньев не достигали вновь уровня 20lg M/(M+1).

Для систем с астатизмом 1-ого порядка проверяют возможность сведения желаемой ЛАЧХ к виду 1-2 или модификациям, путем уменьшения постоянных времени до значения:

, где (M<1,3).

Если это невозможно, то формируют участок -20 дБ/дек аналогично методике для систем с астатизмом 2-ого порядка.

Корневой метод синтеза

Метод позволяет получить приемлемые динамические качества, при заданной структуре САР и заданном значении коэффициента усиления (последний член характеристического уравнения).

Пусть имеется ХУ:

(1)

sn+A1sn-1+...+An = 0.

Сумма модулей вещественных частей всех корней равна коэффициенту A1. При заданной его величине быстродействие будет максимальным, если вещественные части корней равны. Но это не достижимо - система будет не устойчивой. Например, для САР состоящей из 3-х апериодических звеньев выполнение условия эквивалентно равенству постоянных времени...

Реально всегда можно выделить 2 или 3 корня, с наименьшей по модулю вещественной частью, которые определяют вид переходного процесса. Положим их 2 и они комплексные. Перепишем ХУ:

(2)

(sn-2+C1sn-3+...+Cn-3) (s2+B1s+B2) = 0.

Достаточно рассматривать только 2-ой сомножитель, поскольку им определен вид переходного процесса:

  • B2 определяется значением K и должен иметь возможно большее значение.
  • B1 определяется суммой 2-х низкочастотных постоянных времени и связан с затуханием z, следовательно должен быть выбран исходя из 2-х противоречивых требований быстродействия и устойчивости.

Оптимальное соотношение между B1 и B2 может быть получено из условия затухания за один период z, выбор которого определяет отношение вещественной части корней к мнимой:

m = a/b = 2p / ln(1/(1-1/z)), где: a = - B1/2; b = (B2-B12/4)1/2.

Если принять, что вид переходного процесса определяют три корня, то следует воспользоваться уравнением 3-ей степени:

(3)

(...) (s3+B1s2+B2s1+B3) = 0,

которое нужно представить в виде:

(s+C11) (s2+B11s+B22) = 0.

Вещественные части корней будут равны a1 = a2,3 = - B1/3. Требования к B11 и B22 уже сформулированы, а связи с (3) определены равенствами:

B1=C11+B11, B2=B22+B11C11, B3=C11B22.

Выбор порядка уравнения для описания основной составляющей переходного процесса (2) или (3) зависит от структурной схемы САР.

Метод корневых годографов

Рабочие файлы: [root_locus.vsm]

Метод позволяет подобрать параметры системы по оценке их влияния на общую картину расположения корней замкнутой САР.

Если ПФ замкнутой САР:

где: m < n,

то полюсы и нули (корни) всегда можно вычислить и нанести на комплексную плоскость. Если менять один из параметров системы, (K, ..., Ti, ..., z), то изменения в ПФ F(s) приведут к смещению корней - движению по траекториям, совокупность которых называется корневым годографом. Если менять один параметр, при дискретных значениях другого, то можно оптимально выбрать значения уже 2-х параметров, оценивая семейство корневых годографов. При выборе допустимо пользоваться любой из корневых оценок качества: m, h, W0.

Наиболее эффективен метод при выборе K. ПФ разомкнутой системы и ХУ запишем в виде:

(*)

,

здесь s - не оператор Лапласа или дифференцирования, а любой из корней!!!

Если корни - полюсы и нули известны (q1o, q2o, ..., qmo; q1x, q2x, ..., qnx), то операторную часть ПФ - G1(s) можно представить в виде:

где: ; n>m.

Представим сомножители (s - qi) векторами:

.

Теперь вновь запишем ХУ:

.

При изменении K от 0 до бесконечности уравнения (1) и (2) определяют правила движения корней:

  1. Если K=0, то корни ХУ (*) совпадают с полюсами W(s), т.к. G(s) должна стремится к бесконечности.
  2. Если K®Ґ, то часть корней ХУ (*) совпадают с нулями W(s), а часть уходит в бесконечность, т.к. G(s)®0 как при совпадении s с нулями, так и при s®Ґ. Наклон асимптот для уходящих в бесконечность корней можно рассчитать по формуле:

(p+2i p) / (n-m), где: i=1,2, ..., n-m.


Системы с переменными параметрами

Система линейная с переменными параметрами
Линейной системой с переменными (var) параметрами называется такая, движение которой описывается ДУ с переменными во времени коэффициентами:
где воздействие f может быть и задающим - g(t).

Те. ПФ подобной системы параметрическая, например:

W(s, t) = | Y(s, t) | = | K(t)...
 | X(s, t) |  | (1+T1s)(1+T2(t)s)...

где: K(t), T2(t) - зависящие от времени функции.

Пример параметрической САР

Понятие о параметрической функции веса. Нахождение реакции параметрической САР на произвольное воздействие

Рабочие файлы: [Интеграл Дюамеля] [Интеграл свертки]
[Интеграл свертки]

Очевидно, что реакции САР с var-параметрами на стандартные возмущения 1(t) и d(t) будут зависеть от момента времени поступления сигналов. В связи с этим функцию веса можно изобразить в виде поверхности:

Сопряженная весовая функция и ее реверс-смещение Различают:

  • Нормальную весовую функцию w(t-J, J) при J=const.
  • Сопряженную весовую функцию w(t-J, J) при t=const.
  • Реверс-смещение сопряженной весовой функции w(q, t-q) при t=const.

Заметим, что в системах с постоянными параметрами рельеф функций веса цилиндрический и нормальная функция веса совпадает с сопряженной (с реверс-смещением).
Если на систему, со свойственной ей функцией веса w(t-J, J), действует входной сигнал f(t), то элементарная реакция на выходе системы в произвольные момент времени t=J будет:

dy = w(t-J, J) f(J) d J .

Полный сигнал определяется как суперпозиция элементарных реакций:

y = ot т w(t-J, J) f(J) d J .

А если использовать реверс смещение q = t-J (t=const):

y = ot т w(q, t-q) f(t-q) d q ,

то получим интеграл свертки для квазистационарных систем.

Найти функцию веса для систем первого и второго порядков можно аналитически. Для систем высших порядков существуют численные методы.

Отыскание ПФ системы с var-параметрами

ПФ системы с переменными параметрами можно определить либо по функциям веса:

W(s, t) = -Ґt т w(t-J, J) e-(t-J)s d J = o+Ґ т w(q, t-q) e-q s d q ,

либо по переходной функции h(t-J, J):

W(s, t) = s -Ґt т h(t-J, J) e-(t-J)s d J = s o+Ґ т h(q, t-q) e-q s d q ,

но этот подход нерационален, т.к. требует знания типовых реакций системы h и w.

Более удобно находить ПФ W(s, t) из исходного ДУ с var-параметрами:

A(s, t) W(s, t) + N{W(s, t)} = B(s, t) ,

где:

A(s, t) = a0(t)sn+...+an(t) ;      B(s,
t) = b0(t)sm+...+bm(t) ;
N{W(s, t)} =[ dA/ds dW/dt + ... + 1/n! dnA/dsn dnW/dtn
] .

Решение ДУ, т.е. ПФ W(s, t) будем искать в виде ряда:

W(s, t) = W0(s, t) + W1(s, t) + ...

где: W0(s, t) = B(s, t) / A(s, t); Wk(s, t) = N{Wk-1(s, t)} / A(s, t) .

Устойчивость и качество регулирования систем с var-параметрами

Поскольку в квазистационарных САР параметры меняются много медленней свободного движения системы, параметрическую САР считают устойчивой, если при всех "замороженных" комбинациях параметров она остается устойчивой.

Т.е. в параметрической ПФ W(s, t) фиксируют время t в диапазоне 0 < t < T и многократно исследуют на устойчивость, используя любой из критериев. Максимальное внимание надо уделить временным интервалам, где параметры меняются быстро или происходит смена знака. Особенно эффективно использование корневого годографа, зависимого от var-параметра, для оценки тенденций в системе.

При оценке качества регулирования следует учитывать, что коэффициенты ошибок получаются зависимыми от времени: Ck = [dk F x(s, t) / dsk], при s=0.

Изменение параметров можно рассматривать как возмущающее воздействие на систему. Соответственно составляющие ошибки от var-параметра не будут сводиться к нулю, за исключением случая, когда содержащее var-параметр звено установлено в цепи ОС или в прямом канале до интегрирующих элементов. Поскольку динамика изменения var-параметров в сравнении с динамикой задающего воздействия g(t) не значительна в случае квазистационарных систем, то соответствующие составляющие ошибок: по скорости, ускорению, ... - как правило, меньше.

Синтез параметрических САР

При синтезе САР на ЭВМ так же используют "замораживание" коэффициентов, и, если во всем рабочем интервале времени качество САР оказывается приемлемым, ее считают работоспособной.

Во многих случаях удается выделить одно звено, первого или второго порядков с var-параметром. Тогда возможно осуществить синтез САР расчетным путем.

Диапазоны и зоны измения параметров

При синтезе следует стремиться максимально точно определить законы изменения параметров и не ограничиваться диапазонами. Так для случая 2 изменений var-параметров, согласно "D"-разбиению вероятность сохранения устойчивости существенно больше.


Системы с запаздыванием

Система линейная с запаздыванием
Линейной системой с запаздыванием называется такая, которая содержит в своей структуре хотябы одно звено, в котором есть неизменное запаздывание во времени t изменения выходной координаты после начала изменения входной.

Переходная характеристика апериодического звена первого порядка с элементом чистого запаздывания Рассмотрим апериодическое звено первого порядка, которое описывается уравнением:

(1)

T dy/dt + y = K x(t) .

Уравнение соответствующего звена с запаздыванием t будет иметь вид:

(2)

T dy/dt + y = K x(t-t) .

Оно называется дифференциально-разностным.

Обозначим x*(t) = x(t-t), тогда уравнение (2) запишется в обыкновенном виде:

(3)

T dy/dt + y = K x*(t) .

Следовательно его переходная характеристика соответствует апериодическому звену (рис. 1в), но задержана на t с, что определено задержкой воздействия x*(t) (рис. 1б).

Резюме:

  • Временная характеристика любого звена с запаздыванием будет такая же, как у соответствующего обыкновенного звена, но только сдвинута по оси времени вправо на величину t.
  • Величину запаздывания t в звене можно определить экспериментально, путем снятия временной характеристики.

Пример системы с транспортным запаздыванием

Примеры систем с транспортным запаздыванием

ПФ звена чистого запаздывания

Блочное обозначение звена чистого запаздывания Свойства звена таковы, что y(t) = x(t-t), где t - запаздывание, а x(t-t) = 0 при 0 < t < t.

Разложим правую часть уравнения (т.е. выходной сигнал) в ряд Тейлора:

Разложение запазывающего сигнала в ряд Тейлора,

или

Изображение запаздывающего сигнала,

т.е.:

Передаточная функция звена чистого запазывания.

Аппроксимация звена чистого запаздывания

i1.gif (913 bytes) Сравним переходные функции апериодического звена с запаздывающим аргументом и апериодического звена 2-ого порядка:

Переходные функции апериодического звена с запаздывающим аргументом и апериодического звена 2-ого порядка

Поскольку они существенно похожи, в приближенных расчетах можно осуществлять подмены передаточных функций звеньев.

В некоторых случаях применяется прием учета большого числа N звеньев в системе с малыми постоянными времени D Ti и единичным коэффициентом передачи, одним звеном с постоянным запаздыванием, равным сумме этих постоянных времени t = SD Ti » N ЧD T. Т.е.:

Если N®Ґ, то в пределе получим W(s)»e-t s. Уже при N=8..10 степень приближения высока. Ряд будет более точно соответствовать разложению в ряд функции e-t s, если его представлять не апериодическими, а фазосдвигающими звеньями.

Размыкание систем с запаздыванием

Большинство методов исследования устойчивости или качества систем в качестве входной информации используют ПФ системы для разомкнутого состояния W(s). Звено чистого запаздывания является нелинейным элементом, и затрудняет как аналитический анализ систем, так и машинный (программы математического моделирования не могут выполнять функции анализа для систем с нелинейными элементами). Поэтому либо используют линеаризованные аппроксиматоры звена чистого запаздывания, либо размыкают систему в той ветви, которая содержит звено чистого запаздывания, дабы ПФ имела вид: W(s) = Wo(s) ґ e-t s, где Wo(s) - ПФ части системы без запаздывания.

Рассмотрим и разомкнем системы с основными вариантами включения звена чистого запаздывания - последовательным, параллельным и в цепи ОС:

Преобразование структурной схемы системы при последовательном включении звеньев чистого запаздывания в контуре

Преобразование структурной схемы системы при параллельном включении звена чистого запаздывания

Преобразование структурной схемы системы при включении звена чистого запаздывания цепи локальной ОС

Если звенья чистого запаздывания имеются в разных ветвях структурной схемы, то для исследований используют их аппроксиматоры и машинные методы анализа.

Частотные свойства систем с запаздыванием. Понятие о критическом запаздывании

Перейдем в частотный домен:

,

следовательно:

L(w) = |W(j w)| = Ao(w) ґ 1 = Ao(w) ,
j(w) = jo(w) - wt .

Закручивание АФХ звеном чистого запаздывания Резюме:

  • Таким образом, наличие звена с запаздыванием не меняет модуля, а лишь вносит дополнительный фазовый сдвиг (-wt).
  • Из графика видно, что звено e-t s закручивает исходный годограф Wo(j w) по часовой стрелке, ухудшая условия устойчивости.
  • По имеющемуся годографу Wo(j w) можно определить критическое значение запаздывания tкр:
    j1 - wсрtкр = -p =>

    tкр = (p + j1) / wср

    В некоторых случаях tкр можно рассчитать аналитически.

Устойчивость систем с запаздыванием

Рассмотрим замкнутую систему:

АФХ и годограф Михайлова системы со звеном чистого запаздывания

По знаменателю ПФ F(j w) видно, что в общем случае характеристическое уравнение будет иметь множитель e-t s, который определяет возможность наличия бесконечного количества корней (см. петли годографа Михайлова D(j w) ).

Как и прежде, для устойчивости все они должны иметь отрицательные вещественные части.

  • Для устойчивости систем 1-ого и 2-ого порядка с запаздыванием не достаточно положительности коэффициентов.
  • Для систем 3-его и более порядков не применимы критерии Вышнеградского, Рауса, Гурвица.

Об исследовании точности систем с запаздыванием

Частотные характеристики звена чистого запаздывания По ЧХ звена чистого запаздывания наглядно видно, что его коэффициент передачи во всем частотном диапазоне равен единице. Причем в области низких частот и задержка в звене пренебрежимо мала (т.е. сдвиг фазы стремится к нулю), поэтому при исследовании точности систем с запаздыванием допустимо просто исключить все звенья чистого запаздывания из структурной схемы. Эта операция допустима, поскольку точность любой системы определяет только НЧ часть ее ЧХ.


Импульсные системы

Система импульсная линейная
Линейной системой импульсного регулирования называется такая САР, которая кроме звеньев описываемых обыкновенными линейными ДУ содержит импульсное звено, преобразующее непрерывное входное воздействие в равноотстоящие друг от друга по времени импульсы.

Варианты выходных последовательностей импульсных звеньев

Варианты выходных последовательностей импульсных звеньев

Пример импульсной системы

Пример импульсной системы

1 - импульсное звено - ключ с ШИМ; 2 - непрерывное звено - фильтр с нагрузкой; изменение +U можно рассматривать как возмущение f(t)

Система линейна, если линеен ШИ-модулятор. Если Rн меняется, то система дополнительно будет параметрической.

Математический аппарат описания импульсных систем

Решетчатые функции

Рабочие файлы: [z_sin.vsm]

Решетчатые функции 2 определены только в дискретные моменты времени [nT] (сокращенно [n]), и формируются из непрерывных функций 1: f [nT] = f (t) при t=nT. Рассматривают так же смещенные решетчатые функции (последовательность 3): f [n, e] = f (t) при t=(n+e)T, где e - относительное смещение, eО[0..1).

Синтез огибающих (интерполяция) Непрерывные функции, проходящие через дискреты заданной решетчатой функции, называют огибающими. Их бесконечно много.

Основная огибающая может быть получена, как результат решения ДУ наименьшего порядка и должна содержать гармоники наименьшей частоты.

Дифференцирование и интегрирование решетчатых функций

Аналогом первой производной для решетчатой функции является либо первая прямая разность: Производная решетчатой функции

D f [n] = f [n+1] - f [n],

либо первая обратная разность:

С f [n] = f [n] - f [n-1].

Аналогов второй являются вторые разности. Прямая:

D2 f [n] = D f [n+1] - D f [n] = (f [n+2] - f [n+1]) - (f [n+1] - f [n]) = f [n+2] - 2 f [n+1] + f [n],

и обратная:

С2 f [n] = С f [n] - С f [n-1] = f [n] - 2 f [n-1] + f [n-2].

По аналогии могут определяться и высшие разности:

D k f [n] = n=0k е(-1)nCknf [n+k-n] С k f [n] = n=0k е(-1)nCknf [n-n]

где: Ckn = k! / (n!(k-n)!).

Очевидно, что если f [n] определена только для положительных n, то для n=0 все обратные разности С k f [n] равны нулю, что позволяет ...

Аналогом интеграла является неполная сумма:

s[n] = m=0n-1е f [m] = n=1n е f [n-n],

и полная сумма:

so[n] = s[n] + f [n].

Разностные уравнения

Аналогом ДУ для импульсной системы является уравнение в конечных разностях или разностное уравнение (РУ):

b0С my[n] + b1Сm-1y[n] + ... + bm y[n] = f [n],

(оно может быть составлено и в прямых разностях). Если раскрыть разности, то уравнение будет иметь вид:

(1)

a0 y[n] + a1 y[n-1] + ... + am y[n-m] = f [n],

где: am-k = n=0k е (-1)m-k bn Cm-nk-n ; Cm-nk-n = (m-n)! / [ (k-n)! (m-k)! ] .

РУ легко машинизируются и для их расчета можно составлять рекуррентный алгоритм.

Учтем запаздывание передаточной функцией звена чистого запаздывания и вынесем теперь уже изображение дискретной последовательности y[n] в уравнении (1) за скобку:

(a0 + a1e-Ts + ... + ame-mTs) Y *[s] = F *[s],

введем обозначение z = eTs и перепишем уравнение:

(a0 + a1 z -1 + ... + am z -m) Y [z] = F [z].

Решая для него ХУ (левая часть приравненная к нулю) можно получить "Общее решение" - т.е. переходную составляющую:

y [n] = С1 z1n + С2 z2n + ... + Сm zmn ,

где: z1, z2, ..., zm - корни ХУ; а Ci - произвольные постоянные.

Вид решения ХУ определяет условие устойчивости для систем, описанных с помощью РУ:

| zi | < 1.

Z-преобразование

Для решетчатых функций времени может быть введено понятие дискретного преобразования Лапласа:

Дискретное преобразование Лапласа и z-преобразование

которое называется Z-преобразованием при подстановке z = eTs, и связывает изображение с оригиналом.

Z-преобразования (изображения) типовых решетчатых функций и типовых непрерывных ПФ W(s) сведены в таблицы. Определены правила и теоремы для математических манипуляций с ними.

Типовая структура импульсной системы.
Понятие об импульсном фильтре

Типовая структура импульсной системы

  • Если время замкнутого состояния ключа мало, то сигнал на его выходе можно заменить последовательностью x*[nT] дельта-функций, с площадью x[nT]: x*[nT] = x[nT] d(t-nT).
  • В таком случае реакция непрерывной части Wo(s) - это суперпозиция весовых функций w(t), которую можно рассматривать и как непрерывный сигнал y(t), и как дискретную последовательность y[nT].
  • Импульсным фильтром считают импульсный элемент (ключ) с непрерывной частью Wo(s) на выходе. За истинный сигнал фильтра принимают выходную последовательность только в дискретные моменты времени y[nT], где n = ..., -2, -1, 0, 1, 2, ...

Обобщенная модель импульсного элемента

Обобщенная математическая модель импульсного элемента

  • Задача идеального импульсного элемента (ИИЭ) в модели - сформировать для дальнейшего математического описания системы либо последовательность импульсов типа d-функций с площадью ~ x(t), либо решетчатую функцию, в основе которой единичная импульсная функция do(t) = { 1 при t=0; 0 при t№0 } с амплитудой ~ x(t).
  • Задача экстраполятора - математически описать выходную последовательность реального импульсного звена (экстраполяция - это прогнозирование (синтез) сигнала между значениями решетчатой функции).
  • Коэффициент передачи квантователя (ИИЭ) обратно пропорционален периоду квантования, а коэффициент передачи экстраполятора нулевого порядка равен периоду. Таким образом общий коэффициент передачи квантующей и восстанавливающей цепи, т.е. ИЭ обычно равен единице.

Приведенные весовая и передаточная функции разомкнутой импульсной системы

  • Если ИИЭ выдает решетчатую функцию, то можно ввести понятие "приведенной весовой функции" - wп. Это отношение выходного сигнала y(t) к значению единственной дискреты xo поданной на вход экстраполятора.
  • Если ИИЭ выдает последовательность типа d-функций, то для непрерывной части совместно с экстраполятором можно вывести понятие приведенной непрерывной передаточной функции:

Wп(s) = Wэ(s) Wo(s), при этом Wп(s) = L{ wп(t) }.

Дискретная ПФ

Знание приведенной решетчатой весовой функции wп[n] позволяет найти реакцию импульсного фильтра на входную величину произвольного вида - x(t). Рассмотрим реакции на отдельные значения входной величины в дискретные моменты времени:

  • на x[0]: y[n] = wп[n] x[0]
  • на x[1]: y[n] = wп[n-1] x[1]
  • на x[m]: y[n] = wп[n-m] x[m]

Следовательно реакция на всю входную последовательность будет равна:

y[n] = m=0n е w п[n-m] x[m] = m=0n е w п[m] x[n-m] = m=0n е w п[m] x[n] e
-mTs = m=0n е w п[m] x[n] z
-m = x[n] m=0n е w п[m] z -m
.

Здесь первоначально изменен порядок суммирования (свертка), а затем учли запаздывание оператором запаздывания z = eTs. Если устремить n к бесконечности, то, очевидно, что сомножитель для x[n] есть дискретная ПФ:

W (z) = n=0Ґ е wп[n] z -n = Y (z) / X (z) .

И поскольку она является Z-преобразованием приведенной решетчатой весовой функции, то ее можно представить как Z-преобразование от обратного преобразования Лапласа приведенной ПФ экстраполятора и непрерывной части:

W (z) = Z { wп[n] } = Z { L-1 { Wп(s) } } .

Часто для краткости записи знак операции L-1 опускают записывая: W (z) = Z { Wп(s) }.

Правила преобразования структурных схем дискретных систем

Рабочие файлы: [series_z.vsm]

Wп(s) = W1(s) + W2(s)
W(z) = W1(z) + W2(z)

Wп(s) = W1(s) W2(s)
W(z) = Z { W1(s) W2(s) } = W1W2(z)
те. W(z) № W1(z) W2(z) !!!

W(z) = W1(z) W2(z)

W(z, e) = Z { L-1 { Wп(s) e-t s } } =
= z -1 Ze { wп[n, e] }

где:

e - относительное смещение, которое отсчитывается
от начала предыдущего такта (e = 1 - t/T ; 0 < t < T ).

ПФ системы с экстраполятором нулевого порядка и звеном запаздывания

Импульсная система с экстаполятором нулевого порядка и звеном запаздывания

Экстраполятором нулевого порядка являются: 1) УВХ и 2) ЦАП.

Найдем изображение Лапласа для единичного импульса:

Изображение Лапласа для выходного импульса экстаполятора нулевого порядка.

Тогда Z-изображение экстраполятора и непрерывной части со звеном запаздывания:

,

где: e = 1 - t/T ; 0 < t < T ; W(z) не учитывает коэффициент передачи ИИЭ равный 1/T.

ПФ системы с экстраполятором, осуществляющим АМ первого или второго рода

Импульсная система с экстаполятором, осуществляющим АМ первого рода

Найдем изображение Лапласа для частично заполненного импульса:

Изображение Лапласа для частично заполненного единичного импульса.

Тогда Z-изображение экстраполятора и непрерывной части со звеном запаздывания:

,

где: e = 1 - g ; W(z) не учитывает коэффициент передачи ИИЭ равный 1/T.

Если g << 1, то e -g Ts » 1 - g Ts, тогда:

.

К этой формуле, в первом приближении, сводится и АМ второго рода.

ПФ замкнутой импульсной системы

Замкнутая импульсная система

Опишем систему в изображениях Лапласа:

те.:

.

  • ПФ по ошибке F x может быть получена решением системы относительно ошибки x.
  • Поскольку запаздывание не определяет свойства системы в области низких частот, практически всегда для оценки качества могут быть использованы формулы

(осталась особенность - "W1W2(z)", см. правило 2 преобразования структурных схем)

ПФ для возмущений

Приведение возмущающего воздействия ко входу

Поскольку для произведения 2х операторных многочленов: F(s) (изображение возмущения) и W2(s) нельзя найти Z-преобразование раздельно, см. правило 2, то ПФ по возмущению удобно определять для эквивалентных возмущений F1(z), приведенных к входу ИЭ:

.

Дискретная синусоидальная последовательность x[n] = a sin [w nT+j].
Частота Найквиста. Теорема Котельникова.
Частотные ПФ импульсных систем

Рабочие файлы: [z_sin2.vsm] [psd45.vsm] [fft30.vsm]

Дискретные синусоидальные последовательности

Особые свойства последовательности x[n]:

  1. Функция может быть как периодической - рис. а и б, так и непериодической - рис. в.
  2. Амплитуда образующей непрерывной функции может быть максимальным значением последовательности a - рис. а, и может не является им - рис. б.
  3. Последовательность не изменится, если на вход ключа подавать сигналы с частотами, отличающимися на частоту дискретизации: f ; f + 1f0; f + 2f0; ...; f + kf0.

Запишем закон изменения синусоидальной последовательности в экспоненциальной форме:

x[n] = a sin [w nT+j] = a e j[w nT+j] = a e j j e j w nT = a e j w nT = a zn ,

тогда выходная величина импульсного фильтра:

y[n] = m=0Ґ е w п[n-m]
x[m] = m=0Ґ е w п[m] x[n-m] = m=0Ґ е w п[m]
a zn-m = a zn
m=0Ґ е w п[m]
z -m = a znW (z) = x[n]
W (z).

Таким образом ПФ W(z) при подстановке z = e j w T - есть частотная ПФ. Все остается в силе и для F(e j w T) и F x(e j w T).

Очевидно, что частотные ПФ W(e j w T), F(e j w T) и F x(e j w T) обладают периодическими свойствами (w0 = 2p T -1). Это видно и из нижнего рис., поскольку одну и ту же входную последовательность могут вызывать входные сигналы с разными частотами f + k f0.

v - Преобразование. Билинейные преобразования.
Устойчивость и качество импульсных систем

Рабочие файлы: [bi_line_sz.vsm]

Вид границы устойчивости в домене Лапласа, в Z и W доменах

Построим область устойчивости в плоскости комплексной величины z. Воспользуемся методикой D-разбиения и, меняя частоту w от - Ґ до + Ґ, получим границу z = eTs = e j w T - в виде окружности единичного радиуса, внутрь которой попадает левая полуплоскость комплексной величины s. Следовательно, для устойчивости, все корни-полюсы замкнутой системы F(z) должны находится внутри этой окружности.

Итак, для описанных с помощью аппарата Z-преобразования импульсных систем, всилу изменившегося вида области устойчивости и периодичности их ЧХ W(e j w T), разработанные для непрерывных систем критери устойчивости (кроме критерия Найквиста и корневого годографа), а так же наиболее эффективные методы коррекции и синтеза (использующие ЛАЧХ & ЛФЧХ) не приемлемы.

Для преодоления этого затруднения используют v-преобразование, которое отражает окружность единичного радиуса на мнимую ось комплексной величины v, с помощью подстановки:

Переход в W-домен и домен псевдочастоты.

Физически подстановка означает переход к ДУ заменой в РУ элементов чистого запаздывания грубой аппроксимацией - одним фазосдвигающим звеном.

Вторая формула для перехода в область псевдочастот l получена из соотношения:

,

отметим так же, что:

.

v-Домен и домен псевдочастоты l используют редко, поскольку для большинства импульсных и цифровых систем частота дискретизации 1/T выбирается в 6...10 раз больше частоты среза. В таком случае выполняется условие wсрT<2, вследствие чего в полосе системы псевдочастота l и частота w практически совпадают. Поэтому обходятся доменом обычных частот, а для переходов используют формулы "Билинейного преобразования":

Формулы "Билинейного преобразования".

Резюме:

  1. После v-преобразования, используя ПФ W(v) или F(v) можно применять обычные (в основном алгебраические) критерии устойчивости, справедливые для непрерывных систем.
  2. После последующего перехода в область псевдочастот (подстановка v = j l T/2) вид ПФ W(j l T/2) и F(j l T/2) становится пригоден для применения медодов, использующих ЛАЧХ & ЛФЧХ.
  3. Качество импульсной системы может оцениваться построением кривой переходного процесса, что при использовании ПФ F(z) сравнительно легко.
  4. Оценку качества в установившихся режимах удобно выполнять нахождением коэффициентов для разложения ошибки в ряд:

    ,

    которые являются коэффициентами разложения ПФ F x(z) в ряд Маклорена по степеням s:

    ,

    где: z = e Ts.

Понятие о переходном процессе конечной длительности

Импульсная система, имеющая переходный процесс конечной длительности

Принципиальным недостатком линейных систем является тот факт, что любой переходный процесс будет иметь бесконечную длительность. Это объясняется тем, что при уменьшении значений сигналов на входах интеграторов пропорционально уменьшается скорость изменения их выходных координат. Т.е. если в линейной астатической системе ошибка становится меньше, то тут же понижается скорость ее компенсации по цепи ООС (см. рис., кадр 1).

Если же на некоторое время периодически замораживать сигнал в цепи ООС, то скорость изменения выходной координаты интегратора в течение периода "заморозки" уменьшаться не будет, а при правильном подборе периода "заморозки" можно добиться переходного процесса конечной длительности, завершающегося за один или же два цикла (см. рис., кадры 2 и 3).

Следует отметить, что подобная импульсная система на время "заморозки" сигнала ООС приобретает все достоинства и недостатки не имеющих ОС систем.


Cистемы цифрового управления

Цифровые системы

Цифровые системы строятся на базе комплекса средств вычислительной техники, основными элементами которого являются: 1) ЦВМ, 2) устройства ввода, 3) устройства вывода.

Функции ЦВМ могут выполнять: 1) ЭВМ (компьютеры), 2) DSP - цифровые сигнальные процессоры, 3) ЦУ на жесткой логике. Первые относятся к универсальным устройствам управления, вторые специализированны для приложений, третьи разрабатываются для конкретных устройств (например, цифровой фильтр имеющийся в каждом еD АЦП).

Устройствами ввода и вывода в случае состыковки с аналоговыми сигналами являются АЦП и ЦАП-ы, а в случае состыковки с цифровыми сигналами - порты и интерфейсы.

В системах с ЦВМ, последние могут выполнять роли: 1) регулятора, 2) регулятора и устройства сравнения, 3) корректирующего устройства или 4) самого объекта.

Если ЦВМ универсальная (ЭВМ), то возможно построение многофункциональных САУ, когда одна ЦВМ обслуживает комплекс составляющих объект устройств. Например, в автомобиле: 1) система навигации, 2) система бортового электропитания, 3) АБС, 4) электронная подвеска, 5) управление топливоподачей, ... В подобных случаях в состав системы ЦУ должны входить аналоговые или цифровые мультиплексоры и демультиплексоры.

Во всех случаях ЦВМ предоставляет легко доступные информационные потоки, позволяющие кроме прямого управления осуществлять функции: 1) контроля, 2) оптимизации, 3) координации и 4) организации всех процессов.

Процессы протекающие в системах ЦУ

Рабочие файлы: [Субгармонические автоколебания]

Дискретная природа ЦВМ определила наличие 2-х процессов в системах ЦУ: 1) дискретизации сигналов по времени (получение решетчатой функции), и 2) квантования сигналов по уровню (АЦ и ЦА преобразования).

Дискретизация сигналов по времени делает систему дискретной, а квантование по уровню - нелинейной. Оба процесса сопровождаются возникновением методических погрешностей.

Выбор частоты дискретизации производится исходя из ширены полосы пропускания или из времени регулирования замкнутой системы. Разумные частоты дискретизации в 6..10 раз больше ширены полосы пропускания или от 2-х до 4-х дискретных отсчетов за время нарастания, в противном случае качество системы будет резко ухудшаться.

Количество ступеней квантования по уровню оказывает существенное влияние на динамические свойства систем. При недостаточном их количестве могут возникать периодические режимы переключений между дискретами (автоколебания).

Может случиться так, что выполняемые ЦВМ задачи (опрос датчиков, расчет программы, формирование информационных потоков, запись в порты вывода) могут быть выполнены только при систематической задержке синтезируемого воздействия на один такт дискретизации. В таком случае в системе с ЦВМ появится запаздывание t, которое должно быть учтено оператором запаздывания z -1 и, возможно, смещенной ПФ W(z, e).

Обычно количество ступеней квантования по уровню велико, поэтому его влиянием пренебрегают. Это делает систему, линейной и позволяет использовать математический аппарат импульсных систем.

Методика вывода дискретных ПФ

Система, управляемая ЦВМ (предполагается, что АЦП совместно с ЦАП-ом имеют единичный коэффициент усиления, т.е. в модели можно подобрать либо коэффициент усиления ключа и масштаб задания, либо коэффициент усиления экстраполятора)

Работу ЦВМ обеспечивают АЦП (квантователь) и ЦАП (экстраполятор нулевого порядка), следовательно:

Последовательно включенные ПФ с общим ключом нельзя по отдельности преобразовывать к эквивалентным дискретным ПФ (см. правило 2)...

Для нахождения z-изображения непрерывной ПФ W(s) по таблицам, последнюю надо разложить на элементарные дроби (т.е. преобразовать к параллельной структуре):

,

где:

A (1+T1s) + Bs (1+T1s) + Cs2 = 1 ;
(BT1+C) s2 + (AT1+B) s + A = 0s2 + 0s + 1 ; =>
=> A = 1, B = -T1, C = T12 .

Коэффициент передачи ООС 1/Tц учитывать не надо (см. примечание к рис.).

О синтезе систем с ЦВМ методом логарифмических амплитудных характеристик

ЧХ импульсного фильтра, демонстрирующие: 1) их схожесть с ЧХ непрерывной части в области НЧ, и 2) поглощение частот кратных частоте дискретизации ЦВМ делил W(e^jwTц) на Tц

Изображенный дискретный фильтр имеет в области частот w ЛАЧХ & ЛФЧХ, использовать которые при синтезе неудобно.

Перевод с помощью v-преобразования ЧХ в область псевдочастот l, позволяет получить ЛАЧХ, которые по виду подобны ЛАЧХ непрерывных систем.

Последовательность преобразований следующая:

Wэ(s)Ч W(s) ® W(z) ® W(v) ® W(j l Tц/2).

Эти преобразования при использовании экстраполятора нулевого порядка могут быть формализованы. Пусть ПФ непрерывной части имеет вид:

.

Техническая реализуемость систем с ЦВМ позволяет ввести положения:

  1. Пусть для частоты среза непрерывной части выполняется условие wср < 2/Tц.
  2. Все постоянные времени знаменателя разделим на две группы - до и после диапазона от частоты среза до частоты дискретизации:

    T1, ..., Tq > (1/wср ... 1/wц) > Tq+1, ..., Tn.

  3. Постоянные времени в числителе t1, ..., t m пусть больше чем 1/wср.
  4. Поскольку система должна быть устойчива, пусть наклон ЛАЧХ на wср будет -20 дБ/дек.

Принятые положения, позволяют описать свойства систем в области низких и высоких частот двумя ПФ:

.

Теперь для формального перехода в область псевдочастот l (минуя промежуточные z и v-преобразования) достаточно подставить в ПФ Wo(s)НЧ вместо s j l и умножить ее на множитель (1-j l Tц/2), для низких частот приближенно равный 1.

А ПФ Wo(s)ВЧ будет соответствовать выражение:

.

Модуль которого: .

Результирующий фазовый сдвиг обеих областей:

.

Резюме:

  1. В области НЧ (w < 2/Tц) асимптотическая ЛАЧХ системы с ЦВМ практически сливается с ЛАЧХ непрерывной части (множитель (1-j l Tц/2) » 1) и можно положить l » w. Это позволяет один к одному использовать разработанную для непрерывных систем методику формирования НЧ части желаемой ЛАЧХ.
  2. В области ВЧ отличия вносит множитель (1-j l Tц/2), ухудшающий условия устойчивости. Поэтому при формировании запретной ВЧ области в расчетных формулах величина Tц/2 должна быть просуммирована с малыми постоянными времени:

Цифровая коррекция

Цифровая или дискретная коррекция весьма интересна с практической точки зрения в силу конструктивной универсальности устройств и гибкости настройки. Решения задач коррекции предполагают модификации низкочастотного и среднечастотного фрагментов ЛАЧХ, как правило, с уменьшением частоты среза wср. Известно, что в этом диапазоне системы с ЦВМ и их ЛАЧХ - L(l) не отличаются существенно по свойствам от непрерывных аналогов. Поэтому методика синтеза коррекции едина для цифровых и непрерывных систем. Проектирование же дискретной коррекции ведется в четыре этапа.

  1. Синтез ПФ непрерывного корректирующего устройства Wк(s) по методикам разработанным для непрерывных систем.
  2. Переход от непрерывной ПФ корректирующего устройства Wк(s) к эквивалентной дискретной Wк(z) посредствам последовательных переходов по изображениям:

    ,

    с помощью результирующей формулы билинейного преобразования (т.е. формальной подстановки):

    где: Tц - период дискретизации ЦВМ.

  3. Составление структурной схемы дискретной ПФ Wк(z), оптимизированной при реализации по объёму памяти, быстродействию или для контроля промежуточных фазовых координат системы.
  4. Написание программы для ЦВМ (периферийный контроллер, микроЭВМ, ЭВМ, цифровой сигнальный процессор - DSP) или разработка схемы на цифровых микросхемах.
  • Заметим, что из непрерывной ПФ можно получить бесконечное количество вариантов дискретной ПФ, при разных периодах дискретизации ЦВМ (этап 2).
  • Обычно частоту дискретизации fц=1/Tц выбирают в 6..10 раз больше частоты среза fср разомкнутой системы. Первоначально частоту дискретизации выбирают большой (fц=10..30fср), за тем, за две три попытки стремятся ее уменьшить (т.е. повторяют этап 2). При низких частотах дискретизации качество переходного процесса ухудшается настолько (в сравнении с непрерывной коррекцией), что платить за это понижением производительности ЦВМ не представляется возможным. Соответствующую ПФ Wк(z) используют в дальнейшем.
  • При синтезе ПФ Wк(s) или Wк(z) необходимо, что бы степень числителя Wк(s) не была больше степени знаменателя или свободный коэффициент a0 в знаменателе ПФ Wк(z) не был нулевым, иначе невозможно реализовать программу.
  • Если требуется обратный переход от Wк(z)НЧ к Wк(s)НЧ следует воспользоваться обратной формулой билинейного преобразования:

    Этот переход однозначен при известном периоде работы ЦВМ Tц.

Цифровые регуляторы

В непрерывных системах широко используются PID-регуляторы, которые представляются идеализированным уравнением:

.

где: KP - коэффициент усиления пропорционального канала; TIx - постоянная времени сопрягающего полюса интегрального канала; TDx - постоянная времени сопрягающего полюса дифференциального канала.

Для малых периодов дискретизации Tц уравнение может быть преобразовано в разностное без существенной потери в точности. Непрерывное интегрирование может быть представлено с помощью метода прямоугольников [image], или метода трапеций [image].

Используем метод прямоугольников для аппроксимации непрерывного интеграла и запишем PID-закон в дискретном виде:

Если в сумму включить и текущую выборку, то фазовый сдвиг интегрирующего канала будет чуть менее чем 90 градусов, а так он чуть более 90.

В результате получен нерекуррентный (позиционный) алгоритм управления, который требует сохранения всех предыдущих значений сигнала ошибки x[i], и в котором каждый раз заново вычисляется управляющий сигнал u[n].

Для реализации программ закона регулирования на ЦВМ более удобным является рекуррентный алгоритм. Он характеризуется тем, что для вычисления текущего значения сигнала u[n] используется его предыдущее значение u[n-1] и поправочный коэффициент, не требующий существенных вычислительных затрат. Определим его:

Если это РУ, но с не приведенными членами записать для изображений, затем перейти к z-ПФ представленной элементарными дробями, то получится PID регулятор с разделенными каналами, т.е. так можно получить дифференцирующий и интегрирующий дискретные элементы.

Перенесем u[n-1] в правую часть - получим "скоростной" алгоритм для программной реализации регулятора:

(*)

u[n] = u[n-1] + b0 x[n] + b1 x[n-1] + b2 x[n-2].

Если для аппроксимации непрерывного интеграла использовать метод трапеций, то разностное уравнение будет иметь вид:

.

Преобразования, аналогичные выше изложенным, при получении рекуррентного соотношения (*), выявляют отличия только для коэффициента b0:

.

Запишем РУ (*) для изображений в z-домене:

U [z] (1- z -1) = (b0 + b1 z -1 + b2 z -1) X [z] ,

и представим его в виде дискретной ПФ:

или Wpid(z) = K [ 1 + Tц/Ti (1/(z-1)) + Td/Tц (z-1)/z ].

Анализ ее коэффициентов показывает, что:

  1. Для исключения статической ошибки, ПФ должна иметь полюс zx=1.
  2. Если b2 = 0, то получим PI-регулятор.
  3. Если b0 = 0, а b1 = (1 + b2), то получим PD-регулятор.

Алгоритмы программ цифровых фильтров

Существует три основных алгоритма программной реализации дискретных передаточных функций (z-ПФ):

Алгоритм | Требуемое быстродействие | Объём памяти
Непосредственный а) с двумя буферами б) с одним буфером | 24(m+k+1) / Tц надо | 9m+9k+12 уточнить
Последовательный | 52k / Tц | 20k+10
Параллельный | 50k / Tц | 19k+8

Дискретную ПФ можно представить в любой из форм:

W(z) = | Y(z) | = | b0+b1z-1+...+bmz-m | - стандартная форма для дискретных ПФ
 | X(z) |  | a0+a1z-1+...+akz-k
W(z) = | Y(z) | = | K | 1+e2z-1 | ... | 1+ekz-1 | - разложение z-ПФ на множители [1]
 | X(z) |  | 1+d1z-1 | 1+d2z-1 |  | 1+dkz-1
W(z) = | Y(z) | = | P1 | + | P2 | +...+ | Pk | - разложение z-ПФ на элементарные дроби [1]
 | X(z) |  | 1+d1z-1 |  | 1+d2z-1 |  | 1+dkz-1

где: ei - нули z-ПФ; di - полюса z-ПФ; a0 - не равно нулю; Pi - коэффициенты разложения

Этим формам представления z-ПФ соответствуют структурные схемы изображенные на рис. 1.

Рис. 1

  • Разложения [image] и [image] делают параметры z-ПФ независимыми, позволяют контролировать ряд дополнительных фазовых координат: x1[n], x2[n], ..., xk-1[n]; или y1[n], y2[n], ..., yk[n] - что удобно при отладке систем.
  • Последовательная структура [image] удобна при синтезе дискретной коррекции.
  • Параллельная структура [image] удобна для построения цифровых регуляторов.
  • Разложение z-ПФ на элементарные дроби [image] позволяет реализовать z-ПФ на параллельно работающих ЦВМ для повышения быстродействия.

Перечисленные факторы определяют выбор алгоритма программы для ЦВМ.

После разложений, каждый из множителей в форме [image] или каждую из элементарных дробей в форме [image] следует представить в стандартной форме [image] (с отрицательными степенями оператора z). Переход к разностным уравнениям будет един. z-ПФ в форме [image] соответствует разностное уравнение (РУ):

Обший вид разностного уравнения (РУ БИХ-фильтра),

по которому и составляется программа. Поскольку текущее значение выходной координаты y[n] рассчитывается по предыдущим значениям y[n-1], y[n-2], y[n-k] - данное РУ называется рекурсивным.

Изобразим структурную схему цифрового фильтра для этого уравнения (см. рис. 2). Ее можно преобразовать, объединив два буфера (см. рис. 3). Цепочки элементов z-1 в программах будут соответствовать буферам из ячеек памяти, данные в которых сдвигаются на каждом такте дискретизации. Обе структурные схемы можно составить из простейших блоков программы VisSim.

Структурная схема рекурсивного цифрового фильтара

Структурной схеме соответствует алгоритм [image] а.
Условие физической реализуемости - а0 № 0
Рис. 2

Альтернативная структурная схема рекурсивного цифрового фильтара

Структурной схеме соответствует алгоритм [image] б.
Условие физической реализуемости - а0 № 0
Рис. 3

Если выбран последовательный [image] или параллельный [image] алгоритм, то структура каждого множителя или элементарной дроби первого порядка (см. рис. 1) будет иметь более простой вид (см. рис. 4).

Структурные схемы цифровых фильтров первого порядка
Рис. 4

Согласно структурной схеме рис. 2, составим процедуру реализующую дискретную ПФ второго порядка:

function y_zW(x) {
  y=( k * (x*b0+xz_1*b1+xz_2*b2)
        - (     yz_1*a1+yz_2*a2) ) / a0;
  xz_2=xz_1; xz_1=x;
  yz_2=yz_1; yz_1=y;
  return y;
};

где: xz_2, xz_1 и yz_2, yz_1 - ячейки двух буферов, т.е. регистры задержки - z -1.

Выберем коэффициенты z-ПФ для расчета переходной характеристики и построим ее:

K= |
b0= | b1= | b2=
a0= | a1= | a2=

Об эффекте квантования параметров

ПФ цифрового PID-регулятора имеет три коэффициента b0, b1, b2. Заметим, что только один коэффициент b1 содержит информацию о таком параметре регулятора как постоянная времени сопрягающего полюса интегрального канала TIx. Для объяснения сути эффекта квантования параметров рассмотрим не усугубляющий случай плотного расположения сопрягающих полюсов. Пусть TIx = 0,1; TDx = 0,01; при Tц = 0,0003. Рассчитаем коэффициент b1:

Заметим, что для любой системы отклонение любой постоянной времени в два раза не должно иметь критического значения, однако коэффициенты ПФ-ий, как показано, зависят от параметров отличающихся на порядки, поэтому скажем для отношения TDx/Tц, входящего во все коэффициенты числителя ПФ регулятора требуется сохранять мантиссу длиной 5 знакомест (17 двоичных разрядов), поскольку иначе информация о параметре TIx будет потеряна вследствие округления.

Существуют следующие методы преодоления эффекта квантования параметров при ограниченной длине мантиссы ЦВМ:

  1. Развязка параметров посредствам разложения z-ПФ высокого порядка либо на множители, либо на элементарные дроби.
  2. Подбор для реализации z-ПФ структурной схемы среди альтернативных, имеющих разные по плотности сетки возможных положений корней в единичной окружности.


БИХ-фильтры

Проектирование цифровых фильтров второго порядка с бесконечной импульсной характеристикой

Рабочие файлы: [Аналоговые прототипы дискретных фильтров]
Примеры ЧХ дискретного фильтра: [z2_tf_fr.vsm] [z2_tf_fr.mcd]

Передаточную функцию (ПФ) для дискретного фильтра любого типа можно получить из ПФ аналогового прототипа посредствам Билинейного преобразования (БЛП). Одновременно БЛП может быть использовано для масштабирующих операций в частотном домене. В частности для смещения полосы пропускания и регулировки ее ширины.

Дискретная ПФ фильтра второго порядка имеет вид:

(1)

            b0 + b1*z^-1 + b2*z^-2
    H(z) = ------------------------
            a0 + a1*z^-1 + a2*z^-2

Для сокращения нагрузки на ЦВМ шесть коэффициентов z-ПФ могут быть заменены эквивалентными, один из которых будет равен единице (одна из шести операций умножения будет сокращена). Если проектируемая z-ПФ лишь одна из нескольких включенных последовательно, то можно привести к единице еще один коэффициент, за счет коррекции общего коэффициента передачи цепочки фильтров или системы. Тогда z-ПФ будет иметь вид:

(2)

            (b0/a0) + (b1/a0)*z^-1 + (b2/a0)*z^-2
    H(z) = ---------------------------------------
               1 + (a1/a0)*z^-1 + (a2/a0)*z^-2

или

(3)

                      1 + (b1/b0)*z^-1 + (b2/b0)*z^-2
    H(z) = (b0/a0) * ---------------------------------
                      1 + (a1/a0)*z^-1 + (a2/a0)*z^-2

Дальнейшее сокращение операций умножения возможно, если z-ПФ имеет пары равных коэффициентов.

Рекуррентный алгоритм, реализующий z-ПФ (2), должен рассчитывать следующее разностное уравнение (РУ):

(4)

    y[n] = (b0/a0)*x[n] + (b1/a0)*x[n-1] + (b2/a0)*x[n-2]
                        - (a1/a0)*y[n-1] - (a2/a0)*y[n-2]

Параметры цифровых фильтров

1/dT = sampleRate
Частота дискретизации фильтра. Определяется как обратная величина от периода времени dT, через который цифровая вычислительная машина способна выполнять подпрограмму, рассчитывающую соответствующее разностное уравнение (4)
Частота (frequency)
В зависимости от типа фильтра - это "частота сопряжения" (оценивается по пересечению ЛАЧХ с уровнем -3 дБ), "резонансная частота" для полосового и режекторного фильтров, "центральная частота" полософормирующего фильтра, или "центральна частота наклонного участка" фильтра-ступени (фильтра-горки)
К в полосе (dBgain)
Коэффициент передачи на модифицируемом участке ЛАЧХ для полософормирующего фильтра и фильтра-ступени
Добротность (Q)
Отношение резонансной частоты фильтра к ширине его полосы. В зависимости от типа фильтра при формировании требований к ЧХ, бывает удобней пользоваться эквивалентными параметрами - "полосой" и "наклоном"
Полоса (bandwidth)
Ширина полосы рабочих частот фильтра. Для полосового и режекторного фильтров оценивается по пересечению их ЛАЧХ с уровнем -3 дБ. Для полософормирующего фильтра - по пересечению их ЛАЧХ с её средним уровнем (dBgain/2). Для фильтра-ступени - это длина наклонного участка
Наклон (shelf slope)
Модуль наклона ЛАЧХ фильтра-ступени. Максимально возможный наклон (без появления колебательности ЛАЧХ) равен 1 Белу за октаву. При задании малого значения наклона фильтр-ступень превращается в фильтр-лестницу (ЛАЧХ похожа на две ступеньки). Наклонный участок становится нелинейным

Вычисление коэффициентов цифровых фильтров

Аналоговые прототипы разрабатываются для приведенной (нормализованной) частоты. Данные прототипы, при оптимальной настройке, являются фильтрами Баттерворта (с максимально плоскими ЛАЧХ). Билинейное преобразование выполняется посредствам подстановки:

                1          1 - z^-1
   s  =  -------------- * ----------
          tan(omega/2)     1 + z^-1

Для вычисления тангенса при составлении программы используются тригонометрические тождества:

                 sin(w)                                 1 - cos(w)
   tan(w/2) = ------------              (tan(w/2))^2 = ------------
               1 + cos(w)                               1 + cos(w)

Расчет промежуточных переменных

A     = sqrt[ 10^(dBgain/20) ] =
      = 10^(dBgain/40)                    (только для полософормирующих фильтров)

omega = 2*pi*frequency/sampleRate

sin   = sin(omega)
cos   = cos(omega)

alpha = sin/(2*Q) =                                    (если задана Q)
      = sin*sinh[ ln(2)/2 * bandwidth * omega/sin ]    (если задана полоса)

    Отношение между шириной полосы и Q:
            1/Q = 2*sinh[ln(2)/2*bandwidth*omega/sin]  (для ЦФ на основе БЛП)
    or      1/Q = 2*sinh[ln(2)/2*bandwidth]            (для аналогового прототипа)

beta  = sqrt(A)/Q =                                    (только для фильтров-ступенек)
      = sqrt(A)*sqrt[ (A + 1/A)*(1/S - 1) + 2 ]        (если задан наклон горки)
      = sqrt[ (A^2 + 1)/S - (A-1)^2 ]

    Отношение между наклоном и Q:
            1/Q = sqrt[(A + 1/A)*(1/S - 1) + 2]
ФНЧ:	H(s) = 1 / (s^2 + s/Q + 1)

    b0 =  (1 - cos)/2
    b1 =   1 - cos
    b2 =  (1 - cos)/2
    a0 =   1 + alpha
    a1 =  -2*cos
    a2 =   1 - alpha

ФВЧ:	H(s) = s^2 / (s^2 + s/Q + 1)

    b0 =  (1 + cos)/2
    b1 = -(1 + cos)
    b2 =  (1 + cos)/2
    a0 =   1 + alpha
    a1 =  -2*cos
    a2 =   1 - alpha

ПФ:	H(s) = s / (s^2 + s/Q + 1)          (пик АЧХ = Q)

    b0 =   sin/2  =   Q*alpha
    b1 =   0
    b2 =  -sin/2  =  -Q*alpha
    a0 =   1 + alpha
    a1 =  -2*cos
    a2 =   1 - alpha

ПФ:	H(s) = (s/Q) / (s^2 + s/Q + 1)      (пик АЧХ = 0 dB)

    b0 =   alpha
    b1 =   0
    b2 =  -alpha
    a0 =   1 + alpha
    a1 =  -2*cos
    a2 =   1 - alpha

Режекторный фильтр или фильтр - пробка:
    H(s) = (s^2 + 1) / (s^2 + s/Q + 1)

    b0 =   1
    b1 =  -2*cos
    b2 =   1
    a0 =   1 + alpha
    a1 =  -2*cos
    a2 =   1 - alpha

Фазовращающий фильтр:
    H(s) = (s^2 - s/Q + 1) / (s^2 + s/Q + 1)

    b0 =   1 - alpha
    b1 =  -2*cos
    b2 =   1 + alpha
    a0 =   1 + alpha
    a1 =  -2*cos
    a2 =   1 - alpha

Полософормирующий фильтр (для эквалайзеров):
    H(s) = (s^2 + s*(A/Q) + 1) / (s^2 + s/(A*Q) + 1)

    b0 =   1 + alpha*A
    b1 =  -2*cos
    b2 =   1 - alpha*A
    a0 =   1 + alpha/A
    a1 =  -2*cos
    a2 =   1 - alpha/A

Фильтр - НЧ-ступень-лестница:
    H(s) = A * (s^2 + (sqrt(A)/Q)*s + A) / (A*s^2 + (sqrt(A)/Q)*s + 1)

    b0 =    A*[ (A+1) - (A-1)*cos + beta*sin ]
    b1 =  2*A*[ (A-1) - (A+1)*cos            ]
    b2 =    A*[ (A+1) - (A-1)*cos - beta*sin ]
    a0 =        (A+1) + (A-1)*cos + beta*sin
    a1 =   -2*[ (A-1) + (A+1)*cos            ]
    a2 =        (A+1) + (A-1)*cos - beta*sin

Фильтр - ВЧ-ступень-лестница:
    H(s) = A * (A*s^2 + (sqrt(A)/Q)*s + 1) / (s^2 + (sqrt(A)/Q)*s + A)

    b0 =    A*[ (A+1) + (A-1)*cos + beta*sin ]
    b1 = -2*A*[ (A-1) + (A+1)*cos            ]
    b2 =    A*[ (A+1) + (A-1)*cos - beta*sin ]
    a0 =        (A+1) - (A-1)*cos + beta*sin
    a1 =    2*[ (A-1) - (A+1)*cos            ]
    a2 =        (A+1) - (A-1)*cos - beta*sin

Мастер для генерации коэффициентов дискретного фильтра

Встроенный ниже в html-страницу мастер корректно визуализируется и функционирует в браузере MSIE 5.0. Отображение мастера меняется не существенно в браузере Opera 6.04, и логика работы с мастером не нарушается. В браузере Netscape 7.0 мастер не работает.

Три коэффициента числителя (b0, b1, b2) и три коэффициента знаменателя (a0, a1, a2) z-ПФ в соответствующем порядке выводятся мастером в двух нижних строках. В качестве разделителя используется пробел. Рекомендуется пользоваться клавиатурным копированием (Ctrl+c и Ctrl+v) для переноса коэффициентов в блок "Передаточная функция" моделирующей программы. Для перехода между полями формы используйте клавиши Tab и Shift+Tab.

БИХ-фильтр второго порядка
Тип:
: = f/Df
: = f/Df
К в полосе: [дБ]
Аналоговый прототип (w=1):
k:
Числ:
Знам:
Дискретный фильтр:
1/dT: [Гц]
Частота: [Гц]
Числ:
Знам:

Приведенная ниже форма позволяет на основе коэффициентов рассчитанных мастером построить частотные характеристики соответствующего дискретного фильтра. Скрипт считает ЧХ именно дискретной системы, а не ее линеаризованного аппроксиматора (в большинстве моделирующих программ для построения ЧХ дискретной системы выполняется обратное БЛП и строятся ЧХ линеаризованного аппроксиматора). С ознакомительными целями Вы можете выполнить расчеты для выбранных по умолчанию установок. Поскольку графики строятся в Excel'е, Вы должны ответить положительно на вопрос системы безопасности программы MSIE о том запускать ActiveX компонент (Excel) или нет.

Построение ЛАЧХ & ЛФЧХ (в Excel'e)
Начальная частота: [рад/с]
Считать для декад: (100 точек / дек)
+ АЧХ & ФЧХ: ( + 30 сек )


ТАУ - РУКОВОДСТВО К ВЫПОЛНЕНИЮ ЛАБОРАТОРНЫХ РАБОТ

ПРИМЕРЫ ДЛЯ САМОСТОЯТЕЛЬНОГО ИЗУЧЕНИЯ И СПРАВОЧНЫЙ МАТЕРИАЛ

Моделирование в программе VisSim

Переходный процесс в "RLC" схеме: | [rlc.vsm]
Модели измерителей электрических величин: | [rms_ex.vsm] [meter.vsm]
Поиск корней уравнения: | [roots.vsm]
Звенья с модулированным сигналом: | [fil_resp.vsm] [pwm_ex.vsm]
Звено чистого запаздывания: | [vtcdelay.vsm]
Релейные САР: | [roomctrl.vsm]
Импульсные САР: | [bworth.vsm]
Диаграмма Вышнеградского: | [vishngrd.vsm]
Линии уровня показателя колебательности М: | [m.vsm]
W(s) на основе характеристического полинома D(s): | [order3.vsm]
Коррекция САР, коррекция жесткой ОС & изодромный блок на апериодическом звене: | [2ou+kor.ca4] [ouhik&f1.vsm] [kor_ooc1.vsm & kor_ooc2.vsm]
Дельта-сигма АЦП: | [adc_dsigm.vsm]
Импульсная характеристика КИХ-фильтра: | [fir.vsm]
Универсальные блок-схемы для составления моделей: | [tf_univr.vsm]
Прямое и обратное быстрые преобразования Фурье (БПФ): | [fft.vsm]
Ряды Фурье: | [furye1.vsm]
Оценка мощности спектра сигнала: | [psd.vsm]
Генераторы на z-ПФ с начальными условиями: | [gen_z.vsm]

Моделирование в программе Electronics Workbench

Модели устройств выборки хранения (УВХ): | [yvx1.ca4] [yvx2.ca4] [yvx3.ca4] [yvx4.ca4]
ЦАП на ШИ-модуляторе: | [dac_pwm.ca4]
Последовательный ЦАП на переключаемых конденсаторах: | [dac_2c.ca4]
Параллельный ЦАП на R-2R матрице постоянного импеданса: | [dac_r2r.ca4]
Параллельный ЦАП на коммутируемых конденсаторах: | [dac_nc.ca4]

ПЛАН РАЗВИТИЯ ДАННОГО РУКОВОДСТВА

  1. Разработка лабораторных работ для второго семестра (нелинейные и цифровые системы) (к февралю 2001г.).
  2. Дальнейшая взаимная интеграция моделей из разных моделирующих пакетов. Организация одновременной работы моделей (в разных пакетах) в динамическом режиме посредствам технологий динамического обмена данными (DDE - dinamic data exchange, на базе ActiveX). Пример: регулятор в пакете Electronics Workbench, объект в пакете VisSim, - должны работать совместно.
  3. Разработка моделей, предполагающих наличие в контуре модели реального технического устройства, подключенного посредством платы сбора данных - (DAQ-board).
  4. Подготовка моделей для альтернативных моделирующих пакетов, например "МВТУ" (если будет договоренность с разработчиками).

30.10.2000

Сделать "D-разбиение" по вариантам см. задачник.

1. Цель работы | 2. Предварительное домашнее задание | 3. Содержание работы
4. Обработка результатов | 5. Методические указания к моделированию и рекомендации к содержанию отчета | 6. Контрольные вопросы

Работа 4

3.7. Провести исследование устойчивости модели электронного усилителя на трехкаскадном ОУ (файлы ou3.vsm и ou2+1.ca4)
3.8. Исследовать влияние контурного коэффициента усиления на полосу пропускания замкнутой системы на примере электронного усилителя на ОУ.

Работа 5?[err_pid.vsm] [PIDTUNE.vsm]

Выяснение сути корневых методов оценки качества.

Работа 6?[ASTATIC.vsm]

Изучение основных методов повышения точности САР: 1) увеличение коэффициента усиления разомкнутой цепи, 2) применение регулирования по производным от ошибки с увеличением контурного коэффициента усиления, 3) повышение степени астатизма, 4) применение неединичных обратных связей или масштабирующих устройств на входе / выходе и 5) комбинированного управления.

4.3. Выполнить количественное исследование результатов применения методов повышения точности САР на основе исследований (измерений) ошибки x(t). По необходимости рекомендуется использовать тест-сигналы задания g(t): единичную ступенчатую функцию 1(t), синусоидальный, меняющийся с постоянной скоростью или ускорением (см. сигнал g(t) в файле err_ast3.vsm). Для измерений ошибки рекомендуется использовать: датчики скорости и ускорения (дифференцирующие звенья), преобразователи построенные в соответствии с интегральными оценками качества, а так же измерители действующего или средневыпрямленного значений. Выбор схемы измерения ошибки x(t) следует обосновать.
3.6. Определить первые коэффициенты ошибок систем до и после применения методов повышения точности.
(можно измерить первые коэффициенты ошибок систем до и после повышения точности).

4.1. Один из методов повышения точности САР - это повышение степени астатизма. Метод реализуется применением либо интегрирующего, либо изодромного звена включаемого в разрыв контура регулирования. Качественно описать результаты применения упомянутых технических решений (в сравнении). Сформулировать достоинства, недостатки (ограничения в применении). Привести поясняющие графические зависимости (информацию удобно представить в режиме пререкрытия графиков).

Работа 8 [Ak_wk.vsm] [wo.vsm]

Среди предложенных моделей идентифицировать устойчивые в разомкнутом состоянии.
3.2. Для неустойчивых в разомкнутом состоянии систем спроектировать последовательные компенсационные звенья.


Теория систем автоматического регулирования

681.5(07)
К493 		VisSim.nm.ru & VisSim.com

Н. В. Клиначёв

МОДЕЛИРОВАНИЕ ОБЫКНОВЕННЫХ
И ОСОБЫХ ЛИНЕЙНЫХ СИСТЕМ

ТАУ, ЭЛЕКТРОНИКА

Руководство к лабораторным работам в пакетах
VisSim и Electronics Workbench


УДК 681.5(07) K493

УДК 681.51.01(076.5)+621.51.015.26(076.5)+621.382.81(076.5)
K493

Клиначёв Н. В. Моделирование обыкновенных и особых линейных систем. ТАУ, Электроника: Руководство к лабораторным работам в пакетах VisSim и Electronics Workbench. - Offline версия 1.7. - Челябинск, 2002. - 97 файлов, ил.

Руководство предназначено для студентов электротехнических специальностей, изучающих курсы "Теория автоматического управления" (ТАУ), "Моделирование систем управления" и им подобных. Лабораторные исследования проводятся на персональных ЭВМ с применением моделирующих пакетов VisSim и Electronics Workbench. Совокупность учебных моделей разбита на две группы. Ядром являются модели для пакета VisSim, которые не отражают особенности конкретных систем, являются чисто математическими и построены на основе задания структурных схем и передаточных функций. Они могут быть использованы для любой специальности вплоть до нетехнических. Вторая группа моделей для пакета Electronics Workbench предназначена для студентов электротехнических специальностей и отражает особенности технических решений из схемотехники устройств на операционных усилителях (ОУ). Совокупность работ закрывает потребность в лабораторном практикуме по обыкновенным и особым линейным системам автоматического регулирования и рассчитана на выполнение в течение двух семестров.

Ил. 26, табл. 10, учебных моделей 74, список лит. - 12 назв.

Одобрено учебно-методической комиссией автотракторного факультета Южно-Уральского государственного университета.

Рецензенты: зав. кафедрой "Автоматика и телемеханика" Дальневосточного государственного университета путей сообщения, д.т.н., профессор Г. П. Малай, и зам. зав. кафедры "Автоматизация и управление" Азербайджанского технического университета, к.т.н., доц. М. Б. Намазов.

© Н.В. Клиначёв, 2000-2002.

Инструкции

Данное руководство - это электронная версия документа tau.doc или tau_a5.doc. Назначение электронной версии - быстрый и систематизированный доступ во время занятий к тексту пособия, к изучаемым моделям, а так же, при необходимости, к конспекту лекций, и к тестам. Операционная система установленная на компьютерах должна распознавать расширения рабочих файлов (*.vsm и *.ca4) и, при активации в руководстве соответствующих гипертекстовых ссылок, должна автоматически запускать приложения VisSim и Electronics Workbench. Информация о версиях пакетов, их изготовителях и архиве моделей приведена в разделе "Требуемые программные пакеты". Достаточно, если студенты будут проинструктированы о порядке запуска электронного руководства (tau_knv.chm).

Требуемые программные пакеты

  1. Электронное руководство к лабораторным работам вошедшее в учебно-методический комплекс (файл tau_knv.chm) выполнено в соответствии со стандартом Windows-HTML-справки. Оно представляет собой один файл, в котором заархивированы html-страницы, учебные модели (рабочие файлы программ VisSim и Electronics Workbench), рисунки и необходимые скрипты. Файл пособия автоматически распознается и запускается операционной системой Windows 98 (NT, 2000), точнее браузером MSIE версии не ниже 4.0. Пользователям Windows 95 (NT) возможно потребуется установить Windows-HTML-справку. Для чего на сайте фирмы Microsoft следует найти установочный файл hhupd.exe (733 KB).
  2. Для организации учебного процесса следует получить пакет VisSim FAP 3.0 по "Бесплатной Академической Программе" (http://www.vissim.com). См. также сайт "VisSim в России" (http://vissim.nm.ru). Большинство работ можно выполнить, используя старую версию пакета - VisSim 1.2, в которой нет годографа Найквиста и оптимизации. Достоинство этого варианта в том, что руководство, модели и пакет умещаются на одной дискете и легко могут быть предоставлены студентам для самостоятельной работы дома. В первой работе имеется ссылка на демонстрационный файл csd_new.scm, который можно получить по адресу http://www.vissim.com/downloads/demos.html. В форме нужно отметить пункт «Control system design demo». Отсутствие файла может быть компенсировано рассказом преподавателя о пакете.
  3. Требуемая версия пакета Electronics Workbench не ниже 4.1. Адрес сайта изготовителя - http://www.electronicsworkbench.com.

Обновленные версии руководства доступны на сайте "VisSim в России". Архив руководства можно получить по электронной почте, направив письмо-запрос автору (klinacherv_nv@mail.ru). При возможных изменениях в адресах рекомендуется воспользоваться поисковыми системами, используя ключевые слова: VisSim, симуляция движения, моделирование, Nikolay Klinachyov. Клиначёв Николай Васильевич


Оглавление лекций Клиначёва по ТАУ

Перечень лабораторных занятий по дисциплине
"Теория систем автоматического регулирования"

ЧАСТЬ 1

1. Знакомство с моделирующим ПО
2. Типовые динамические звенья
3. Принципы и законы регули-вания
4. Анализ устойчивости САР
5. Оценка качества регулирования
6. Повышение точности САР
7. Коррекция САР
8. Синтез САР

ЧАСТЬ 2

09. САР с var-параметрами
10. Системы с запаздванием
11. Импульсные системы
12. Цифровые системы
13. Релейные системы

Справочный материал


ТАУ - РУКОВОДСТВО К ВЫПОЛНЕНИЮ ЛАБОРАТОРНЫХ РАБОТ

Лабораторная работа 1
ПРИНЦИПЫ ФУНКЦИОНИРОВАНИЯ МОДЕЛИРУЮЩИХ ПАКЕТОВ

Рабочие файлы: [csd_new.scm] [rlc.vsm] [rlc.ca4]

1. Цель работы

Приобретение навыков работы с моделирующими программными пакетам VisSim и Electronics Workbench. Ознакомление с главными этапами моделирования. Определение общих методов представления результатов. Выяснение сути задания параметров моделирования и начальных условий состояния системы.

2. Содержание работы

2.1. Выяснить порядок запуска используемых программных пакетов VisSim и Electronics Workbench.

2.2. Просмотреть демонстрацию работы программы VisSim (файл csd_new.scm - control system design demo). Выявить а) назначение программы, б) основные этапы работы с программой.

2.3. Запустить программу VisSim. Ознакомиться с содержанием меню. Загрузить файл rlc.vsm с моделью "RLC"-цепи и изучить модель. Записать уравнение модели. Определить параметры моделируемых элементов и начальные условия в схеме. Изменить начальные условия и параметры модели по собственному усмотрению.

2.4. Запустить программу Electronics Workbench. Ознакомиться с содержанием меню. Составить "RLC"-цепь получить переходный процесс подобный полученному в пакете VisSim.
2.5. По вариантам (см. табл.) спроектировать модели источников периодического сигнала в пакете VisSim. Измерить и при необходимости компенсировать постоянную составляющую в сигнале. Использовать блок "plot" для осциллографирования.

Вариант | Форма сигнала | Частота, кГц | Амплитуда, ед.
1 | Прямоугольный скважность 1:2 | 10 | 10
2 | Треугольный | 20 | 20
3 | Линейно нарастающий | 30 | 30
4 | Нарастающий по параболе | 40 | 40
5 | Модуль синусоиды | 50 | 50

3. Методические указания к моделированию и рекомендации к содержанию отчета

3.1. Кратко описать принципы функционирования программных пакетов VisSim и Electronics Workbench.

3.2. Привести распечатки, подтверждающие выполнение всех пунктов экспериментальной части и текстовые пояснения к ним. Для модели "RLC"-цепи записать уравнение, подставить в него параметры элементов и начальные условия, а также полностью охарактеризовать переходный процесс.

3.3. Для измерения постоянной составляющей (см. пп. 2.5) следует составить блок-схему соответствующую магнитоэлектрическому измерительному механизму, который реагирует на среднее значение. Главный блок в модели измерительного преобразователя - интегратор.

3.4. Выводы.


ТАУ - РУКОВОДСТВО К ВЫПОЛНЕНИЮ ЛАБОРАТОРНЫХ РАБОТ

Лабораторная работа 2
ТИПОВЫЕ ДИНАМИЧЕСКИЕ ЗВЕНЬЯ

Рабочие файлы: [zvenya.vsm] [k((1+tp)(1+tp))^-1.ca4] [k(1+2etp+(tp)^2)^-1.ca4] [k(p^-1).ca4] [kp.ca4]

1. Цель работы

Исследование взаимосвязей между параметрами типовых динамических звеньев и их характеристиками. Идентификация реальных технических устройств - схем на операционных усилителях с типовыми звеньями (т.е. с математическим описанием). Приобретение навыков использования типовых возмущающих воздействий и инструментов частотного анализа для исследования систем.

2. Предварительное домашнее задание

2.1. Составить уравнения и вывести передаточные функции W(p) для всех блоков файла zvenya.vsm. Сравнить полученные передаточные функции с типовыми, идентифицировать блоки по названиям.

3. Содержание работы

3.1. В программе VisSim ознакомиться с моделями единичной ступенчатой функции - 1(t) и дельта-функции - 1'(t) (файл zvenya.vsm). Выявить положенные допущения (неидеальности) в моделях.

3.2. В программе VisSim (файл zvenya.vsm) выполнить исследование типовых динамических звеньев (см. п. "Методические указания к моделированию и рекомендации к содержанию отчета"). По ходу работы необходимо изменить постоянные времени, коэффициенты затухания и усиления по своему усмотрению. Убедится, что дифференцирование переходной функции звена - h(t) дает его функцию веса - w(t); и наоборот, интегрирование функции веса звена - w(t) дает его переходную функцию - h(t).

3.3. Выполнить измерения виртуальными приборами (анализатор, осциллограф) в схемах на операционных усилителях (файлы *.ca4 для программы Electronics Workbench) с целью идентификации моделей с типовыми динамическими звеньями. Настроить схемы по совпадению вида ЛАЧХ & ЛФЧХ, а так же реакций подобных переходной функции и функции веса. Допустимо несовпадение только коэффициентов усиления.

3.4. Подавая на вход типовых динамических звеньев синусоидальный сигнал, убедиться, что изменение коэффициента усиления вне полосы пропускания за одну декаду составляет либо 20 дб (10 раз), либо 40 дб (100 раз).

4. Методические указания к моделированию и рекомендации к содержанию отчета

4.1. Привести названия и графики использованных типовых возмущающих воздействий. Описать изменения в реакции типовых звеньев на варьирование параметров воздействий.

4.2. Для каждого звена привести: а) название звена; б) структурную схему (подписав входную величину, выходную, сигнал ошибки и обратной связи); в) вывод передаточной функции (подставить коэффициенты усиления и постоянные времени; проверить соответствие с линеаризованной передаточной функцией, которую рассчитывает программа VisSim (Analyze, Transfer Function Info); записать координаты корней и полюсов функции); г) список параметров с описанием характера влияния (на ЛАЧХ & ЛФЧХ, переходные процессы, ...); д) переходную функцию; е) функцию веса; ж) ЛАЧХ & ЛФЧХ (определить достигает ли фаза значения -180 градусов в диапазоне частот и если да, то имеет ли звено на данной частоте коэффициент усиления больший единицы); з) диаграмму Найквиста (определить охватывает ли АФХ точку (-1, j0); отметить траектории для положительных и отрицательных частот; точки, в которых частота стремится к нулю и к бесконечности); и) корневой годограф (определить имеются ли нулевой, положительные, или чисто мнимые корни; если есть парные корни с мнимой частью, то по мнимой части определить собственную частоту колебаний звена и сравнить с колебаниями переходной функции или функции веса, сделать вывод об устойчивости звеньев).

4.3. Указать на неидеальности, присущие свойствам, которыми обладают реальные дифференцирующие устройства и их компьютерные дискретные модели. Пояснить причину неидеальности в дискретных моделях.

4.4. Кроме осциллограмм, ЛАЧХ & ЛФЧХ подтверждающих результаты настройки схем по пп. 3.3 необходимо привести схемы проведения измерений (включая источники тест-сигналов) и дать пояснения к ним.


ТАУ - РУКОВОДСТВО К ВЫПОЛНЕНИЮ ЛАБОРАТОРНЫХ РАБОТ

Лабораторная работа 3
ПРИНЦИПЫ И ЗАКОНЫ РЕГУЛИРОВАНИЯ

Рабочие файлы: [open.vsm] [closed.vsm] [pid.ca4]

1. Цель работы

Ознакомление с принципами разомкнутого и замкнутого регулирования. Исследование процессов преобразования сигналов в каналах типового ПИД-регулятора. Изучение свойств непрерывных законов регулирования: пропорционального (П), интегрального (И), изодромного (ПИ) и вариантов с дифференцирующим каналом (ПД, ПИД).

2. Предварительное домашнее задание

2.1. Составить передаточные функции W(p) для всех блоков структурных схем рабочих файлов.

3. Содержание работы

3.1. Изучить параметры сигнала задания g(t) в файле open.vsm. (определить интервалы, где координата задания постоянна, меняется с постоянной скоростью или с постоянным ускорением).

3.2. Включая каналы типового ПИД-регулятора по очереди, изучить, как формируется сигнал воздействия на объект - u(t) из первичной информации - x(t) (файл open.vsm).

3.3. В файлах open.vsm и closed.vsm коэффициенты усиления регуляторов оптимально настроены для управления объектом в соответствии с принципами Понселе (без ОС) и Ползунова-Уатта (с ОС). По своему усмотрению изменить параметры объекта и вновь настроить регуляторы.

3.4. Оценить степень влияния изменений параметров объекта на ошибку регулирования для обоих вариантов управления. При анализе следует учесть, что статическую составляющую ошибки определяет нестабильность коэффициента усиления объекта, а динамическую - его постоянная времени.

3.5. Изучить реализацию ПИД-регулятора на ОУ (файл pid.ca4).

4. Методические указания к моделированию и рекомендации к содержанию отчета

4.1. Привести общее описание типового ПИД-регулятора (структурная схема, дифференциальное уравнение или передаточная функция, основные параметры).

4.2. Описать принципиальные отличия в формировании сигнала воздействия на объект u(t) каналами типового ПИД-регулятора (сравнительный анализ): а) при малых возмущениях в первичной информации x(t), и при больших; б) при постоянстве входной координаты, при движении её с постоянной скоростью и с постоянным ускорением. Привести поясняющие графические зависимости.

4.3. Привести переходные процессы: а) при оптимальных настройках регуляторов для разных принципов регулирования объектом; б) для тех же случаев, с теми же настройками, но при отклонениях параметров объекта. Дать пояснения.

4.4. Построить два семейства зависимостей приведенной статической погрешности от изменения коэффициента усиления объекта при разных коэффициентах передачи пропорционального канала регулятора. В первом случае - для управления с ОС, во втором - без ОС. Первое семейство погрешностей привести к сигналу задания 1(t), второе - к среднему значению коэффициента усиления для каждой вариации (семейство вырождается в один график). Пояснить результаты.

4.5. Определить для модели ПИД-регулятора на ОУ коэффициенты усиления каждого канала. Для интегрального и дифференциального каналов необходимо указать граничные (сопрягающие) частоты или соответствующие постоянные времени. Нанести значения параметров на ЛАЧХ & ЛФЧХ регулятора. Выявить соответствие между параметрами и элементами схемы. Описать, какие ограничения накладывает частотная характеристика типового ОУ на параметры ПИД-регулятора. Продемонстрировать изменения сдвига фаз сигналов на характерных участках частотных характеристик, используя сигнал синусоидальной формы. При выполнении экспериментов следует учитывать, что данный ПИД-регулятор инвертирует сигнал.


ТАУ - РУКОВОДСТВО К ВЫПОЛНЕНИЮ ЛАБОРАТОРНЫХ РАБОТ

Лабораторная работа 4
АНАЛИЗ УСТОЙЧИВОСТИ ЛИНЕЙНЫХ САР

Рабочие файлы: [mihaylo4.vsm] [d_4_k&t.vsm] [nyquist.vsm] [ou3.vsm] [ou2+1.ca4]

1. Цель работы

Приобретение навыков использования критериев устойчивости Михайлова и Найквиста. Исследование влияний параметров систем на их устойчивость. Изучение методики применения D-разбиения.

2. Предварительное домашнее задание

2.1. По передаточной функции разомкнутой системы (файл mihaylo4.vsm) записать ее характеристический полином D(p), определить его коэффициенты, выделить мнимую и вещественную составляющие.

2.2. Без применения программных инструментов построить асимптотические ЛАЧХ & ЛФЧХ для передаточных функций:

W(p) = 4 | 0,5p+1 | ; W(p) = 1 | 2p+1 | ; W(p) = 1 | 2p2+p+1
 | p2-p |  | 0,15p+p |  | p3

2.3. Для передаточных функций W(p) (файл nyquist.vsm) вывести передаточные функции соответствующих замкнутых систем Ф(p).

2.4. Самостоятельно познакомиться с сутью итерационных алгоритмов.

3. Содержание работы

3.1. Исследовать границу устойчивости (типы границы устойчивости), используя возможность пакета VisSim задать передаточную функцию с помощью перечисления корней (нулей и полюсов её числителя и знаменателя). Убедиться, что только корни-полюсы с неотрицательной вещественной частью приводят к расходящемуся переходному процессу.

3.2. Исследовать влияние корней характеристического полинома на вид годографа Михайлова (файл mihaylo4.vsm).

3.3. Изучить влияние контурного коэффициента усиления на устойчивость системы и вид годографа Михайлова.

3.4. Задавая постоянную времени T2 по варианту (см. табл.), подбором найти коэффициент усиления системы, при котором она будет находиться на колебательной границе устойчивости. В качестве признака границы использовать критерий Михайлова.

Вариант | 1 | 2 | 3 | 4 | 5
T2 | 0,12; 0,42; 0,72 | 0,18; 0,48; 0,78 | 0,24; 0,54; 0,84 | 0,30; 0,60; 0,90 | 0,36; 0,66; 0,96

3.5. Познакомиться с применением D-разбиения (файл d_4_k&t.vsm). Убедиться, что параметры, см. пп. 3.4, образуют точки на границе разбиения. Определить частоты для этих точек.

3.6. Исследовать на устойчивость передаточные функции, предложенные в файле nyquist.vsm, применяя годограф Найквиста и логарифмические частотные характеристики.

3.7. Изучить характер влияния контурного коэффициента усиления на устойчивость и на полосу пропускания замкнутой системы - модели электронного усилителя на трехкаскадном ОУ (файлы ou3.vsm и ou2+1.ca4). Менять контурный коэффициент усиления предполагается делителем в цепи обратной связи.

4. Методические указания к моделированию и рекомендации к содержанию отчета

4.1. Для произвольно спроектированных передаточных функций привести переходные процессы, соответствующие наличию: а) одного и двух нулевых корней-полюсов; б) паре чисто мнимых корней-полюсов; в) корню-полюсу с положительной вещественной частью.

4.2. Убедиться, что каждый корень-полюс с отрицательной вещественной частью разворачивает годограф Михайлова на 90 градусов против часовой стрелки, а с положительной - на 90 градусов по часовой.

4.3. Продемонстрировать влияние коэффициента усиления на вид переходных процессов и вид годографа Михайлова (в режиме перекрытия графиков).

4.4. Для D-разбиения, указать область устойчивости (подтвердить моделированием) и выяснить влияние параметров на ее размер.

4.5. Среди предложенных к изучению с помощью годографа Найквиста и логарифмических частотных характеристик найти передаточные функции, отвечающие следующим признакам: а) астатические (указать порядок); б) имеющие корни-полюсы с положительной вещественной частью (Transfer Function Info); б) неустойчивые в разомкнутом состоянии; в) неустойчивые в замкнутом состоянии; ж) в которых понижение коэффициента усиления приведет к появлению неустойчивости в замкнутом состоянии; з) в которых повышение коэффициента усиления приведет к появлению неустойчивости в замкнутом состоянии; д) условно устойчивые; г) абсолютно устойчивые. Результаты свести в таблицу с отметками "+" и "-". Методика получения результатов должна быть отображена.

4.6. Пункт 3.7 предполагает построение семейств ЛАЧХ & ЛФЧХ для разомкнутой и замкнутой систем, при варьировании контурного коэффициента усиления электронного усилителя. Для замкнутой системы дополнительно требуется получить семейство переходных характеристик. Кроме пояснения графических результатов, в отчете привести описание модели трехкаскадного ОУ. Модель для пакета Electronics Workbench (ou2+1.ca4) предполагается использовать для сравнительного контроля полученных результатов.

4.7. Описать с точки зрения удобства применения в исследованиях годографы Михайлова, Найквиста и ЛАЧХ.


ТАУ - РУКОВОДСТВО К ВЫПОЛНЕНИЮ ЛАБОРАТОРНЫХ РАБОТ

Лабораторная работа 5
ОЦЕНКА КАЧЕСТВА РЕГУЛИРОВАНИЯ

Рабочие файлы: [err_ast3.vsm] [err_s^-1.vsm]

1. Цель работы

Ознакомление с основными группами критериев качества (оценивающими точность, устойчивость, быстродействие и обобщенные свойства САР). Изучение методики использования интегральных оценок качества при исследовании ошибок систем в типовых режимах движения. Приобретение навыков оценки качества по переходной характеристике и по АЧХ замкнутой системы.

2. Предварительное домашнее задание

Приравнивая в структурной схеме (файл err_ast3.vsm) коэффициенты усиления (KI1 & KI2 & KI3), или (KI2 & KI3) или (KI3) к нулю, можно получить модели САР с астатизмом от нулевого до третьего порядков (считая исходную).

2.1. Начальные значения коэффициентов усиления установить в соответствии с вариантом (см. табл.). Вывести передаточные функции по ошибке Фx(p) для четырех моделей САР при астатизме от нулевого до третьего порядка.

Вариант | 1 | 2 | 3 | 4 | 5
KI1; KI2; KI3 | 25; 50; 60 | 30; 50; 70 | 35; 50; 80 | 45; 50; 90 | 50; 50; 100

2.2. Для тех же моделей вывести формулы расчёта первых четырёх коэффициентов ошибки и определить их числовые значения.

2.3. Описать суть интегральной и улучшенной интегральной оценок качества.

2.4. Составить функцию цены из блоков пакета VisSim, подсчитывающую количество переходов через ноль ошибки САР в переходном процессе.

3. Содержание работы

3.1. Изучить сигнал задания g(t) спроектированный для введения систем в режимы типового движения (файл err_ast3.vsm). Заполнить таблицу.

Временной промежуток постоянства параметров сигнала
Параметр сигнала и его значение

3.2. Измерить значения первых четырех установившихся ошибок по: положению q0, скорости qu, ускорению qe, и приращению ускорения qg''' для систем с астатизмом от нулевого до третьего порядков (файл err_ast3.vsm). Параметры моделей должны соответствовать расчетному заданию. Опираясь на экспериментальные данные определить коэффициент усиления систем в области низких частот K, а так же добротности по скорости Ku, ускорению Ke и приращению ускорения Kg'''. Определить численные значения коэффициентов ошибок по положению, скорости, ускорению и приращению ускорения - c0, c1, c2, c3. Заполнить таблицу.

Система \ Ошибки | q0 & K & c0 | qu & Ku & c1 | qe & Ke & c2 | qg''' & Kg''' & c3
W(p)=1/p^0 * ... |  |  |  |
W(p)=1/p^1 * ... |  |  |  |
W(p)=1/p^2 * ... |  |  |  |
W(p)=1/p^3 * ... |  |  |  |

3.3. Изучить влияние (качественно) на вид переходной функции h(t) систем с астатизмом первого второго (и третьего по указанию преподавателя) порядков возмущающего воздействия f(t). В качестве f(t) использовать сигнал задания g(t) спроектированный для изучения типовых режимов движения систем. Возмущающее воздействие подавать до и после интегрирующих элементов, менять его знак и подбирать амплитуду так, чтобы ошибка от возмущения в установившемся режиме составляла 10...30 % от h(t) и была наглядна при визуальном наблюдении (информацию удобно представить в режиме перекрытия графиков).

3.4. Минимум три раза оптимально настроить ПИД-регулятор для модели системы регулирования (файл err_s^-1.vsm), используя разные функции цены - интегральные оценки качества. Для каждого случая заполнить таблицу.

KP | KI | KD
Функция цены и переходная характеристика h(t)

3.5. Оценить запас устойчивости и быстродействие по переходным характеристикам системы при различных настройках ПИД-регулятора, используя показатели качества: перерегулирование s, длительность переходного процесса tП, частота колебаний f, допустимое число колебаний, время запаздывания tЗ, время нарастания tН. Величиной допустимых отклонений 2D для определения длительности переходного процесса задаться самостоятельно.

3.6. Для тех же вариантов настроек ПИД-регулятора, используя АЧХ замкнутой системы |Ф(jw)| определить показатель колебательности М и показатели быстродействия: резонансную частоту wР, полосу пропускания wП, частоту среза wС, и эквивалентную полосу пропускания wЭ.

3.7. Для тех же случаев, определить запас устойчивости по амплитуде (модулю) L и по фазе m, используя АФХ (годограф Найквиста). Повторить определение по ЛАЧХ & ЛФЧХ.

4. Методические указания к моделированию и рекомендации к содержанию отчета

4.1. Исследование точности в типовых режимах (пп. 3.1, 3.2, 3.3) следует проиллюстрировать временными зависимостями с подробными пояснениями. Внесенные в таблицы данные, должны быть отражены на графиках. Рекомендуется использовать режим графического наложения результатов моделирования при изменении знака и точки ввода воздействий.

4.2. Сравнить экспериментальные значения коэффициентов ошибки с расчетными.

4.3. В основе функций цены для итерационного процесса оптимизации должны быть: интегральная оценка качества; улучшенная интегральная оценка; и оценка дополнительно использующая параметры переходного процесса - перерегулирование или количество колебаний. Сравнить эффективность оценок, качественно характеризуя принципиально достижимые результаты.

4.4. Показатели качества найденные в пп. 3.5 и 3.7, нанести на переходные характеристики h(t), АЧХ замкнутой системы |Ф(jw)|, АФХ и ЛАЧХ & ЛФЧХ разомкнутой системы соответственно. Сравнить качество настроек ПИД-регулятора в трех случаях. АЧХ замкнутой системы |Ф(jw)| - это ее ЛАЧХ, у которой ось модуля не логарифмическая (снимите соответствующую галочку в свойствах графика). При определении ЛАЧХ & ЛФЧХ разомкнутой системы следует выделить требуемые блоки структурной схемы и отметить точки входа и выхода сигнала (Select Input/Output Points).


ТАУ - РУКОВОДСТВО К ВЫПОЛНЕНИЮ ЛАБОРАТОРНЫХ РАБОТ

Лабораторная работа 6
ПОВЫШЕНИЕ ТОЧНОСТИ САР

Рабочие файлы: [1.vsm] [3.vsm] [2.vsm] [4.vsm] [5.vsm]

1. Цель работы

Освоение основных методов повышения точности САР: 1) увеличения коэффициента усиления разомкнутой цепи, 2) регулирования по производным от ошибки с увеличением контурного коэффициента усиления, 3) повышения степени астатизма, 4) применения неединичных обратных связей или масштабирующих устройств на входе / выходе, 5) введения комбинированного управления.

2. Предварительное домашнее задание

2.1. Дано пять систем. Каждая обладает совокупностью уникальных свойств (см. табл.). В работе изучается пять методов повышения точности САР. Выбрать наиболее эффективный или единственно возможный метод повышения точности для каждой САР. Выбор обосновать.

Nо | Свойства САР (состоящих из минимально фазовых звеньев) | Метод, файл
1 | САР статическая. Контурный коэффициент мал (<10). Объект и чувствительный элемент являются одним конструктивным элементом (нет возможности изменить вид ЛАЧХ прямого канала) |
 | ИЛИ: ЛАЧХ разомкнутой системы в области низких частот имеет наклон -20 или -40 дб/дек. При этом либо в измерительном канале (на входе, вне контура регулирования) неединичный коэффициент передачи, либо в цепи обратной связи установлен делитель сигнала
2 | Объект моделируется двумя звеньями: колебательным (с большим подавлением) и апериодическим. Сопрягающая частота апериодического звена на две декады меньше резонансной частоты колебательного звена |
3 | ЛАЧХ разомкнутой системы имеет вид 20-0-20-40 (участок с нулевым наклоном не продолжителен). Предъявлены требования: минимально возможное перерегулирование, и малые собственные шумы САР. В точке единичного усиления фаза, уменьшаясь, пересекает значение -90 градусов с небольшим приращением |
4 | Объект моделируется двумя звеньями: колебательным (с большим подавлением) и апериодическим. Сопрягающая частота апериодического звена на две декады больше резонансной частоты колебательного звена |
5 | ЛАЧХ разомкнутой системы в области низких частот имеет наклон 0 дб/дек. Контурный коэффициент объекта не стабилен в той же полосе частот (в области низких частот); или предъявлено требование равенства нулю первой или первой и второй составляющих ошибки |

3. Содержание работы

3.1. Ознакомиться с предложенными моделями, идентифицировать их с описаниями в таблице.

3.2. Определить цель применения изучаемых методов повышения точности для каждой модели (повышение точности в установившихся режимах, увеличение запаса устойчивости или повышение быстродействия).

3.3. Повысить точность систем в соответствии с выбранными методами.

3.4. Качественно описать результаты применения методов повышения точности. Рекомендуется использовать переходную функцию h(t). Графическую информацию удобно представить в режиме наложения (перекрытия) результатов моделирования.

3.5. Используя инструменты частотного исследования систем (ЛАЧХ & ЛФЧХ) сформулировать ограничения в применении каждого метода повышения точности.

3.6. Выполнить количественное исследование результатов применения методов повышения точности САР на основе исследований (измерений) ошибки x(t). Можно измерить значения первых установившихся составляющих ошибки по: положению q0, скорости qu, ... - до и после применения методов повышения точности. По необходимости рекомендуется использовать тест-сигналы задания g(t): единичную ступенчатую функцию 1(t), синусоидальный, меняющийся с постоянной скоростью или ускорением (см. сигнал g(t) в файле err_ast3.vsm). Для измерений ошибки рекомендуется использовать: датчики скорости и ускорения (дифференцирующие звенья), преобразователи построенные в соответствии с интегральными оценками качества, а так же измерители действующего или средневыпрямленного значений (см. файл rms_ex.vsm). Выбор схемы измерения ошибки x(t) следует обосновать.

3.7. Рассмотреть все блоки (звенья), которые применялись для повышения точности. Назвать техническое устройство их практической реализации. Рассмотрев все модифицированные модели САР, указать необходимые диапазоны для подстраиваемых параметров этого устройства.

4. Методические указания к моделированию и рекомендации к содержанию отчета

4.1. Готовые звенья для изменений в структурных схемах моделей находятся в блоке Instruments. Только требуемое звено и соответствующий регулятор настройки нужно перенести и подключить к модели. Изменения в структурных схемах отразить в отчете.

4.2. Если моделирование занимает много времени (10...20 с, VisSim 1.2), то отключите второстепенные визуализирующие приборы - такие как блок Display. Синхронный с разверткой вывод на экран информации на каждом шаге расчёта растягивает последний на 1/50 секунды.

4.3. В случае применения неединичных обратных связей или масштабирующих устройств на входе / выходе или комбинированного управления использование выходного сигнала чувствительного элемента системы (сумматора) для исследования ошибки x(t) не имеет смысла. Необходимо вычесть выходной сигнал y(t) из входного g(t) дополнительным сумматором.


ТАУ - РУКОВОДСТВО К ВЫПОЛНЕНИЮ ЛАБОРАТОРНЫХ РАБОТ

Лабораторная работа 7
КОРРЕКЦИЯ САР

Рабочие файлы: [k1.vsm] [k2.vsm] [k3.vsm] [k4.vsm]
[kor_ou3.ca4] [kor_c_in.ca4] [kor_cout.ca4] [kor_2_ou.ca4] [kor_derv.ca4]
[kor_ooc.vsm]

1. Цель работы

Освоение основных методов повышения запаса устойчивости (коррекции) САР: 1) демпфирования с подавлением высоких частот, 2) демпфирования с подавлением средних частот, 3) демпфирования с подавлением низких частот. Приобретение навыков решения типовых задач коррекции схем на операционных усилителях. Ознакомление с основными видами корректирующих обратных связей: 1) гибкими ООС, 2) жесткими ООС, 3) положительными (изодромное звено на апериодическом звене).

2. Предварительное домашнее задание

2.1. Дано четыре системы. Каждая обладает совокупностью уникальных свойств (см. табл.). Подобрать наиболее оптимальное или единственно возможное, последовательное корректирующее звено для каждой САР (апериодическое, пассивное дифференцирующее, пассивное интегрирующее, пассивное интегро-дифференцирующее). Выбор обосновать.

Nо | Свойства САР (состоящих из минимально фазовых звеньев) | метод, звено, файл
1 | ЛФЧХ разомкнутой системы чуть ниже частоты среза (в пределах декады) меняет свое значение от -90 до -270 градусов. Допустима минимально возможная потеря частотных свойств (площади ограниченной ЛАЧХ и осью частот) |
2 | ЛАЧХ разомкнутой САР соответствует трехкаскадному операционному усилителю без внутренней коррекции (звено с большим коэффициентом усиления и три апериодических звена с близкими сопрягающими частотами), и пересекает ось частот с наклоном -60 дб/дек. Допустима существенная потеря полосы пропускания |
3 | ЛФЧХ системы вплоть до частоты среза приобретает значения около -180 градусов. Для исключения условий, при которых возможно появление неустойчивости в большом, дополнительные отрицательные фазовые сдвиги не допустимы |
4 | Вблизи частоты среза и ниже по частоте более декады наклон ЛАЧХ разомкнутой системы составляет -40 дб/дек. Допустима минимально возможная потеря частотных свойств |

2.2. Составить структурную схему и построить ЛАЧХ & ЛФЧХ для передаточной функции корректирующего звена: W(p)=1/(1+T1p)+(0,1)+T2p/(1+T2p); T1=0,1; T2=0,0001. Определиться с его названием. Разобраться, какие изменения в структурной схеме звена надо сделать, чтобы получить: апериодическое, или пассивное дифференцирующее или пассивное интегрирующее звено.

3. Содержание работы

3.1. Ознакомиться с первыми четырьмя предложенными моделями систем, идентифицировать их с описаниями в таблице. Изменить параметры моделей так, чтобы их логарифмические частотные характеристики сместились вдоль частотной шкалы.

3.2. Скорректировать системы в соответствии с выбранными методами (ввести соответствующие корректирующие звенья в контур и настроить их, добиваясь устойчивости в замкнутом состоянии).

3.3. Дать количественную характеристику результатам коррекции, оценивая: полученный запас устойчивости (L & m или M), потери точности (K или Ku или Ke), и уменьшение быстродействия (wП, wС).

3.4. По указанию преподавателя, для одной из исследуемых моделей составить подобную на операционных усилителях в пакете Electronics Workbench.

3.5. Изучить модели *.ca4, в которых рассмотрены стандартные задачи коррекции схем на операционных усилителях. Описать суть способов коррекции. Дать количественную характеристику результатам, оценивая их аналогично пп. 3.3.

3.6. В соответствии с вариантом (см. табл.), составить подобную схеме на операционном усилителе модель из блоков пакета VisSim.

Вариант, модель | Описание типовых задач коррекции схем на ОУ
1 kor_ou3.ca4 | Выходное сопротивление ОУ и паразитная емкость монтажа выходных цепей образуют третий полюс ЛАЧХ, ведущий к неустойчивости. Модель можно рассматривать как схему на трехкаскадном ОУ без или с частичной внутренней коррекцией
2 kor_c_in.ca4 | Паразитная емкость монтажа входных цепей ОУ и большое сопротивление обратной связи образуют апериодическое звено первого порядка, которое может привести к неустойчивости схем на ОУ
3 kor_cout.ca4 | Необходимость работы ОУ на емкостную нагрузку приводит к тому, что выходное сопротивление ОУ и емкость нагрузки образуют третий полюс ЛАЧХ, ведущий к неустойчивости. Малое сопротивление емкости нагрузки на высоких частотах может перегрузить выход ОУ
4 kor_2_ou.ca4 | Стремление получить в схемах высокую точность и быстродействие приводит к необходимости использования двух ОУ (точного и быстродействующего). Но простое последовательное включение приводит к неустойчивости схемы, поскольку минимальное фазовое запаздывание для двух, даже корректированных ОУ составляет 180 градусов
5 kor_derv.ca4 | Построение дифференциатора на ОУ вызывает затруднения: а) в петле ОС ОУ оказывается включенным апериодическое звено с большой постоянной времени, что увеличивает результирующее запаздывание по фазе свыше значения 180 градусов и приводит к неустойчивости схемы; б) входное емкостное сопротивление дифференциатора может вызвать неустойчивость и в предыдущем каскаде на ОУ; в) коэффициент усиления схемы по высокой частоте велик и это ухудшает соотношение сигнал/шум

3.7. Ознакомиться с тремя наиболее часто используемыми видами корректирующих обратных связей (файл kor_ooc.vsm). Определить, какими последовательными корректирующими звеньями можно добиться тех же результатов.

4. Методические указания к моделированию и рекомендации к содержанию отчета

4.1. Определить ЛАЧХ & ЛФЧХ разомкнутой системы в пакете VisSim можно без размыкания контура - необходимо выделить все блоки файла, а за тем отменить выделение только для источника сигнала и сумматора. Если САР неустойчива, то нужно разорвать контур. Для описанного выделения выполните два действия: а) установите мышь на свободное место и нажмите Shift+[правая клавиша мыши] (выделение всей схемы), б) повторная отметка указанной комбинацией любого элемента схемы отменит выделение для него. В некоторых случаях потребуется принудительно отметить вход и выход. Далее - стандартно.

4.2. При составлении моделей по пп. 3.4, допускается произвольная инверсия сигналов в схемах на операционных усилителях, но следует обратить внимание на результирующий фазовый сдвиг от инверсии.

4.3. Схемотехника инвертирующих включений операционных усилителей предполагает введение входного сигнала в корректирующую цепь. Если при построении моделей в пакете VisSim по пп. 3.6 это вызывает затруднения, то можно перейти к неинвертирующему включению операционного усилителя.

4.4. В пакете Electronics Workbench методика использования виртуального прибора - анализатора сильно упрощена. На практике, подобные подключения прибора не позволят снять частотную характеристику операционного усилителя с разорванной обратной связью. Дайте пояснения.

4.5. В файле kor_ooc.vsm корректирующие обратные связи должны включатся не одновременно.


ТАУ - РУКОВОДСТВО К ВЫПОЛНЕНИЮ ЛАБОРАТОРНЫХ РАБОТ

Лабораторная работа 8
СИНТЕЗ САР

Рабочие файлы: [w1.vsm] [w2.vsm]

1. Цель работы

Приобретение навыков использования метода логарифмических частотных характеристик и метода корневых годографов для синтеза САР.

2. Предварительное домашнее задание

2.1. В соответствии с вариантом (см. табл.) построить располагаемую ЛАЧХ объекта регулирования. Учитывая требования к точности и к устойчивости, нанести на график низкочастотную и высокочастотную запретные области.

Параметры

Значения

Вариант
Располагаемая передаточная функция
объекта
Wo(p) = | 100 | 1 | w1.vsm
 | 1+0,33p | p2/30002+2*0,04p/3000+1
 1, 2
Wo(p) = | 100 | 40 | 1 | w2.vsm
 | p | 1+0,0033p | p2/30002+2*0,04p/3000+1
 3, 4
Требования
к точности 		Vm =10 ед./с; Em = 100 ед./с2; Xm =0,01 ед. 1, 3
wK = 0,3 рад/с; Dj = 0,573e-3 град; d = 9e-6 % | 2, 4
к устойчивости | M < 1,16 | 1,2,3,4

2.2. Определить передаточные функции последовательных (возможно последовательно-параллельных) корректирующих устройств, которые рекомендуется разбить на типовые звенья. Составить структурную схему системы с устройствами коррекции.

3. Содержание работы

3.1. Дополнить структурные схемы в рабочих файлах рассчитанными последовательными корректирующими звеньями. Проверить, имеет ли ЛАЧХ системы желаемый вид.

3.2. Пустые блоки "1" и "2" определяют места возможного подключения средств коррекции к реальной системе. Заменить часть последовательных корректирующих устройств эквивалентной обратной связью, в соответствии с заданной структурой системы.

3.3. Точно настроить устройства коррекции и выполнить измерения, подтверждающие верность результатов синтеза, подавая тест сигналы с необходимыми параметрами.

3.4. Используя корневой годограф, определить параметр затухания z для сопряженных комплексных корней передаточной функции синтезированной системы при единичной обратной связи. А также определить во сколько раз должен увеличиться контурный коэффициент усиления (добротность по скорости), чтобы система оказалась на границе устойчивости (проверить по переходной функции).

4. Методические указания к моделированию и рекомендации к содержанию отчета

4.1. При синтезе низкочастотных корректирующих устройств следует полагать, что подъём ЛАЧХ от запретной области не допустим, по причине возможного возрастания влияния помех и наводок на входе.

4.2. При выполнении измерений, цель которых - определить точность замкнутой системы, следует подавать синусоидальные сигналы как на участках границы запретной области с разным наклоном, так и на сопрягающей частоте. Только фазовую ошибку Dj допустимо измерить, прибегая к функциям частотного анализа (необходимо задаваться очень узким частотным диапазоном).

4.3. При точной настройке системы по показателю колебательности M следует помнить, что второй пик АЧХ замкнутой системы |Ф(jw)| так же не должен достигать уровня M.

4.4. Для построения годографа корней в пакете VisSim нужно выделять разомкнутую систему W(p).

4.5. VisSim строит годограф корней - 1+KocW(p)=0 - характеристического уравнения замкнутой системы Ф(p) с варьируемым коэффициентом передачи в цепи обратной связи Koc, для выделенных блоков, которые принимает за разомкнутую систему W(p):

  1. Если Kос=0, то корни уравнения 1+KocW(p)=0 устремляются к корням-полюсам W(p), которые отмечены крестами (только при Kос=0!).
  2. Если Kос стремится к бесконечности, то часть корней уравнения 1+KocW(p)=0 устремляется к корням-нулям W(p), а часть - к бесконечности.
  3. Если Kос=1, то характеристическое уравнение соответствует единичной обратной связи.

4.6. Если уточнять координаты корней на траекториях годографов, то дополнительно будут высвечиваться три соответствующие корню параметра: 1) Koc; 2) параметр затухания - z (в программе VisSim - z); 3) угловая частота свободных колебаний - w. По значению Koc, можно оценить: при каких значениях контурного коэффициента усиления K*Kос система станет не устойчивой, а также быстродействие системы. Степень быстродействия определяется по самому ближнему к мнимой оси корню на траекториях при заданном значении Koc. Параметр затухания - z и угловую частоту свободных колебаний - w легко интерпретировать, если вспомнить, что передаточная функция замкнутой системы с комплексными корнями Ф(p) часто может быть аппроксимирована колебательным звеном.


ТАУ - РУКОВОДСТВО К ВЫПОЛНЕНИЮ ЛАБОРАТОРНЫХ РАБОТ

Лабораторная работа 10
СИСТЕМЫ С ЗАПАЗДЫВАНИЕМ

Рабочие файлы: [e^(-pt).vsm] [Вар1 e^(-pt)2.vsm] [Вар2 e^(-pt)2.vsm]
[Вар3 e^(-pt)2.vsm] [Вар4 e^(-pt)2.vsm]

1. Цель работы

Идентификация влияния временного запаздывания на устойчивость и точностные параметры систем. Ознакомление с различными моделями-аппроксиматорами звена временного запаздывания. Приобретение навыков обоснования применения моделей с допущениями.

2. Предварительное домашнее задание

2.1. Рассчитать критическое запаздывание для системы (файл e^(-pt)2.vsm) (по вариантам).

2.2. Построить асимптотические ЛАЧХ & ЛФЧХ для звена с передаточной функцией W(p)=(1-Tp)/(1+Tp).

3. Содержание работы

3.1. Ознакомиться с процессом симуляции в звене временного запаздывания, построенном на буфере (блок "timeDelay"). Изучить структурное построение двух предложенных линеаризовананных моделей-аппроксиматоров звена временного запаздывания (файл e^(-pt).vsm).

3.2. Оценить адекватность получаемых результатов при использовании каждой из трех альтернатив звена в моделях систем, если ставятся задачи: а) симуляции движения (файл e^(-pt).vsm); б) оценки точности (файл e^(-pt)2.vsm); в) оценки запаса устойчивости (файл e^(-pt)2.vsm).

4. Методические указания к моделированию и рекомендации к содержанию отчета

4.1. При использовании линеаризованных моделей-аппроксиматоров звена временного запаздывания наиболее схожими переходные процессы будут в случае использования простейших методов интегрирования - Эйлера, и трапециидального. В пакете VisSim все функции анализа для блока "timeDelay" не доступны.

4.2. Выполняя пункт 3.1, следует назвать звенья составляющие модели-аппроксиматоры звена временного запаздывания и указать, каким образом следует изменить их структуру для более точной аппроксимации.

4.3. Оценить адекватность симуляции движения (пп. 3.2.а) необходимо исходя из положений: а) сигнал на входе системы имеет широкий спектр (может меняться с большими скоростями и ускорениями); б) сигнал на входе звена, в силу инерционных свойств системы, имеет ограниченный спектр.

4.4. Оценить адекватность результатов при исследовании точностных параметров систем (пп. 3.2.б) необходимо для двух методик. Первая предполагает измерение ошибок в типовых режимах движения (см. л.р. No 5). Вторая - изучение параметров ЛАЧХ в области низких частот (см. л.р. No 8).

4.5. Оценить адекватность результатов при исследовании запасов устойчивости систем (определении критического запаздывания), (пп. 3.2.в) необходимо для двух методик. Первая предполагает подбор запаздывания при симуляции движения до получения переходного процесса соответствующего границе устойчивости. Вторая базируется на изучении частотных свойств разомкнутой системы в области частоты среза либо по ЛАЧХ & ЛФЧХ, либо по АФХ (годограф Найквиста).

4.6. Выводы по работе должны содержать рекомендации о том, каким из аналогов звена временного запаздывания наиболее целесообразно пользоваться и для каких целей.


ТАУ - РУКОВОДСТВО К ВЫПОЛНЕНИЮ ЛАБОРАТОРНЫХ РАБОТ

Лабораторная работа 12
ЦИФРОВЫЕ СИСТЕМЫ

Рабочие файлы: [Приложение 1] [Приложение 2] [Рис. 1] [Рис. 2] [err_s^-1.vsm] [k3.vsm]

1. Цель работы

Приобретение навыков составления программ для ЦВМ реализующих дискретные передаточные функции. Уяснение технических различий между непосредственным, последовательным и параллельным алгоритмами программной реализации дискретных фильтров.

2. Предварительное домашнее задание

2.1. Выбрать язык программирования для выполнения лабораторной работы - Pascal или Си++. Ознакомится с технологией создания внешних dll-моделей для моделирующей программы VisSim (см. прил. 1, 2).

2.2. Адаптировать предложенный шаблон программы для реализации рекурсивного цифрового фильтра второго порядка. По умолчанию можно выбрать произвольные значения для коэффициентов фильтра, но они должны быть доступны для изменения пользователем. Фильтр должен иметь дополнительный вход для сигнала синхронизации выполнения программы. Если номер варианта 1, 2, 5, 6, ..., то нужно воспользоваться непосредственным алгоритмом с одним буфером; если - 3, 4, 7, 8, ..., то тем же алгоритмом, но с двумя буферами (см. рис. 1, 2).

3. Содержание работы

Изучаемая методика построения цифровых регуляторов или устройств коррекции предполагает переход к дискретным реализациям от непрерывных аналогов. Нечетные варианты должны реализовать цифровой ПИД-регулятор (файл err_s^-1.vsm), четные - цифровое корректирующее устройство (файл k3.vsm). Далее по тексту для четных вариантов вместо названия "ПИД-регулятор" следует читать "корректирующее устройство".

3.1. В рабочем файле *.vsm настроить ПИД-регулятор определив качественные показатели по своему усмотрению. Изменить параметры системы так, чтобы ЛАЧХ & ЛФЧХ сместились вдоль частотной шкалы в пределах двух декад.

3.2. Заменить структурную схему ПИД-регулятора одним блоком "transferFunction" с эквивалентными параметрами. Проконтролировать неизменность переходного процесса.

3.3. Несколько раз осуществить переход от непрерывной передаточной функции ПИД-регулятора (transferFunction) к дискретной, отыскивая наибольший период дискретизации, при котором качество переходного процесса не ухудшается значительно.

3.4. Перенести коэффициенты дискретной передаточной функции регулятора в подготовленный текст программы, выполнить её компиляцию и подключить полученную динамически загружаемую библиотеку (файл *.dll) к рабочему файлу посредствам блока "userFunction". Убедиться в схожести переходного процесса.

3.5. Разложить дискретную передаточную функцию регулятора на множители и на элементарные дроби, для написания разделённых программ в соответствии с последовательным и параллельным алгоритмами. В соответствии с этими алгоритмами в рабочем файле регулятор должен состоять из блоков "userFunction" включенных последовательно или параллельно.

4. Методические указания к моделированию и рекомендации к содержанию отчета

4.1. При выполнении работы рекомендуется использовать простейший метод интегрирования - Эйлера.

4.2. При настройке ПИД-регулятора рекомендуется убедиться в отсутствии комплексных нулей у его передаточной функции. Если таковые имеются, следует поднять коэффициент в пропорциональном канале.

4.3. Получить коэффициенты полиномов числителя и знаменателя, а также значения их корней для выделенной части структурной схемы можно воспользовавшись пунктами меню "Analyze", "Transfer Function Info".

4.4. Для осуществления перехода от непрерывной передаточной функции к дискретной, на вкладке свойств блока "transferFunction" следует нажать кнопку "Convert S->Z" и ввести период дискретизации больший, чем шаг моделирования.

4.5. При манипуляциях с коэффициентами полиномов числителя и знаменателя дискретных фильтров следует воздержаться от округлений - переход от изображения Лапласа к Z-изображению описывается свертыванием правой полуплоскости "устойчивых" корней в несравнимо малую окружность единичного радиуса, т.е. точность позиционирования корня должна быть эквивалентно выше.

4.6. Разложение на множители и на элементарные дроби не обязательно выполнять для дискретной передаточной функции, можно выполнить его и для непрерывной, а потом уже перейти к дискретным фильтрам первого порядка. При этом возможности пакета VisSim освобождают от расчетов.

4.7. Для выявления других технических особенностей каждого из трех алгоритмов следует попытаться идентифицировать частотные свойства для разделенных блоков, составляющих ПИД-регулятор (см. пп. 3.5) и выявить параметры, которые отвечают за его настройки.


ЛИТЕРАТУРА

  1. Бесекерский В.А., Попов Е.П. Теория систем автоматического регулирования. - М.: Наука, 1975.
  2. Лукас В. А. Теория автоматического управления. – М.: Недра, 1990. – 416 с.
  3. Брюханов В. Н. и др. Теория автоматического управления. –М: Высшая школа, 2000 г.
  4. Острём К., Виттенмарк Б. Системы управления с ЭВМ: Пер. с англ. - М.: Мир, 1987. - 480 с., ил.
  5. Оппенгейм Э., Шафер Р. Цифровая обработка сигналов/ Пер. с англ./ Под ред. С. Я. Шаца. - М.: Связь, 1979. - 416 с.
  6. Антонью А. Цифровые фильтры: анализ и проектирование/ Пер. с англ. - М.: Радио и связь, 1983. - 320 с.
  7. Гольденберг Л. М., Матюшкин Б. Д., Поляк М. Н. Цифровая обработка сигналов: Справочник. - М.: Радио и связь, 1985. -312 с., ил.
  8. Дженкинс Г., Ваттс Д. Спектральный анализ и его приложения: В 2 т./ Пер. с англ. Ф. М. Писаренко с предисловием А. М. Яглома - М.: Мир, 1971.
  9. Сборник задач по теории автоматического регулирования и управления/ Под редакцией В. А. Бесекерского. - M.: Наука, 1978.
  10. Бронштейн И.Н., Семендяев К.Н. Справочник по математике для инженеров и учащихся вузов. - М.: Наука,1986.
  11. Титце У., Шенк К. Полупроводниковая схемотехника: Справочное руководство/ Пер. с нем. - М.: Мир, 1982.
  12. Хоровиц П., Хилл У. Искусство схемотехники: В 3 т./ Пер. с англ. - М.: Мир, 1993


Рабочая программа дисциплины ТАУ

Для написания собственной рабочей программы Вам следует сохранить архив rp_tau.zip на своем диске, разархивировать содержащийся в нем документ программы MS Word. Внести требуемые изменения и распечатать.

Предлагаемый макет программы не содержит информацию для служебного пользования (билеты к экзамену, и пр.), поскольку предполагается передача учебно-методического комплекса в данной комплектации студентам.


Вопросы к экзамену по ТАУ

Клиначёв Николай Васильевич

Вопросы к экзамену по курсу ТАУ

Примеры автоматических систем. Принципы автоматического регулирования. Классификация автоматических систем. Программы и законы регулирования. Демонстрационные примеры адаптивных систем.

Линеаризация дифференциальных уравнений (ДУ) систем автоматического регулирования (САР). Геометрическая трактовка линеаризации. Формы записи линеаризованных уравнений. Единичная функция, дельта-функция, переходная функция и функция веса. Частотная передаточная функция (ПФ), частотные характеристики. Позиционные звенья. Интегрирующие звенья. Дифференцирующие звенья. Составление исходных ДУ САР (форма Коши; решенные относительно: ошибки, относительно регулируемой величины). ПФ используемые для описания систем (W(p), Wf(p), Ф(p), Фх(p)). Линейные непрерывные законы регулирования (пропорциональное регулирование, интегральное регулирование, изодромное регулирование, регулирование с использованием производных).

Понятие устойчивости для линейных САР. Условия устойчивости, типы границы устойчивости. Необходимое условие устойчивости САР, достаточное для систем 1-ого и 2-ого порядков. Критерий устойчивости Гурвица. Критерий устойчивости Михайлова. Свойства, примеры годографов Михайлова. Построение областей устойчивости D-разбиение. Критерий устойчивости Найквиста. Свойства, примеры годографов Найквиста. Определение устойчивости по ЛАЧХ & ЛФЧХ. Методика построения асимптотических ЛАЧХ & ЛФЧХ линейных систем.

Основные подходы к оценке качества систем и общие понятия о соответствующих критериях. Точность САР в типовых режимах. Коэффициенты ошибок. Оценка запаса устойчивости и быстродействия по переходной характеристике. Корневые методы оценки качества (колебательность, степень быстродействия). Понятие о среднегеометрическом корне. Мажоранта и миноранта переходного процесса. Интегральные оценки качества (линейная, квадратичная, улучшенная). Частотные критерии качества. Показатель колебательности.

Постановка задачи повышения точности систем, обзор используемых методов. Увеличение коэффициента усиления разомкнутой цепи, как метод повышения точности. Повышение степени астатизма, как метод повышения точности. Применение регулирования по производным, как метод повышения точности. Комбинированное управление. Введение неединичных обратных связей.

Постановка задачи коррекции систем, обзор используемых методов. Способы введения корректирующих звеньев. Практическая реализация последовательных корректирующих звеньев. Демпфирование с подавлением высоких частот. Демпфирование с подавлением средних частот. Демпфирование с подавлением низких частот или эквивалентным поднятием высоких. Демпфирование с введением отрицательных фазовых сдвигов. Применение корректирующих обратных связей.

Постановка задачи синтеза систем, обзор используемых методов. Метод логарифмических амплитудных характеристик. Требования к низкочастотной части (НЧ) желаемой ЛАЧХ. Построение НЧ части желаемой ЛАЧХ. Требования к высокочастотной части (ВЧ) желаемой ЛАЧХ. Построение ВЧ части желаемой ЛАЧХ. Корневой метод синтеза. Метод корневых годографов.

Системы с переменными (var) параметрами и их реакции на стандартные возмущения 1(t) и d(t). Отыскание ПФ систем с var-параметрами. Устойчивость и качество регулирования систем с var-параметрами. Синтез параметрических систем.

Системы с запаздыванием; ПФ звена чистого запаздывания. Линеаризованные аппроксиматоры звена времянного запаздывания, вопросы адекватности. Устойчивость и качество регулирования систем с запаздыванием.

Импульсные системы; виды модуляции. Типовая структура импульсной системы. Решетчатые функции. Математические операции с решетчатыми функциями. Разностные уравнения. Z-преобразование. Математическая модель реального импульсного элемента. Понятие дискретной ПФ. Правила преобразования структурных схем дискретных систем. ПФ системы с экстраполятором нулевого порядка и звеном запаздывания. ПФ системы с экстраполятором, осуществляющим АМ первого и второго рода. ПФ замкнутой дискретной системы (для регулируемой координаты, для ошибки, для возмущений). Дискретная синусоидальная последовательность, теорема Котельникова, частота Найквиста. Частотные ПФ импульсных систем. Устойчивость и качество импульсных систем. W-преобразование.

Системы с ЦВМ, общие понятия. Процессы, протекающие в системах с ЦВМ. Методика вывода дискретных ПФ. О синтезе систем с ЦВМ методом логарифмических амплитудных характеристик. Дискретная коррекция. Дискретное представление непрерывных регуляторов. Модифицированные законы регулирования. Алгоритмы составления программ, реализующих ПФ на ЦВМ. Примеры составления программ для ЦВМ.


Вопросы к экзамену по ТАУ

Клиначёв Николай Васильевич

Билеты-задачи по ТАУ к государственному экзамену

Задача № 1 ТАУ

Выбрать оптимальный метод и повысить точность системы, если известна её частотная характеристика в разомкнутом состоянии (система имеет единичную обратную связь (ОС)).

Совокупность возможных методов повышения точности ограничена требованием сохранить линейность системы. Решение задачи должно быть выполнено (подтверждено моделированием) системы в пакете VisSim. Блок-схему (модель) системы составить и сдать комиссии до подхода к ЭВМ.

Задача № 2 ТАУ

Выбрать оптимальный метод, и выполнить коррекцию системы, модель которой изображена на рисунке.

Совокупность возможных методов коррекции ограничена требованием сохранить линейность системы. Решение задачи должно быть выполнено (подтверждено моделированием) системы в пакете VisSim. Асимптотические ЛАЧХ & ЛФЧХ построить и сдать комиссии, указав название метода коррекции, до подхода к ЭВМ.

Задача № 3 ТАУ

Указать настройки ПИД-регулятора, формирующего управляющее воздействие на объект, передаточная функция которого изображена на рисунке (система имеет единичную ОС). Требования к точности системы: Vm=10ед./с; Em=100ед./с2; Xm=0,01ед. Требование к устойчивости: M < 1,16.

Решение задачи должно быть выполнено (подтверждено моделированием) системы в пакете VisSim. Фрагменты ЛАЧХ & ЛФЧХ, удовлетворяющие предъявленным к системе требованиям построить и сдать комиссии до подхода к ЭВМ.

Задача № 4 ТАУ

Выполнить проектирование дискретной коррекции для замкнутой системы с единичной ОС, чьи ЛАЧХ & ЛФЧХ для разомкнутого состояния и ПФ непрерывного корректирующего устройства приведены на рисунках. Дискретное корректирующее устройство должно быть представлено в виде блок-схемы на регистрах задержки (предъявлять текст программы необязательно).

Решение задачи должно быть выполнено (подтверждено моделированием) системы в пакете VisSim. ЛАЧХ & ЛФЧХ разомкнутой, некорректированной системы, а так же ее блок-схему построить и сдать комиссии до подхода к ЭВМ.

Задача № 5 ТАУ

Определить запасы устойчивости по амплитуде и фазе для системы изображенной на рисунке. Найти выражение для ошибки системы x(t) в установившемся режиме работы при заданном входном сигнале.

Решение задачи должно быть выполнено (подтверждено моделированием) системы в пакете VisSim. До подхода к ЭВМ предъявить комиссии асимптотические ЛАЧХ & ЛФЧХ разомкнутой системы, выражение для сигнала задания g(t) и значения первых трех коэффициентов ошибок замкнутой системы.


Каталог ссылок - Симуляция движения (моделирование)

Интерактивный каталог ссылок

(Каталог виден только при наличии подключения к Интернету)


e-Группa "Симуляция движения (моделирование)"

VisSim.nm.ru & VisSim.com

Приглашение к членству в дискуссионной группе
"Симуляция движения (моделирование)"

Уважаемые коллеги - это приглашение вступить в почтовую дискуссионную группу (форум-рассылка). Вам не требуется подключаться к серверу новостей. Необходимо иметь только почтовый (e-mail) адрес. Ваши сообщения, посланные по адресу vissim@yahoogroups.com будут получать ведущие специалисты России в области моделирования, и вы получите ответы на свои вопросы.

Дискуссии в группе связаны с использованием специализированных пакетов - VisSim, Simulink (MATLAB), SystemBuild (MATRIXx), Anylogic (Model Vision Studium), MBTY, 20-sim, ITI-SIM, DyMoLa, SIMPLORER (+hAMSter), DYNAST, Easy5, DASE и т.д. (см. выпадающие меню справа). В нашем архиве вы найдете интересные модели.

Model & Sim & WebSim

Electro CAD's

Ключевые слова для обсуждаемых тем: симуляция движения, моделирование, управление; системы (объекты) линейные, нелинейные, непрерывные, дискретные, гибридные; инструменты частотные, корневые, вариационные, нейронные, компилирующие, оценки качества, устойчивости, быстродействия, синтеза, коррекции, оптимизации, линеаризации, программирования цифровых сигнальных процессоров - DSP, отладки в контуре модели реальных объектов.

АДРЕСНАЯ ИНФОРМАЦИЯ ДЛЯ УПРАВЛЕНИЯ ПОДПИСКОЙ (команды почтовому роботу)
Подписка (вступление в группу): vissim-subscribe@yahoogroups.com | пустое письмо
Почтовое сообщение ко всем членам (доступно только члену группы): vissim@yahoogroups.com |
Прекращение членства: vissim-unsubscribe@yahoogroups.com | пустое письмо
Письмо ведущему: vissim-owner@yahoogroups.com |
Приостановка подписки (вы ушли в отпуск): vissim-nomail@yahoogroups.com | пустое письмо
Переход в режим дайджеста (удобен для наблюдателей): vissim-digest@yahoogroups.com | пустое письмо
Возврат в нормальный режим: vissim-normal@yahoogroups.com | пустое письмо
Изменение почтовых настроек: http://groups.yahoo.com/mygroups |
Адрес группы: http://groups.yahoo.com/group/vissim |

Ели для подписки вы используете почту, то обратите внимание, что вам будет прислано почтовым роботом письмо на английском языке, с просьбой подтвердить подписку. Его достаточно просто вернуть адресату (роботу). Это подтвердит ваше согласие. Если у вас нет возможности отправить письмо, т.е. вы за чужим компьютером - воспользуйтесь желтой формой, которая приведена ниже.

По адресу группы имеются дополнительные возможности:

  • В архив доступный членам группы можно положить свою интересную модель.
  • Вы найдете коллекцию интересных нашей группе ссылок и внесете свои.
  • Можете инициировать голосование и принять в нем участие.
  • Можете обсудить вопросы в тематическом web-форуме.
  • Составить краткую справку о себе для членов группы.
  • Настроить способ получения почты.
Online подписка на VisSim
Сервис groups.yahoo.com

Более 650 российских специалистов в области АСУ ТП уже выбрали подобный инструмент общения (asutp-subscribe@yahoogroups.com), оценив этот сервис выше услуг серверов новостей (группа news:fido7.ru.scada SCADA - системы автоматизации). Есть группа, обсуждающая вопросы использования в России программной и аппаратной продукции корпорации National Instruments (LabVIEW_ru-subscribe@yahoogroups.com).

19.10.2000


Клиначёв Николай Васильевич

Клиначёв Николай Васильевич Клиначёв Николай Васильевич,
к.т.н., доцент кафедр "Электротехника" и "Информатика" ЮУрГУ
т.р. (3512)67-90-14, т.д. (3512)34-71-62; <klinacherv_nv@mail.ru>

Основные преподаваемые дисциплины:

1) "Электротехника и электроника",
2) "Электрические и электронные аппараты",
3) "Управление техническими системами",
4) "Математические основы ТАУ",
5) "Аналоговые и аналогово-цифровые интегральные микросхемы",
6) "Информатика".

Специальность: Системы обработки информации и управления

Сфера профессиональных интересов:

Все уровни разработки любой электроники любыми методами на любой элементной базе. Программирование: C++, Pascal, Java, VB, JavaScript, HTML, ассемблеры, эмуляторы, отладчики; интегрированные среды разработки IDE; CAE/CAD системы, EDA/PCB инструменты; пакеты симулирующие движение; SCADA пакеты. Педагогическая деятельность.

Принимал участие в разработке следующих проектов:

  1. Генератор сигналов произвольной формы.
  2. Измерительный комплекс для снятия АФЧХ систем.
  3. Имитатор солнечной батареи - DC/DC (для замещения последней в наземных условиях).
  4. Прибор для измерения контактного сопротивления.
  5. Прибор для измерения удельного сопротивления углеграфитовых изделий.
  6. Прибор для измерения активного сопротивления обмоток электрических машин большой мощности.

Личные проекты:

  1. Cервер "VisSim в России".
  2. Сервер "LabVIEW в России".
  3. Система "ИНТЕРНЕТ-КОЛЛОКВИУМ".
  4. Библиотека измерений ЧХ систем для пакета VisSim.

Методическая работа:

  1. Сервер кафедры "Электротехника".
  2. Выполнение обязанностей модератора почтовых дискуссионных групп и одноименных форумов:
    е-группа "Цифровая обработка сигналов в LabVIEW" (пустое письмо для подписки или ...)
    е-группа "Симуляция движения и моделирование САУ в VisSim-е" (пустое письмо для подписки или...)

Публикации (методические):

  1. Клиначёв Н. В. Электротехника: Контрольно-тестирующая система. - Offline версия 3.0. - Челябинск, 1999. - 671 файл, ил.
  2. Клиначёв Н.В. Моделирование обыкновенных линейных систем. ТАУ, Электроника: Руководство к лабораторным работам в пакетах VisSim и Electronics Workbench. - Челябинск, 2001. (дополнительный адрес).
  3. Клиначёв Н. В. Теория систем автоматического регулирования и управления: Контрольно-тестирующая система. - Offline версия 3.0. - Челябинск, 2001. - 101 файл, ил.
  4. Клиначёв Н. В. Моделирование систем в программе VisSim: Справочная система. - Online версия 1.0. - Челябинск, 2001. - 214 файлов, ил. (архив Offline версии - vsmhlpru.chm).
  5. Литюга А. М., Клиначёв Н. В., Мазуров В. М. Теоретические основы построения эффективных АСУ ТП: Конспект лекций. - Offline версия 1.0. - Тула, Челябинск, 2002. - 693 файла, ил.
  6. Неизвестный автор и Клиначёв Н. В. LabVIEW в упражнениях: Учебное пособие. - Offline версия 1.0. - Челябинск, 2001. - 212 файлов, ил.
  7. Федосов Б. Т., Клиначёв Н. В. Теория систем автоматического регулирования: Руководство к выполнению лабораторных работ. - Offline версия 1.0 для заочного обучения. - Рудный, Челябинск, 2002. - 66 файлов, ил.
  8. Клиначёв Н. В. Теория систем автоматического регулирования и управления: Учебно-методический комплекс. - Offline и Online версии 1.5, 1.6, 1.7. - Челябинск, 2002. - 543 файла, ил. (дополнительный адрес).

Год начала преподавательской деятельности: 1997

Рабочие языки общения: английский

Адрес: Энгельса 42-31, Челябинск, Россия, 454048


Технология создания внешних dll-моделей

Клиначёв Николай Васильевич

Технология создания внешних "dll-моделей"
для моделирующей программы VisSim

Актуальность наличия технологий решения задач моделирования, мониторинга и управления сложными технологическими объектами не вызывает сомнений. Сегодня у научных и инженерно-технических работников в наличии имеется большое количество программных продуктов в основном зарубежного производства. Полноценное их использование в силу не полной документированности или дороговизны отдельных составляющих модулей (библиотек) затруднительно. Поэтому наличие возможности самостоятельного расширения пакетов конечным пользователем всегда представляет особый интерес. "MathConnex" в пакете "Mathcad 2000", и "VisSim" - возможно наиболее известные моделирующие программы, имеющие интерфейсы для расширений.

Существуют несколько технологий расширений. Первая - внедрение ActiveX объектов других программных продуктов (см. "MathConnex"). Вторая - динамический обмен данными между программами посредством DDE или OPC серверов / клиентов. Третья - создание библиотечных модулей с новыми для пакетов процедурами и функциями. Пакет VisSim имеет все три механизма. Первые два интуитивно понятны и хорошо описаны в документации. Методика подключения внешних, динамически загружаемых библиотек - dll документирована не полностью, поэтому вызывает затруднения у пользователей, хотя способна существенно расширить возможности пакета. Пользователь сможет, используя известный ему язык программирования С, С++, Pascal (Delphi), Basic, Fortran создавать новые линейные, нелинейные, дискретные, частотно зависимые элементы, расширяя библиотеку стандартных; разрабатывать собственные процедуры и функции измерений, анализа, работы с базами данных; подключать как собственные, так и стандартные платы сбора данных (DAQ-board) или OPC сервера для исследования, мониторинга, управления внешним объектом.

Постановка задачи. Необходимо создать "dll-модель" (согласно меню VisSim-а "userFunction") (см. рис. 1), которая имеет два выхода и выполняет две операции: интегрирование и синтез синусоидальной функции. Модель должна иметь: вход для интегратора, вход для временного сигнала, и вход для передачи значения шага моделирования.

Демонстрация результатов моделирования с использованием пользовательской функции "myF", подключенной с помощью блока "userFunction" из библиотеки Project2.dll, написанной с использованием зыка программирования Pascal (Delphi)

Рис. 1

Модель должна иметь следующие начальные условия и параметры: 1) начальное значение, присваиваемое интегратору в начале моделирования, 2) амплитудное значение, 3) частоту и 4) фазу синтезируемого синусоидального сигнала. Т.е. при нажатии правой клавиши мыши на блоке "Project2.dll.myF", должно появится диалоговое окно - см. рис. 2.

Рис. 2

Все, что требуется - это написать библиотечную программу на языке Pascal в соответствии с определенными правилами, скомпилировать в файл Project2.dll (имя библиотеки значения не имеет) и подключить его к рабочему файлу пакета VisSim с помощью блока "userFunction". Для создания dll-библиотеки выбран язык Pascal (Delphi), поскольку в примерах пакета есть исходные файлы для языка С. Приведем распечатку файла Project2.dpr.

Файл: Project2.dpr

library Project2;

type
InVector = array [0..9] of Double; { тип входной переменной: входов - 10 }
OutVector = array [0..9] of Double; { тип выходной переменной: выходов - 10 }
Global = record { запись параметров, и координат "dll"-модели }
Uo : double; { Начальное условие для интегратора ID1 }
Am : double; { Амплитуда синусоиды }
freq : double; { частота синусоиды }
faza : double; { фаза синусоиды }
end;

var ID1 : double; { вспомогательные переменные "dll"-модели }

{/************ Это базовая процедура в DLL ****************************/}
{/************ Вызывается VisSim-ом на каждом шаге моделирования ******/}
procedure myF(var P:Global; var inV:InVector; var outV:OutVector); export; stdcall;
begin
{ Расчеты, выполняемые на каждом шаге моделирования }
 ID1:=ID1+inV[0]*inV[2]/2; outV[0]:=ID1; { интегрирование }
outV[1]:=P.Am*sin(2*Pi*inV[1]*P.freq+P.faza); { синтез синусоидального сигнала }
end;

{/************ Функция размещения параметров **************************/}
{/************ Вызывается VisSim-ом при создании блока ****************/}
function myFPA( var pCount:integer):Longint; export; stdcall;
begin
pCount := 4; { число первых по списку параметров записываемых в файл *.vsm }
 myFPA := sizeof(Global); { размер памяти необходимый под параметры }
end;

{/************ Процедура инициализации параметров *********************/}
{/************ Вызывается VisSim-ом после PA функции ******************/}
procedure myFPI( var P:Global ); export; stdcall;
begin
{ Инициализация параметров (координат) модели.
значения постоянных времени, напряжений, токов ...}
 P.Uo:=0;
P.Am:=10;
P.freq:=2;
P.faza:=0;
end;

{/************ Функция изменения параметров ***************************/}
{/************ Вызывается VisSim-ом при нажатии правой клавиши мыши ***/}
function myFPC( var P:Global ):Pchar; export; stdcall;
begin
{ Изменение параметров модели:
соответствующий очередности список названий параметров }
 myFPC :='Начальное условие;Am;freq;faza';{ названия могут быть любые }
end;

{/************ Процедура Simulation Start *****************************/}
{/************ Вызывается VisSim-ом на первом шаге моделирования ******/}
procedure myFSS( var P:Global; var runCount:longint); export; stdcall;
begin
{ присвоение начальных условий интеграторам:
напряжений на конденсаторах, токов в индуктивностях ...}
 ID1:=P.Uo;
end;

{/************ Процедура Simulation End *******************************/}
{/************ Вызывается VisSim-ом на последнем шаге моделирования ***/}
procedure myFSE( var P:Global; var runCount:longint); export; stdcall;
begin
{ сохранение значений интеграторов для повторного запуска
при многоэтапном моделировании:
напряжений на конденсаторах, токов в индуктивностях ...}
end;

exports
myF index 1,{ Имя базовой процедуры в DLL Его нужно будет указать в блоке userFunction }
myFPA index 2,{ Список вспомогательных процедур и функций для экспорта. Они будут }
myFPI index 3,{ вызываться Vissim-ом по окончаниям PA,PI,PC,SS,SE для базового имени. }
myFPC index 4,
myFSS index 5,
myFSE index 6;

begin
end.

По тексту программы видно, что для базовой функции (процедуры) с именем "myF" пользователь должен написать минимум еще пять процедур и функций, назначение которых ясно из комментариев. Следует отметить, что откомпилированная, тридцатидвухразрядная библиотека подключается ко всем версиям пакета VisSim начиная со 2-ой (текущая 4.5 Beta).

К сожалению VisSim не создает экземпляров dll-библиотек, поэтому повторное использование dll-библиотеки требует размножения файла *.dll (*.dll, *1.dll, *2.dll, ...). Этот прием демонстрирует модель сигма-дельта аналогово-цифрового преобразователя (см. в архиве (files) дискуссионной e-группы). Цифровой фильтр модели состоит из трех одинаковых звеньев. Одно звено это одна dll-библиотека.

Любой из частотных анализов неприменим для dll-библиотек. Поскольку VisSim не производит виртуальных измерений, а анализирует модели используя передаточные функции.

При написании dll-библиотек пользователю предоставляется еще две, интересные возможности. Первая заключена в использовании глобальных переменных и процедур непосредственно файла Vissim32.exe, что избавляет от необходимости передавать в и из "dll-модели" пользователя переменные и сигналы "шаг моделирования", "время моделирования", "остановить моделирование", "ошибка в dll-модели". Вторая заключена в направлении потока событий (Event) в "dll-модель", что позволяет пользовательской модели реагировать как на события стандартных устройств ввода / вывода: клавиатуры, мыши, так и на события пакета VisSim: "получить имя модели", "получить описание параметров", "установить локальный временной шаг моделирования", "выполнить пред-моделирование", "выполнить пост-моделирование", и т.д.

25.08.2000


Типовые динамические звенья

Южно-Уральский государственный университет
кафедра Электротехника

Предмет: ТАУ
Тема: Типовые звенья

для активизации программы
нажимайте цифры внизу

h(t)

Разработчики:

Клиначёв Николай Васильевич
e-mail: klinacherv_nv@mail.ru


Идентифицируйте частотные свойства безинерционного звена.

ЛАЧХ & ЛФЧХ


Идентифицируйте частотные свойства апериодического звена первого порядка.

ЛАЧХ & ЛФЧХ


Идентифицируйте частотные свойства апериодического звена второго порядка с не равными постоянными времени.

ЛАЧХ & ЛФЧХ


Идентифицируйте частотные свойства апериодического звена второго порядка с равными постоянными времени.

ЛАЧХ & ЛФЧХ


Идентифицируйте частотные свойства колебательного звена.

ЛАЧХ & ЛФЧХ


Идентифицируйте частотные свойства консервативного звена.

ЛАЧХ & ЛФЧХ


Идентифицируйте частотные свойства интегрирующего звена.

ЛАЧХ & ЛФЧХ


Идентифицируйте частотные свойства интегрирующего звена с замедлением.

ЛАЧХ & ЛФЧХ


Идентифицируйте частотные свойства изодромного звена.

ЛАЧХ & ЛФЧХ


Идентифицируйте частотные свойства дифференцирующего звена.

ЛАЧХ & ЛФЧХ


Идентифицируйте частотные свойства дифференцирующего звена с замедлением.

ЛАЧХ & ЛФЧХ


Идентифицируйте переходную функцию безинерционного звена
(при отсутствии таковой нажмите цифру 9).

Переходные функции h(t) типовых динамических звеньев
входное воздействие было задержано на 0,001 с


Идентифицируйте переходную функцию апериодического звена первого порядка
(при отсутствии таковой нажмите цифру 9).

Переходные функции h(t) типовых динамических звеньев
входное воздействие было задержано на 0,001 с


Идентифицируйте переходную функцию апериодического звена второго порядка
(при отсутствии таковой нажмите цифру 9).

Переходные функции h(t) типовых динамических звеньев
входное воздействие было задержано на 0,001 с


Идентифицируйте переходную функцию колебательного звена
(при отсутствии таковой нажмите цифру 9).

Переходные функции h(t) типовых динамических звеньев
входное воздействие было задержано на 0,001 с


Идентифицируйте переходную функцию консервативного звена
(при отсутствии таковой нажмите цифру 9).

Переходные функции h(t) типовых динамических звеньев
входное воздействие было задержано на 0,001 с


Идентифицируйте переходную функцию интегрирующего звена
(при отсутствии таковой нажмите цифру 9).

Переходные функции h(t) типовых динамических звеньев
входное воздействие было задержано на 0,001 с


Идентифицируйте переходную функцию интегрирующего звена с замедлением
(при отсутствии таковой нажмите цифру 9).

Переходные функции h(t) типовых динамических звеньев
входное воздействие было задержано на 0,001 с


Идентифицируйте переходную функцию изодромного звена
(при отсутствии таковой нажмите цифру 9).

Переходные функции h(t) типовых динамических звеньев
входное воздействие было задержано на 0,001 с


Идентифицируйте переходную функцию дифференцирующего звена
(при отсутствии таковой нажмите цифру 9).

Переходные функции h(t) типовых динамических звеньев
входное воздействие было задержано на 0,001 с


Идентифицируйте переходную функцию дифференцирующего звена с замедлением
(при отсутствии таковой нажмите цифру 9).

Переходные функции h(t) типовых динамических звеньев
входное воздействие было задержано на 0,001 с


Укажите передаточную функцию безинерционного звена.

1) W(p) = K
1+Tp
5) W(p) = K
1+T2p2
8) W(p) = K(1+Tp)
p
2) W(p) = K
(1+T3p)(1+T4p)
6) W(p) = K
p
9) W(p) = Kp

3) W(p) =

K
1+2Tp+T2p2
7) W(p) = K
p(1+Tp)
10) W(p) = Kp
(1+Tp)

4) W(p) =

K ; где: 0 < e < 1
1+2e Tp+T2p2
11) W(p) = K


Укажите передаточную функцию апериодического звена первого порядка.

1) W(p) = K
1+Tp
5) W(p) = K
1+T2p2
8) W(p) = K(1+Tp)
p
2) W(p) = K
(1+T3p)(1+T4p)
6) W(p) = K
p
9) W(p) = Kp

3) W(p) =

K
1+2Tp+T2p2
7) W(p) = K
p(1+Tp)
10) W(p) = Kp
(1+Tp)

4) W(p) =

K ; где: 0 < e < 1
1+2e Tp+T2p2
11) W(p) = K


Укажите передаточную функцию апериодического звена второго порядка с не равными постоянными времени.

1) W(p) = K
1+Tp
5) W(p) = K
1+T2p2
8) W(p) = K(1+Tp)
p
2) W(p) = K
(1+T3p)(1+T4p)
6) W(p) = K
p
9) W(p) = Kp

3) W(p) =

K
1+2Tp+T2p2
7) W(p) = K
p(1+Tp)
10) W(p) = Kp
(1+Tp)

4) W(p) =

K ; где: 0 < e < 1
1+2e Tp+T2p2
11) W(p) = K


Укажите передаточную функцию апериодического звена второго порядка с равными постоянными времени.

1) W(p) = K
1+Tp
5) W(p) = K
1+T2p2
8) W(p) = K(1+Tp)
p
2) W(p) = K
(1+T3p)(1+T4p)
6) W(p) = K
p
9) W(p) = Kp

3) W(p) =

K
1+2Tp+T2p2
7) W(p) = K
p(1+Tp)
10) W(p) = Kp
(1+Tp)

4) W(p) =

K ; где: 0 < e < 1
1+2e Tp+T2p2
11) W(p) = K


Укажите передаточную функцию колебательного звена.

1) W(p) = K
1+Tp
5) W(p) = K
1+T2p2
8) W(p) = K(1+Tp)
p
2) W(p) = K
(1+T3p)(1+T4p)
6) W(p) = K
p
9) W(p) = Kp

3) W(p) =

K
1+2Tp+T2p2
7) W(p) = K
p(1+Tp)
10) W(p) = Kp
(1+Tp)

4) W(p) =

K ; где: 0 < e < 1
1+2e Tp+T2p2
11) W(p) = K


Укажите передаточную функцию консервативного звена.

1) W(p) = K
1+Tp
5) W(p) = K
1+T2p2
8) W(p) = K(1+Tp)
p
2) W(p) = K
(1+T3p)(1+T4p)
6) W(p) = K
p
9) W(p) = Kp

3) W(p) =

K
1+2Tp+T2p2
7) W(p) = K
p(1+Tp)
10) W(p) = Kp
(1+Tp)

4) W(p) =

K ; где: 0 < e < 1
1+2e Tp+T2p2
11) W(p) = K


Укажите передаточную функцию интегрирующего звена.

1) W(p) = K
1+Tp
5) W(p) = K
1+T2p2
8) W(p) = K(1+Tp)
p
2) W(p) = K
(1+T3p)(1+T4p)
6) W(p) = K
p
9) W(p) = Kp

3) W(p) =

K
1+2Tp+T2p2
7) W(p) = K
p(1+Tp)
10) W(p) = Kp
(1+Tp)

4) W(p) =

K ; где: 0 < e < 1
1+2e Tp+T2p2
11) W(p) = K


Укажите передаточную функцию интегрирующего звена с замедлением.

1) W(p) = K
1+Tp
5) W(p) = K
1+T2p2
8) W(p) = K(1+Tp)
p
2) W(p) = K
(1+T3p)(1+T4p)
6) W(p) = K
p
9) W(p) = Kp

3) W(p) =

K
1+2Tp+T2p2
7) W(p) = K
p(1+Tp)
10) W(p) = Kp
(1+Tp)

4) W(p) =

K ; где: 0 < e < 1
1+2e Tp+T2p2
11) W(p) = K


Укажите передаточную функцию изодромного звена.

1) W(p) = K
1+Tp
5) W(p) = K
1+T2p2
8) W(p) = K(1+Tp)
p
2) W(p) = K
(1+T3p)(1+T4p)
6) W(p) = K
p
9) W(p) = Kp

3) W(p) =

K
1+2Tp+T2p2
7) W(p) = K
p(1+Tp)
10) W(p) = Kp
(1+Tp)

4) W(p) =

K ; где: 0 < e < 1
1+2e Tp+T2p2
11) W(p) = K


Укажите передаточную функцию дифференцирующего звена.

1) W(p) = K
1+Tp
5) W(p) = K
1+T2p2
8) W(p) = K(1+Tp)
p
2) W(p) = K
(1+T3p)(1+T4p)
6) W(p) = K
p
9) W(p) = Kp

3) W(p) =

K
1+2Tp+T2p2
7) W(p) = K
p(1+Tp)
10) W(p) = Kp
(1+Tp)

4) W(p) =

K ; где: 0 < e < 1
1+2e Tp+T2p2
11) W(p) = K


Укажите передаточную функцию дифференцирующего звена с замедлением.

1) W(p) = K
1+Tp
5) W(p) = K
1+T2p2
8) W(p) = K(1+Tp)
p
2) W(p) = K
(1+T3p)(1+T4p)
6) W(p) = K
p
9) W(p) = Kp

3) W(p) =

K
1+2Tp+T2p2
7) W(p) = K
p(1+Tp)
10) W(p) = Kp
(1+Tp)

4) W(p) =

K ; где: 0 < e < 1
1+2e Tp+T2p2
11) W(p) = K


По реакции h(t) типового динамического звена на ступенчатую функцию 1(t) можно оценить параметры его передаточной функции или частотные свойства.
Определите сопрягающую круговую частоту апериодического звена (1).

Переходные функции h(t) типовых динамических звеньев 1) 0,001
2) 0,004
3) 0,005
4) 0,01
5) 0,5
6) 1
7) 2
8) 10
9) 100
10) 200
11) 400
12) 800 Pi


По реакции h(t) типового динамического звена на ступенчатую функцию 1(t) можно оценить параметры его передаточной функции или частотные свойства.
Определите сумму постоянных времени апериодического звена второго порядка (2).

Переходные функции h(t) типовых динамических звеньев 1) 0,001
2) 0,004
3) 0,005
4) 0,01
5) 0,5
6) 1
7) 2
8) 10
9) 100
10) 200
11) 400


По реакции h(t) типового динамического звена на ступенчатую функцию 1(t) можно оценить параметры его передаточной функции или частотные свойства.
Определите круговую частоту для резонансного пика колебательного звена (3).

Переходные функции h(t) типовых динамических звеньев 1) 0,001
2) 0,004
3) 0,005
4) 0,01
5) 0,5
6) 1
7) 2
8) 10
9) 100
10) 200
11) 400
12) 400 Pi


По реакции h(t) типового динамического звена на ступенчатую функцию 1(t) можно оценить параметры его передаточной функции или частотные свойства.
Определите постоянную времени консервативного звена (4).

Переходные функции h(t) типовых динамических звеньев 1) 0,001
2) 0,004
3) 0,005
4) 0,01
5) 0,5
6) 1
7) 2
8) 10
9) 100
10) 200
11) 400
12) 1/628


По реакции h(t) типового динамического звена на ступенчатую функцию 1(t) можно оценить параметры его передаточной функции или частотные свойства.
Определите коэффициент передачи консервативного звена (4) в области низких частот.

Переходные функции h(t) типовых динамических звеньев 1) 0,001
2) 0,004
3) 0,005
4) 0,01
5) 0,5
6) 1
7) 2
8) 10
9) 100
10) 200
11) 400


По реакции h(t) типового динамического звена на ступенчатую функцию 1(t) можно оценить параметры его передаточной функции или частотные свойства.
Определите коэффициент усиления интегрирующего звена (6) или его круговую частоту при единичном коэффициенте передачи.

Переходные функции h(t) типовых динамических звеньев 1) 0,001
2) 0,004
3) 0,005
4) 0,01
5) 0,5
6) 1
7) 2
8) 10
9) 100
10) 200
11) 400


По реакции h(t) типового динамического звена на ступенчатую функцию 1(t) можно оценить параметры его передаточной функции или частотные свойства.
Определите коэффициент передачи интегрирующего звена (6) на частоте 10 рад/с.

Переходные функции h(t) типовых динамических звеньев 1) 0,001
2) 0,004
3) 0,005
4) 0,01
5) 0,5
6) 1
7) 2
8) 10
9) 100
10) 200
11) 400


По реакции h(t) типового динамического звена на ступенчатую функцию 1(t) можно оценить параметры его передаточной функции или частотные свойства.
Определите постоянную времени интегрирующего звена с замедлением (7).

Переходные функции h(t) типовых динамических звеньев 1) 0,001
2) 0,004
3) 0,005
4) 0,01
5) 0,5
6) 1
7) 2
8) 10
9) 100
10) 200
11) 400


По реакции h(t) типового динамического звена на ступенчатую функцию 1(t) можно оценить параметры его передаточной функции или частотные свойства.
Определите коэффициент передачи для горизонтального участка ЛАЧХ изодромного звена (8).

Переходные функции h(t) типовых динамических звеньев 1) 0,001
2) 0,004
3) 0,005
4) 0,01
5) 0,5
6) 1
7) 2
8) 10
9) 100
10) 200
11) 400


По реакции h(t) типового динамического звена на ступенчатую функцию 1(t) можно оценить параметры его передаточной функции или частотные свойства.
Определите постоянную времени дифференцирующего звена с замедлением (5).

Переходные функции h(t) типовых динамических звеньев 1) 0,001
2) 0,004
3) 0,005
4) 0,01
5) 0,5
6) 1
7) 2
8) 10
9) 100
10) 200
11) 400


По реакции h(t) типового динамического звена на ступенчатую функцию 1(t) можно оценить параметры его передаточной функции или частотные свойства.
Определите коэффициент передачи дифференцирующего звена с замедлением (5) в области высоких частот.

Переходные функции h(t) типовых динамических звеньев 1) 0,001
2) 0,004
3) 0,005
4) 0,01
5) 0,5
6) 1
7) 2
8) 10
9) 100
10) 200
11) 400


Укажите структурную схему безинерционного звена
(при отсутствии таковой нажмите цифру 12).

Структурные схемы типовых динамических звеньев. Остановить можно кнопкой браузера, запустить вновь - мышкой


Укажите структурную схему апериодического звена
(при отсутствии таковой нажмите цифру 12).

Структурные схемы типовых динамических звеньев. Остановить можно кнопкой браузера, запустить вновь - мышкой


Укажите структурную схему апериодического звена второго порядка
(при отсутствии таковой нажмите цифру 12).

Структурные схемы типовых динамических звеньев. Остановить можно кнопкой браузера, запустить вновь - мышкой


Укажите структурную схему апериодического звена второго порядка с равными постоянными времени
(при отсутствии таковой нажмите цифру 12).

Структурные схемы типовых динамических звеньев. Остановить можно кнопкой браузера, запустить вновь - мышкой


Укажите структурную схему колебательного звена
(при отсутствии таковой нажмите цифру 12).

Структурные схемы типовых динамических звеньев. Остановить можно кнопкой браузера, запустить вновь - мышкой


Укажите структурную схему консервативного звена
(при отсутствии таковой нажмите цифру 12).

Структурные схемы типовых динамических звеньев. Остановить можно кнопкой браузера, запустить вновь - мышкой


Укажите структурную схему интегрирующего звена
(при отсутствии таковой нажмите цифру 12).

Структурные схемы типовых динамических звеньев. Остановить можно кнопкой браузера, запустить вновь - мышкой


Укажите структурную схему интегрирующего звена с замедлением
(при отсутствии таковой нажмите цифру 12).

Структурные схемы типовых динамических звеньев. Остановить можно кнопкой браузера, запустить вновь - мышкой


Укажите структурную схему изодромного звена
(при отсутствии таковой нажмите цифру 12).

Структурные схемы типовых динамических звеньев. Остановить можно кнопкой браузера, запустить вновь - мышкой


Укажите структурную схему дифференцирующего звена, с минимально возможным замедлением при моделировании на ЦВМ
(при отсутствии таковой нажмите цифру 12).

Структурные схемы типовых динамических звеньев. Остановить можно кнопкой браузера, запустить вновь - мышкой


Укажите структурную схему дифференцирующего звена с замедлением
(при отсутствии таковой нажмите цифру 12).

Структурные схемы типовых динамических звеньев. Остановить можно кнопкой браузера, запустить вновь - мышкой


Определите коэффициент усиления апериодического звена второго порядка (3).

ЛАЧХ и ЛФЧХ типовых динамических звеньев 1) 0
2) 0,01
3) 0,0316
4) 0,1
5) 0,316
6) 1
7) 1,01
8) 3,16
9) 10
10) -> oo

остановить анимацию можно кнопкой "Stop" браузера


Определите сумму постоянных времени апериодического звена второго порядка (3).
Задумайтесь, почему этот вопрос методически несовершенен.

ЛАЧХ и ЛФЧХ типовых динамических звеньев 1) 0
2) 0,01
3) 0,0316
4) 0,1
5) 0,316
6) 1
7) 1,01
8) 3,16
9) 10
10) -> oo

остановить анимацию можно кнопкой "Stop" браузера


Определите коэффициент усиления колебательного звена (5).

ЛАЧХ и ЛФЧХ типовых динамических звеньев 1) 0
2) 0,01
3) 0,0316
4) 0,1
5) 0,316
6) 1
7) 1,01
8) 3,16
9) 10
10) -> oo

остановить анимацию можно кнопкой "Stop" браузера


Определите круговую частоту - q для резонансного пика колебательного звена (5).

ЛАЧХ и ЛФЧХ типовых динамических звеньев 1) 0
2) 0,01
3) 0,0316
4) 0,1
5) 0,316
6) 1
7) 1,01
8) 3,16
9) 10
10) -> oo

остановить анимацию можно кнопкой "Stop" браузера


Определите коэффициент усиления консервативного звена (6).

ЛАЧХ и ЛФЧХ типовых динамических звеньев 1) 0
2) 0,01
3) 0,0316
4) 0,1
5) 0,316
6) 1
7) 1,01
8) 3,16
9) 10
10) -> oo

остановить анимацию можно кнопкой "Stop" браузера


Определите коэффициент усиления изодромного звена (9) (для области интегрирования).

ЛАЧХ и ЛФЧХ типовых динамических звеньев 1) 0
2) 0,01
3) 0,0316
4) 0,1
5) 0,316
6) 1
7) 1,01
8) 3,16
9) 10
10) -> oo

остановить анимацию можно кнопкой "Stop" браузера


Определите пропорциональный коэффициент усиления изодромного звена (9).

ЛАЧХ и ЛФЧХ типовых динамических звеньев 1) 0
2) 0,01
3) 0,0316
4) 0,1
5) 0,316
6) 1
7) 1,01
8) 3,16
9) 10
10) -> oo

остановить анимацию можно кнопкой "Stop" браузера


Определите коэффициент усиления дифференцирующего звена (10).

ЛАЧХ и ЛФЧХ типовых динамических звеньев 1) 0
2) 0,01
3) 0,0316
4) 0,1
5) 0,316
6) 1
7) 1,01
8) 3,16
9) 10
10) -> oo

остановить анимацию можно кнопкой "Stop" браузера


Определите постоянную времени дифференцирующего звена с замедлением (11).

ЛАЧХ и ЛФЧХ типовых динамических звеньев 1) 0
2) 0,01
3) 0,0316
4) 0,1
5) 0,316
6) 1
7) 1,01
8) 3,16
9) 10
10) -> oo

остановить анимацию можно кнопкой "Stop" браузера


Определите коэффициент передачи дифференцирующего звена с замедлением (11) в области потери дифференцирующих свойств.

ЛАЧХ и ЛФЧХ типовых динамических звеньев 1) 0
2) 0,01
3) 0,0316
4) 0,1
5) 0,316
6) 1
7) 1,01
8) 3,16
9) 10
10) -> oo

остановить анимацию можно кнопкой "Stop" браузера


Определите коэффициент усиления дифференцирующего звена с замедлением (11) (для области дифференцирования).

ЛАЧХ и ЛФЧХ типовых динамических звеньев 1) 0
2) 0,01
3) 0,0316
4) 0,1
5) 0,316
6) 1
7) 1,01
8) 3,16
9) 10
10) -> oo

остановить анимацию можно кнопкой "Stop" браузера


Какими частотными свойствами должно обладать типовое динамическое звено, если его передаточная функция не имеет корней.

ЛАЧХ и ЛФЧХ


Какими частотными свойствами должно обладать типовое динамическое звено, если его передаточная функция имеет отрицательный вещественный корень-полюс.

ЛАЧХ и ЛФЧХ


Какими частотными свойствами должно обладать типовое динамическое звено, если его передаточная функция имеет два не равных отрицательных вещественных корня-полюса.

ЛАЧХ и ЛФЧХ


Какими частотными свойствами должно обладать типовое динамическое звено, если его передаточная функция имеет два равных отрицательных вещественных корня-полюса.

ЛАЧХ и ЛФЧХ


Какими частотными свойствами должно обладать типовое динамическое звено, если его передаточная функция имеет два сопряженных комплексных корня-полюса с отрицательной вещественной частью.

ЛАЧХ и ЛФЧХ


Какими частотными свойствами должно обладать типовое динамическое звено, если его передаточная функция имеет два сопряженных чисто мнимых корня-полюса.

ЛАЧХ и ЛФЧХ


Какими частотными свойствами должно обладать типовое динамическое звено, если его передаточная функция имеет нулевой корень-полюс.

ЛАЧХ и ЛФЧХ


Какими частотными свойствами должно обладать типовое динамическое звено, если его передаточная функция имеет нулевой и отрицательный вещественный корни-полюсы.

ЛАЧХ и ЛФЧХ


Какими частотными свойствами должно обладать типовое динамическое звено, если его передаточная функция имеет нулевой корень-полюс и отрицательный вещественный корень-ноль.

ЛАЧХ и ЛФЧХ


Какими частотными свойствами должно обладать типовое динамическое звено, если его передаточная функция имеет нулевой корень-ноль.

ЛАЧХ и ЛФЧХ


Какими частотными свойствами должно обладать типовое динамическое звено, если его передаточная функция имеет нулевой корень-ноль и отрицательный вещественный корень-полюс.

ЛАЧХ и ЛФЧХ


Технология создания тестов

Для ознакомления и перенятия технологии создания данного ресурса выполните действия:

  1. С помощью утилиты "Microsoft HTML Help Workshop" декомпилируйте данный файл на составляющие.

  2. Методом подобия, вооружившись любым HTML-редактором, измените содержание html-страниц.

Примечание 1: После декомпиляции данный ресурс полностью функционален и запускается в любом браузере.

Примечание 2: Утилиту "Microsoft HTML Help Workshop" можно закачать бесплатно с сайта корпорации Microsoft (если адрес изменится, рекомендуется искать файлы htmlhelp.exe и hhupd.exe).

Примечание 3: Ресурс полностью функционален и запускается браузером MSIE, если в адресной строке набрать: mk:@MSITStore:C:\TAU\tau_test.chm::/js/start.html - где C:\TAU\ - путь к файлу tau_test.chm.

Примечание 4: Содержимое данного ресурса является собственностью автора Клиначева Николая Васильевича и его репродуцирование (воспроизведение) любым способом без согласия автора запрещается.

Вернутся к выбору темы


< 1 > < 2 > < 3 > < 4 > < 5 > < 6 > < 7 > < 8 > < 9 > < 10 > < 11 > < 12 >


КОЛЛОКВИУМ ПО ЭЛЕКТРОТЕХНИКЕ

Результаты тестирования оцениваются следующим образом:

1. Первоначально программа задает 5 вопросов. Решение принимается в соответствии с таблицей.

Количество правильных ответов (на пять вопросов) | Оценка
5 | 5
4 | 4
3 | дополнительно задается два вопроса
2 | 2
1 | 1

2. Если на 5 вопросов студент дал 3 верных ответа - дополнительно задается 2 вопроса. В результате оценка может остаться без изменения, быть повышена или понижена на один бал.

3. Если студент неверно отвечает на три вопроса подряд - программа прекращает тестирование.

Вернутся к выбору темы


ТАУ: Контрольно-тестирующая система V 3.0

ИНТЕРНЕТ-КОЛЛОКВИУМ

681.5(07)
K493

Н.В. Клиначёв
ТАУ
Контрольно-тестирующая система

VisSim & Лабораторные по ТАУ

Offline версия 3.0
для вузов

Челябинск 2000

ТЕМЫ

1. Типовые динамические звенья
2. Законы и принципы регули-ния
3. Анализ устойчивости САР
4. Оценка качества регулирования
5. Повышение точности САР
6. Коррекция САР
7. Синтез САР

[Как сделано]
[Правила оценки знаний]

© Н.В. Клиначёв, 2000-2001. Все права защищены


ТАУ: Контрольно-тестирующая система V 3.0

УДК 681.5.01(076)
K493

Клиначёв Н. В. Теория систем автоматического регулирования и управления: Контрольно-тестирующая система. - Offline версия 3.0. - Челябинск, 2000. - 101 файл, ил.

Учебное пособие ориентированно на использование преподавателями в учебном процессе для контроля знаний студентов технических специальностей, изучающих курсы "Теория систем автоматического регулирования и управления" (ТАУ), "Моделирование систем управления" и им подобных. Для самостоятельной проверки уровня своих знаний оно рекомендуется студентам очной и заочной форм обучения.

Ил. 22, вопросов 77.

© Н.В. Клиначёв, 2000-2001. Все права защищены

Вернутся к выбору темы


Сообщение об оценке

Вы не готовы к коллоквиуму -

неверно ответили на три вопроса подряд

дальнейшее тестирование нецелесообразно


Сообщение об оценке

Вы ответили на
1


Сообщение об оценке

Вы ответили на
2


Сообщение об оценке

Вы ответили на
3


Сообщение об оценке

Вы ответили на
4


Сообщение об оценке

Вы ответили на
5